summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/butterfly/butterfly-1.4.0.ebuild')
-rw-r--r--www-apps/butterfly/butterfly-1.4.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/www-apps/butterfly/butterfly-1.4.0.ebuild b/www-apps/butterfly/butterfly-1.4.0.ebuild
new file mode 100644
index 000000000..41e80062a
--- /dev/null
+++ b/www-apps/butterfly/butterfly-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3})
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="A web terminal based on websocket and tornado"
+HOMEPAGE="http://pypi.python.org/pypi/butterfly https://github.com/paradoxxxzero/butterfly"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=www-servers/tornado-3.2[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]"