summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild')
-rw-r--r--www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild b/www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild
index 0b5bda29e..aa628acce 100644
--- a/www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild
+++ b/www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
inherit webapp depend.php
DESCRIPTION="phpMyProxy is a web-based proxy script in PHP"
@@ -10,11 +12,11 @@ HOMEPAGE="http://www.phpmyproxy.com/"
SRC_URI="http://omploader.org/vejZx/${P/-/_}.zip"
LICENSE="GPL-3"
-SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="app-arch/unzip"
+DEPEND="app-arch/unzip
+ dev-lang/php[curl]"
RDEPEND=""
S=${WORKDIR}/${P/-/_}
@@ -22,11 +24,6 @@ S=${WORKDIR}/${P/-/_}
need_php_httpd
need_httpd_cgi
-pkg_setup() {
- webapp_pkg_setup
- require_php_with_use curl
-}
-
src_install() {
webapp_src_preinst