summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libdrm_nouveau/files')
-rw-r--r--x11-libs/libdrm_nouveau/files/2.4.9-0001-nouveau-store-bo-handle-in-public-struct-in-bo_ref_.patch26
-rw-r--r--x11-libs/libdrm_nouveau/files/2.4.9-0002-nouveau-write-posting-got-lost-somewhere-bring-it.patch24
-rw-r--r--x11-libs/libdrm_nouveau/files/2.4.9-0003-libdrm-mode-align-subpixel-results.patch26
-rw-r--r--x11-libs/libdrm_nouveau/files/2.4.9-0004-intel-NULL-fake-bo-block-when-freeing-in-evict_all.patch28
-rw-r--r--x11-libs/libdrm_nouveau/files/libdrm-2.4.6-makefile.patch22
5 files changed, 104 insertions, 22 deletions
diff --git a/x11-libs/libdrm_nouveau/files/2.4.9-0001-nouveau-store-bo-handle-in-public-struct-in-bo_ref_.patch b/x11-libs/libdrm_nouveau/files/2.4.9-0001-nouveau-store-bo-handle-in-public-struct-in-bo_ref_.patch
new file mode 100644
index 000000000..a667eaed2
--- /dev/null
+++ b/x11-libs/libdrm_nouveau/files/2.4.9-0001-nouveau-store-bo-handle-in-public-struct-in-bo_ref_.patch
@@ -0,0 +1,26 @@
+From 78e753d03314e3aa92af8ec601e9dbb869a938d5 Mon Sep 17 00:00:00 2001
+From: Ben Skeggs <bskeggs@redhat.com>
+Date: Wed, 15 Apr 2009 12:44:21 +1000
+Subject: [PATCH 1/4] nouveau: store bo handle in public struct in bo_ref_handle
+
+---
+ libdrm/nouveau/nouveau_bo.c | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/libdrm/nouveau/nouveau_bo.c b/libdrm/nouveau/nouveau_bo.c
+index 023c6be..66466e3 100644
+--- a/libdrm/nouveau/nouveau_bo.c
++++ b/libdrm/nouveau/nouveau_bo.c
+@@ -404,7 +404,8 @@ nouveau_bo_handle_ref(struct nouveau_device *dev, uint32_t handle,
+ nvbo->size = req.size;
+ nvbo->handle = req.handle;
+ }
+-
++
++ nvbo->base.handle = nvbo->handle;
+ return 0;
+ }
+
+--
+1.6.2.3
+
diff --git a/x11-libs/libdrm_nouveau/files/2.4.9-0002-nouveau-write-posting-got-lost-somewhere-bring-it.patch b/x11-libs/libdrm_nouveau/files/2.4.9-0002-nouveau-write-posting-got-lost-somewhere-bring-it.patch
new file mode 100644
index 000000000..fc3c7c207
--- /dev/null
+++ b/x11-libs/libdrm_nouveau/files/2.4.9-0002-nouveau-write-posting-got-lost-somewhere-bring-it.patch
@@ -0,0 +1,24 @@
+From a1e3ab9e55047c08a4006ec389c1a99b72bc672c Mon Sep 17 00:00:00 2001
+From: Ben Skeggs <bskeggs@redhat.com>
+Date: Fri, 17 Apr 2009 09:29:19 +1000
+Subject: [PATCH 2/4] nouveau: write posting got lost somewhere, bring it back
+
+---
+ libdrm/nouveau/nouveau_dma.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/libdrm/nouveau/nouveau_dma.c b/libdrm/nouveau/nouveau_dma.c
+index 23da64b..b084f70 100644
+--- a/libdrm/nouveau/nouveau_dma.c
++++ b/libdrm/nouveau/nouveau_dma.c
+@@ -41,6 +41,7 @@ WRITE_PUT(struct nouveau_channel_priv *nvchan, uint32_t val)
+ volatile int dum;
+
+ NOUVEAU_DMA_BARRIER;
++ dum = nvchan->pushbuf[0];
+ dum = READ_GET(nvchan);
+
+ *nvchan->put = put;
+--
+1.6.2.3
+
diff --git a/x11-libs/libdrm_nouveau/files/2.4.9-0003-libdrm-mode-align-subpixel-results.patch b/x11-libs/libdrm_nouveau/files/2.4.9-0003-libdrm-mode-align-subpixel-results.patch
new file mode 100644
index 000000000..0fa468c63
--- /dev/null
+++ b/x11-libs/libdrm_nouveau/files/2.4.9-0003-libdrm-mode-align-subpixel-results.patch
@@ -0,0 +1,26 @@
+From 412d370b9ae4b2882691863a1c5e13a507574e92 Mon Sep 17 00:00:00 2001
+From: Dave Airlie <airlied@linux.ie>
+Date: Wed, 22 Apr 2009 20:25:40 +1000
+Subject: [PATCH 3/4] libdrm/mode: align subpixel results
+
+---
+ libdrm/xf86drmMode.c | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/libdrm/xf86drmMode.c b/libdrm/xf86drmMode.c
+index 872604f..ea11207 100644
+--- a/libdrm/xf86drmMode.c
++++ b/libdrm/xf86drmMode.c
+@@ -395,7 +395,8 @@ drmModeConnectorPtr drmModeGetConnector(int fd, uint32_t connector_id)
+ r->connection = conn.connection;
+ r->mmWidth = conn.mm_width;
+ r->mmHeight = conn.mm_height;
+- r->subpixel = conn.subpixel;
++ /* convert subpixel from kernel to userspace */
++ r->subpixel = conn.subpixel + 1;
+ r->count_modes = conn.count_modes;
+ /* TODO we should test if these alloc & cpy fails. */
+ r->count_props = conn.count_props;
+--
+1.6.2.3
+
diff --git a/x11-libs/libdrm_nouveau/files/2.4.9-0004-intel-NULL-fake-bo-block-when-freeing-in-evict_all.patch b/x11-libs/libdrm_nouveau/files/2.4.9-0004-intel-NULL-fake-bo-block-when-freeing-in-evict_all.patch
new file mode 100644
index 000000000..6a5a9a314
--- /dev/null
+++ b/x11-libs/libdrm_nouveau/files/2.4.9-0004-intel-NULL-fake-bo-block-when-freeing-in-evict_all.patch
@@ -0,0 +1,28 @@
+From 11b60973bca1bc9bbda44be4c695e22d28d8ca4a Mon Sep 17 00:00:00 2001
+From: Jesse Barnes <jbarnes@virtuousgeek.org>
+Date: Tue, 21 Apr 2009 17:13:16 -0700
+Subject: [PATCH 4/4] intel: NULL fake bo block when freeing in evict_all
+
+Fixes assertion failures on later use of the object.
+---
+ libdrm/intel/intel_bufmgr_fake.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/libdrm/intel/intel_bufmgr_fake.c b/libdrm/intel/intel_bufmgr_fake.c
+index e1f98d6..969c03d 100644
+--- a/libdrm/intel/intel_bufmgr_fake.c
++++ b/libdrm/intel/intel_bufmgr_fake.c
+@@ -1467,8 +1467,10 @@ drm_intel_bufmgr_fake_evict_all(drm_intel_bufmgr *bufmgr)
+ assert(DRMLISTEMPTY(&bufmgr_fake->on_hardware));
+
+ DRMLISTFOREACHSAFE(block, tmp, &bufmgr_fake->lru) {
++ drm_intel_bo_fake *bo_fake = (drm_intel_bo_fake *)block->bo;
+ /* Releases the memory, and memcpys dirty contents out if necessary. */
+ free_block(bufmgr_fake, block, 0);
++ bo_fake->block = NULL;
+ }
+
+ pthread_mutex_unlock(&bufmgr_fake->lock);
+--
+1.6.2.3
+
diff --git a/x11-libs/libdrm_nouveau/files/libdrm-2.4.6-makefile.patch b/x11-libs/libdrm_nouveau/files/libdrm-2.4.6-makefile.patch
deleted file mode 100644
index 61bee916c..000000000
--- a/x11-libs/libdrm_nouveau/files/libdrm-2.4.6-makefile.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 1faab66cfd1a854925da6ff7109aa614292dea90 Mon Sep 17 00:00:00 2001
-From: Dave Airlie <airlied@linux.ie>
-Date: Mon, 06 Apr 2009 23:26:32 +0000
-Subject: drm: fix test makefile
-
-no idea if this is correct but it works so meh
----
-diff --git a/tests/Makefile.am b/tests/Makefile.am
-index bc99447..e5e9fc4 100644
---- a/tests/Makefile.am
-+++ b/tests/Makefile.am
-@@ -2,6 +2,8 @@ AM_CFLAGS = \
- -I $(top_srcdir)/shared-core \
- -I $(top_srcdir)/libdrm
-
-+AM_LDFLAGS = $(top_builddir)/libdrm/libdrm.la
-+
- noinst_PROGRAMS = \
- dristat \
- drmstat
---
-cgit v0.8.2