summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/dmenu/dmenu-1.1.ebuild')
-rw-r--r--x11-misc/dmenu/dmenu-1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/dmenu/dmenu-1.1.ebuild b/x11-misc/dmenu/dmenu-1.1.ebuild
new file mode 100644
index 000000000..416066565
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://www.shortest.de/view/dynamic+window+manager"
+SRC_URI="http://www.shortest.de/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-config_mk.patch"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ dodoc README
+}