summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/dzen/dzen-0.2.4.ebuild')
-rw-r--r--x11-misc/dzen/dzen-0.2.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/dzen/dzen-0.2.4.ebuild b/x11-misc/dzen/dzen-0.2.4.ebuild
new file mode 100644
index 000000000..c06f8520a
--- /dev/null
+++ b/x11-misc/dzen/dzen-0.2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+SLOT="2"
+MY_P="${PN}${SLOT}-${PV}"
+
+DESCRIPTION="a general purpose messaging, notification and menuing program for
+X11."
+HOMEPAGE="http://gotmor.googlepages.com/dzen"
+SRC_URI="http://gotmor.googlepages.com/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xineramaproto"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:/usr/local:/usr:g" -e "s/-Os/${CFLAGS}/g" \
+ -e "s/CC =.*/CC = $(tc-getCC | sed -e 's:/:\\\/:g')/g" \
+ -e "s/LD =.*/LD = $(tc-getCC | sed -e 's:/:\\\/:g')/g" \
+ -i config.mk || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}