summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xorg-edit')
-rw-r--r--x11-misc/xorg-edit/ChangeLog4
-rw-r--r--x11-misc/xorg-edit/Manifest4
-rw-r--r--x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch62
3 files changed, 45 insertions, 25 deletions
diff --git a/x11-misc/xorg-edit/ChangeLog b/x11-misc/xorg-edit/ChangeLog
index a7882cb7b..0f7f595bd 100644
--- a/x11-misc/xorg-edit/ChangeLog
+++ b/x11-misc/xorg-edit/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Aug 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ files/xorg-edit-08.08.06-makefile.patch:
+ Make it build in parallel
+
*xorg-edit-08.08.06 (15 Aug 2009)
15 Aug 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
diff --git a/x11-misc/xorg-edit/Manifest b/x11-misc/xorg-edit/Manifest
index edd1da160..14ccdb88c 100644
--- a/x11-misc/xorg-edit/Manifest
+++ b/x11-misc/xorg-edit/Manifest
@@ -1,5 +1,5 @@
-AUX xorg-edit-08.08.06-makefile.patch 1083 RMD160 1a7248b05c8d335e34d5d17d3e1cdfe9aed0aff4 SHA1 066eb2170480c4fd9c190e33efbdb2d576a6a1a6 SHA256 d7b142d42eba9bdda3607adde44e9015380df29f659f66bab148a07e16d285a1
+AUX xorg-edit-08.08.06-makefile.patch 1468 RMD160 da084dc469e77a7ec14db9b41a1030af6f33bfc0 SHA1 fe972a5470ea7a6eb1d85cb20d143591e9901b25 SHA256 5e6ebef8d9cf5c7bbf8ba64f4178ed2dcd41b43d6e063003c617d073d167149c
DIST xorg-edit-08.08.06_src.tar.bz2 101654 RMD160 aaddf1572f817c69d282bdefa2cd005cb47b0f06 SHA1 a9ab607121f571ca2d0c18dd9090e41628eb39ac SHA256 93b189c276df9bae9d9bfbb4212a068aad53b524af6615d1dad7003ee5857967
EBUILD xorg-edit-08.08.06.ebuild 671 RMD160 ce8588a48ad61f79428bdc070a6e581a77505f5d SHA1 6a195500ba8f5364c71866d5b61d882942c2af7e SHA256 08973fe81eb6715b5ba2fafae3b3e934b4f6c74d1855fde1e18a08851c83b204
-MISC ChangeLog 1317 RMD160 4e4cbd85e982e248e97815910b6d5cc685371c69 SHA1 b61697b48b24baf7f46c5273bce19658c46e3f77 SHA256 a874e397d11f9a1fc59dea97d228f8d1a9852d24108d63718854e1194744444a
+MISC ChangeLog 1446 RMD160 6a034596a10cc15c4493cca5b7508c5924ffbc7f SHA1 27969637cefc7babc56309492a84df03d5eab309 SHA256 5f829b6582ba23d4295815bb679c3738254890fb26fa9053e8ed6550a1f2053c
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch b/x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch
index a8d1fa908..958fd32d3 100644
--- a/x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch
+++ b/x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch
@@ -1,21 +1,6 @@
---- libxorgedit/Makefile 2008-08-05 18:46:23.000000000 +0200
-+++ libxorgedit/Makefile.new 2009-08-15 17:52:26.000000000 +0200
-@@ -6,10 +6,10 @@
- OUTPUT = ../libxorgedit.a
-
- # compiler
--CXX = g++
-+CXX ?= g++
-
- # C++ compiler flags (-g -O2 -Wall)
--CXXFLAGS = -Wall -Wextra -O3
-+#CXXFLAGS = -Wall -Wextra -O3
-
- # implementation
-
--- xorgedit/Makefile 2008-08-06 20:29:54.000000000 +0200
-+++ xorgedit/Makefile.new 2009-08-15 20:11:11.000000000 +0200
-@@ -18,23 +18,23 @@
++++ xorgedit/Makefile.new 2009-08-16 12:23:56.000000000 +0200
+@@ -18,26 +18,26 @@
INCLUDES = -I../
# C++ compiler flags (-g -O2 -Wall)
@@ -27,12 +12,11 @@
+CXX ?= `wx-config --cxx`
# library paths
--LIBS = -L../ -lm -lxorgedit
-+LIBS = -L../ -lm -lxorgedit `wx-config --libs`
+ LIBS = -L../ -lm -lxorgedit
# compile flags
-LDFLAGS = `wx-config --libs`
-+#LDFLAGS = `wx-config --libs`
++WXLIBS = `wx-config --libs`
# implementation
@@ -40,7 +24,39 @@
$(OUTPUT): $(OBJECTS)
- $(CXX) -o $(OUTPUT) $(OBJECTS) $(LIBS) $(LDFLAGS)
-+ $(CXX) $(LDFLAGS) -o $(OUTPUT) $(OBJECTS) $(LIBS)
++ $(CXX) $(LDFLAGS) -o $(OUTPUT) $(OBJECTS) $(LIBS) $(WXLIBS)
+
+-$(OBJECTS): $(SOURCES)
+- $(CXX) $(INCLUDES) -c $(SOURCES) $(CXXFLAGS)
++%.o: %.c
++ $(CXX) $(INCLUDES) -c $@ $(CXXFLAGS) -o obj/$<
+
+ clean:
+ rm -f $(OBJECTS) $(OUTPUT)
+--- libxorgedit/Makefile 2008-08-05 18:46:23.000000000 +0200
++++ libxorgedit/Makefile.new 2009-08-16 12:21:32.000000000 +0200
+@@ -6,10 +6,10 @@
+ OUTPUT = ../libxorgedit.a
+
+ # compiler
+-CXX = g++
++CXX ?= g++
+
+ # C++ compiler flags (-g -O2 -Wall)
+-CXXFLAGS = -Wall -Wextra -O3
++#CXXFLAGS = -Wall -Wextra -O3
+
+ # implementation
+
+--- Makefile 2008-08-06 20:29:24.000000000 +0200
++++ Makefile.new 2009-08-16 12:53:07.000000000 +0200
+@@ -8,7 +8,8 @@
+
+ # implementation
+ all:
+- cd libxorgedit && make && cd ../xorgedit && make && cd ..
++ +make -C libxorgedit
++ +make -C xorgedit
- $(OBJECTS): $(SOURCES)
- $(CXX) $(INCLUDES) -c $(SOURCES) $(CXXFLAGS)
+ install:
+ cd libxorgedit && make && cd ../xorgedit && make install && cd ..