summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/kde-icons-dark-glass/kde-icons-dark-glass-2.5.ebuild')
-rw-r--r--x11-themes/kde-icons-dark-glass/kde-icons-dark-glass-2.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-themes/kde-icons-dark-glass/kde-icons-dark-glass-2.5.ebuild b/x11-themes/kde-icons-dark-glass/kde-icons-dark-glass-2.5.ebuild
new file mode 100644
index 000000000..a2e49002f
--- /dev/null
+++ b/x11-themes/kde-icons-dark-glass/kde-icons-dark-glass-2.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnome2-utils eutils
+
+MY_PN="${PN/kde-icons-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Glass-style icons for KDE."
+HOMEPAGE="http://www.kde-look.org/content/show.php/Dark-Glass+reviewed?content=67902"
+SRC_URI="http://dev.gentooexperimental.org/~jakub/distfiles/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="binchecks strip"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f buildset*
+ edos2unix index.desktop
+ sed -i -e '/^SmallDefault=/s:32:16:' index.desktop
+}
+
+src_compile() {
+ einfo "Nothing to compile, installing. This will take a while..."
+}
+
+src_install() {
+ insinto /usr/share/icons/${MY_PN}
+ doins -r "${S}"/*
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}