summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch')
-rw-r--r--9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch48
1 files changed, 15 insertions, 33 deletions
diff --git a/9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch b/9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch
index a724494..e054415 100644
--- a/9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch
+++ b/9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch
@@ -1,4 +1,4 @@
-From 930c326fd4f16299f06610cf3ff3ee94b13130e0 Mon Sep 17 00:00:00 2001
+From 7b47d0be518ef97bb5259a5dbb70d6b3f22011f6 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Tue, 20 Jul 2021 21:08:31 +0200
Subject: [PATCH 1/7] Gentoo: gold/ld: add support for poisoned system
@@ -33,7 +33,7 @@ Ported to binutils 2.39 by WANG Xuerui <xen0n@gentoo.org>
gold/options.cc | 33 +++++++++++++++++++++++++++++++++
gold/options.h | 7 +++++++
ld/config.in | 3 +++
- ld/configure | 20 ++++++++++++++++++--
+ ld/configure | 16 ++++++++++++++++
ld/configure.ac | 10 ++++++++++
ld/ld.h | 7 +++++++
ld/ld.texi | 18 ++++++++++++++++++
@@ -41,7 +41,7 @@ Ported to binutils 2.39 by WANG Xuerui <xen0n@gentoo.org>
ld/ldlex.h | 3 +++
ld/ldmain.c | 7 +++++++
ld/lexsup.c | 24 ++++++++++++++++++++++++
- 11 files changed, 150 insertions(+), 2 deletions(-)
+ 11 files changed, 148 insertions(+)
diff --git a/gold/options.cc b/gold/options.cc
index c9834b66159..bd3e948a61b 100644
@@ -106,7 +106,7 @@ index 46f658f23ea..8f9b8c177ad 100644
N_("Warn when skipping an incompatible library"),
N_("Don't warn when skipping an incompatible library"));
diff --git a/ld/config.in b/ld/config.in
-index ad0dc6a106c..d21edaddce7 100644
+index a453c7f7241..a0bc2a56013 100644
--- a/ld/config.in
+++ b/ld/config.in
@@ -58,6 +58,9 @@
@@ -120,10 +120,10 @@ index ad0dc6a106c..d21edaddce7 100644
#undef EXTRA_SHLIB_EXTENSION
diff --git a/ld/configure b/ld/configure
-index 0c32b16241a..549b8d49f5e 100755
+index d2cdf256b89..0f32e98bc34 100755
--- a/ld/configure
+++ b/ld/configure
-@@ -839,6 +839,7 @@ with_lib_path
+@@ -838,6 +838,7 @@ with_lib_path
enable_targets
enable_64_bit_bfd
with_sysroot
@@ -131,7 +131,7 @@ index 0c32b16241a..549b8d49f5e 100755
enable_gold
enable_got
enable_compressed_debug_sections
-@@ -1521,6 +1522,8 @@ Optional Features:
+@@ -1520,6 +1521,8 @@ Optional Features:
--enable-checking enable run-time checks
--enable-targets alternative target configurations
--enable-64-bit-bfd 64-bit support (on hosts with narrower word sizes)
@@ -140,25 +140,7 @@ index 0c32b16241a..549b8d49f5e 100755
--enable-gold[=ARG] build gold [ARG={default,yes,no}]
--enable-got=<type> GOT handling scheme (target, single, negative,
multigot)
-@@ -11625,7 +11628,7 @@ else
- lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
- lt_status=$lt_dlunknown
- cat > conftest.$ac_ext <<_LT_EOF
--#line 11628 "configure"
-+#line 11626 "configure"
- #include "confdefs.h"
-
- #if HAVE_DLFCN_H
-@@ -11731,7 +11734,7 @@ else
- lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
- lt_status=$lt_dlunknown
- cat > conftest.$ac_ext <<_LT_EOF
--#line 11734 "configure"
-+#line 11732 "configure"
- #include "confdefs.h"
-
- #if HAVE_DLFCN_H
-@@ -15483,6 +15486,19 @@ fi
+@@ -15538,6 +15541,19 @@ fi
@@ -179,7 +161,7 @@ index 0c32b16241a..549b8d49f5e 100755
if test "${enable_gold+set}" = set; then :
enableval=$enable_gold; case "${enableval}" in
diff --git a/ld/configure.ac b/ld/configure.ac
-index 77edac3258c..a74dac63038 100644
+index c3ebd3ec7e4..71790d7640f 100644
--- a/ld/configure.ac
+++ b/ld/configure.ac
@@ -103,6 +103,16 @@ AC_SUBST(use_sysroot)
@@ -218,11 +200,11 @@ index a0f8a15c7a9..69420b6673a 100644
enum endian_enum endian;
diff --git a/ld/ld.texi b/ld/ld.texi
-index aa8b1aa86eb..b57b0d5c9f5 100644
+index 1f56ded1041..1fa6bf7b225 100644
--- a/ld/ld.texi
+++ b/ld/ld.texi
-@@ -3059,6 +3059,24 @@ creation of the metadata note, if one had been enabled by an earlier
- occurrence of the --package-metdata option.
+@@ -3070,6 +3070,24 @@ creation of the metadata note, if one had been enabled by an earlier
+ occurrence of the --package-metadata option.
If the linker has been built with libjansson, then the JSON string
will be validated.
+
@@ -247,7 +229,7 @@ index aa8b1aa86eb..b57b0d5c9f5 100644
@c man end
diff --git a/ld/ldfile.c b/ld/ldfile.c
-index df7c9cbd65e..ed15262e0bc 100644
+index 8f869c1f19e..ee9d4bccee2 100644
--- a/ld/ldfile.c
+++ b/ld/ldfile.c
@@ -327,6 +327,26 @@ ldfile_add_library_path (const char *name, bool cmdline)
@@ -310,7 +292,7 @@ index 06ac2c64fa8..5ec931a0255 100644
/* We initialize DEMANGLING based on the environment variable
COLLECT_NO_DEMANGLE. The gcc collect2 program will demangle the
diff --git a/ld/lexsup.c b/ld/lexsup.c
-index fe8722313fe..5fd7350efc5 100644
+index 49dfc13382a..b2d1d967aa0 100644
--- a/ld/lexsup.c
+++ b/ld/lexsup.c
@@ -594,6 +594,18 @@ static const struct ld_option ld_options[] =
@@ -352,5 +334,5 @@ index fe8722313fe..5fd7350efc5 100644
input_flags.pushed = xmemdup (&input_flags,
sizeof (input_flags),
--
-2.41.0
+2.42.0