summaryrefslogtreecommitdiff
path: root/3.17
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-15 08:41:38 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-15 08:41:38 +0000
commit3ee6d567eb4ac359c490109a8010d01ffa307299 (patch)
tree3c4519150e111ebc1b07633edd2d569aea582011 /3.17
parentfix mips asm/ptrace.h #527642 (diff)
downloadlinux-headers-patches-3ee6d567eb4ac359c490109a8010d01ffa307299.tar.gz
linux-headers-patches-3ee6d567eb4ac359c490109a8010d01ffa307299.tar.bz2
linux-headers-patches-3ee6d567eb4ac359c490109a8010d01ffa307299.zip
fix installing of kernel headers on x86 when kernel headers are not yet installed #527548 by Alex Cannon
Diffstat (limited to '3.17')
-rw-r--r--3.17/00_all_0008-x86-do-not-build-relocs-tool-when-installing-headers.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/3.17/00_all_0008-x86-do-not-build-relocs-tool-when-installing-headers.patch b/3.17/00_all_0008-x86-do-not-build-relocs-tool-when-installing-headers.patch
new file mode 100644
index 0000000..770279e
--- /dev/null
+++ b/3.17/00_all_0008-x86-do-not-build-relocs-tool-when-installing-headers.patch
@@ -0,0 +1,33 @@
+From ae57ea966ede555757589e48915e9f47f2455cdb Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 15 Nov 2014 03:37:38 -0500
+Subject: [PATCH] x86: do not build relocs tool when installing headers
+
+This isn't needed to install headers, so don't bother building it.
+Otherwise we run into a chicken/egg issue where we need the kernel
+headers in order to install the kernel headers. It's also a waste
+of time.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ arch/x86/Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/arch/x86/Makefile b/arch/x86/Makefile
+index 60087ca..4607c72 100644
+--- a/arch/x86/Makefile
++++ b/arch/x86/Makefile
+@@ -174,8 +174,10 @@ KBUILD_CFLAGS += $(call cc-option,-mno-avx,)
+ KBUILD_CFLAGS += $(mflags-y)
+ KBUILD_AFLAGS += $(mflags-y)
+
++ifneq ($(filter-out headers_install,$(MAKECMDGOALS)),)
+ archscripts: scripts_basic
+ $(Q)$(MAKE) $(build)=arch/x86/tools relocs
++endif
+
+ ###
+ # Syscall table generation
+--
+2.1.3
+