summaryrefslogtreecommitdiff
path: root/3.19
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-09 19:25:49 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-09 19:25:49 +0000
commit5c4bb462b83ab3781a35ca21fee331751b70ab5e (patch)
tree909ca6cca6ad0c8e143b1ad2f08cc5d19d5697bf /3.19
parentinitial 3.18 patchset based on last 3.17 patchset (diff)
downloadlinux-headers-patches-5c4bb462b83ab3781a35ca21fee331751b70ab5e.tar.gz
linux-headers-patches-5c4bb462b83ab3781a35ca21fee331751b70ab5e.tar.bz2
linux-headers-patches-5c4bb462b83ab3781a35ca21fee331751b70ab5e.zip
initial 3.19 patchset based on last 3.18 patchset
Diffstat (limited to '3.19')
-rw-r--r--3.19/00_all_0001-linux-stat.h-remove-__GLIBC__-checks.patch28
-rw-r--r--3.19/00_all_0002-netfilter-pull-in-limits.h.patch28
-rw-r--r--3.19/00_all_0003-convert-PAGE_SIZE-usage.patch54
-rw-r--r--3.19/00_all_0004-asm-generic-fcntl.h-namespace-kernel-file-structs.patch54
-rw-r--r--3.19/00_all_0005-unifdef-drop-unused-errno.h-include.patch32
-rw-r--r--3.19/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch33
-rw-r--r--3.19/00_all_0007-timerfd-export-defines-to-userspace.patch74
-rw-r--r--3.19/00_all_0008-KVM-ia64-drop-kvm.h-from-installed-user-headers.patch27
8 files changed, 330 insertions, 0 deletions
diff --git a/3.19/00_all_0001-linux-stat.h-remove-__GLIBC__-checks.patch b/3.19/00_all_0001-linux-stat.h-remove-__GLIBC__-checks.patch
new file mode 100644
index 0000000..611a4df
--- /dev/null
+++ b/3.19/00_all_0001-linux-stat.h-remove-__GLIBC__-checks.patch
@@ -0,0 +1,28 @@
+From 59cefd6901a2f567f1d8268cd47a60569a737e26 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 29 Dec 2008 06:52:59 -0500
+Subject: [PATCH] linux/stat.h: remove __GLIBC__ checks
+
+Only check __KERNEL__ so we don't assume the C library is glibc.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/linux/stat.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/uapi/linux/stat.h b/include/uapi/linux/stat.h
+index 7fec7e3..256ad24 100644
+--- a/include/uapi/linux/stat.h
++++ b/include/uapi/linux/stat.h
+@@ -2,7 +2,7 @@
+ #define _UAPI_LINUX_STAT_H
+
+
+-#if defined(__KERNEL__) || !defined(__GLIBC__) || (__GLIBC__ < 2)
++#if defined(__KERNEL__)
+
+ #define S_IFMT 00170000
+ #define S_IFSOCK 0140000
+--
+2.2.1
+
diff --git a/3.19/00_all_0002-netfilter-pull-in-limits.h.patch b/3.19/00_all_0002-netfilter-pull-in-limits.h.patch
new file mode 100644
index 0000000..e080918
--- /dev/null
+++ b/3.19/00_all_0002-netfilter-pull-in-limits.h.patch
@@ -0,0 +1,28 @@
+From b6a934c23f67e497d7ced052862be7683d1981a2 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 9 May 2009 17:30:35 -0400
+Subject: [PATCH] netfilter: pull in limits.h
+
+A few netfilter sub-headers use INT_MAX which is in limits.h.
+
+URL: http://bugs.gentoo.org/246160
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/linux/netfilter.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/uapi/linux/netfilter.h b/include/uapi/linux/netfilter.h
+index ef1b1f8..dda752c 100644
+--- a/include/uapi/linux/netfilter.h
++++ b/include/uapi/linux/netfilter.h
+@@ -4,6 +4,7 @@
+ #include <linux/types.h>
+ #include <linux/compiler.h>
+ #include <linux/sysctl.h>
++#include <limits.h>
+
+
+ /* Responses from hook functions. */
+--
+2.2.1
+
diff --git a/3.19/00_all_0003-convert-PAGE_SIZE-usage.patch b/3.19/00_all_0003-convert-PAGE_SIZE-usage.patch
new file mode 100644
index 0000000..dacc2b5
--- /dev/null
+++ b/3.19/00_all_0003-convert-PAGE_SIZE-usage.patch
@@ -0,0 +1,54 @@
+From c98ee5ab05bfbaa7843d2a226bbac5ec9b1efa59 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 13 Feb 2010 03:09:23 -0500
+Subject: [PATCH] convert PAGE_SIZE usage
+
+The size of a page may change at runtime or based on kernel settings, so
+a static value at compile time doesn't work. More importantly, no one
+exports PAGE_SIZE to user space anymore.
+
+URL: http://bugs.gentoo.org/301431
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/linux/binfmts.h | 3 ++-
+ include/uapi/linux/resource.h | 3 ++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/include/uapi/linux/binfmts.h b/include/uapi/linux/binfmts.h
+index 4eb5972..516bfcf 100644
+--- a/include/uapi/linux/binfmts.h
++++ b/include/uapi/linux/binfmts.h
+@@ -1,6 +1,7 @@
+ #ifndef _UAPI_LINUX_BINFMTS_H
+ #define _UAPI_LINUX_BINFMTS_H
+
++#include <unistd.h>
+ #include <linux/capability.h>
+
+ struct pt_regs;
+@@ -11,7 +12,7 @@ struct pt_regs;
+ * prevent the kernel from being unduly impacted by misaddressed pointers.
+ * MAX_ARG_STRINGS is chosen to fit in a signed 32-bit integer.
+ */
+-#define MAX_ARG_STRLEN (PAGE_SIZE * 32)
++#define MAX_ARG_STRLEN (sysconf(_SC_PAGESIZE) * 32)
+ #define MAX_ARG_STRINGS 0x7FFFFFFF
+
+ /* sizeof(linux_binprm->buf) */
+diff --git a/include/uapi/linux/resource.h b/include/uapi/linux/resource.h
+index 36fb3b5..58efd07 100644
+--- a/include/uapi/linux/resource.h
++++ b/include/uapi/linux/resource.h
+@@ -68,7 +68,8 @@ struct rlimit64 {
+ * GPG2 wants 64kB of mlocked memory, to make sure pass phrases
+ * and other sensitive information are never written to disk.
+ */
+-#define MLOCK_LIMIT ((PAGE_SIZE > 64*1024) ? PAGE_SIZE : 64*1024)
++/* No one currently defines PAGE_SIZE bigger than 64kB */
++#define MLOCK_LIMIT (64 * 1024)
+
+ /*
+ * Due to binary compatibility, the actual resource numbers
+--
+2.2.1
+
diff --git a/3.19/00_all_0004-asm-generic-fcntl.h-namespace-kernel-file-structs.patch b/3.19/00_all_0004-asm-generic-fcntl.h-namespace-kernel-file-structs.patch
new file mode 100644
index 0000000..06ac6a4
--- /dev/null
+++ b/3.19/00_all_0004-asm-generic-fcntl.h-namespace-kernel-file-structs.patch
@@ -0,0 +1,54 @@
+From ae139b9fdaa2367c58053aa525ed9dc889a767da Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 29 Dec 2008 07:39:14 -0500
+Subject: [PATCH] asm-generic/fcntl.h: namespace kernel file structs
+
+No one should be using these structs, but just in case they are,
+keep them available in the __kernel_ namespace.
+
+Otherwise, trying to include something like:
+ #include <fcntl.h>
+ #include <linux/inotify.h>
+leads to horrible failure.
+
+URL: http://bugs.gentoo.org/244470
+URL: http://bugs.gentoo.org/388633
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/asm-generic/fcntl.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/include/uapi/asm-generic/fcntl.h b/include/uapi/asm-generic/fcntl.h
+index e063eff..a98769e 100644
+--- a/include/uapi/asm-generic/fcntl.h
++++ b/include/uapi/asm-generic/fcntl.h
+@@ -152,7 +152,7 @@
+ #define F_OWNER_PID 1
+ #define F_OWNER_PGRP 2
+
+-struct f_owner_ex {
++struct __kernel_f_owner_ex {
+ int type;
+ __kernel_pid_t pid;
+ };
+@@ -192,7 +192,7 @@ struct f_owner_ex {
+ #define __ARCH_FLOCK_PAD
+ #endif
+
+-struct flock {
++struct __kernel_flock {
+ short l_type;
+ short l_whence;
+ __kernel_off_t l_start;
+@@ -207,7 +207,7 @@ struct flock {
+ #define __ARCH_FLOCK64_PAD
+ #endif
+
+-struct flock64 {
++struct __kernel_flock64 {
+ short l_type;
+ short l_whence;
+ __kernel_loff_t l_start;
+--
+2.2.1
+
diff --git a/3.19/00_all_0005-unifdef-drop-unused-errno.h-include.patch b/3.19/00_all_0005-unifdef-drop-unused-errno.h-include.patch
new file mode 100644
index 0000000..446226f
--- /dev/null
+++ b/3.19/00_all_0005-unifdef-drop-unused-errno.h-include.patch
@@ -0,0 +1,32 @@
+From 8c7630a48fc3b78577d9d8d7bd3be6446df3dc1a Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 6 Dec 2011 17:22:42 -0500
+Subject: [PATCH] unifdef: drop unused errno.h include
+
+This is the only header on my system that ends up requiring kernel
+headers, so if the kernel headers aren't available, we end up being
+unable to install kernel headers :).
+
+Since this file doesn't actually use anything from errno.h, drop
+the include so it at least makes us a bit more robust on glibc.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ scripts/unifdef.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/scripts/unifdef.c b/scripts/unifdef.c
+index 7493c0e..c5dfae5 100644
+--- a/scripts/unifdef.c
++++ b/scripts/unifdef.c
+@@ -48,7 +48,6 @@
+
+ #include <ctype.h>
+ #include <err.h>
+-#include <errno.h>
+ #include <stdarg.h>
+ #include <stdbool.h>
+ #include <stdio.h>
+--
+2.2.1
+
diff --git a/3.19/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch b/3.19/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch
new file mode 100644
index 0000000..76053d7
--- /dev/null
+++ b/3.19/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch
@@ -0,0 +1,33 @@
+From c06683c33a3f14be2839bfd8fc842cfc6e543461 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 15 Nov 2014 03:37:38 -0500
+Subject: [PATCH] x86: do not build relocs tool when installing headers
+
+This isn't needed to install headers, so don't bother building it.
+Otherwise we run into a chicken/egg issue where we need the kernel
+headers in order to install the kernel headers. It's also a waste
+of time.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ arch/x86/Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/arch/x86/Makefile b/arch/x86/Makefile
+index 920e616..071a14d 100644
+--- a/arch/x86/Makefile
++++ b/arch/x86/Makefile
+@@ -170,8 +170,10 @@ KBUILD_CFLAGS += $(call cc-option,-mno-avx,)
+ KBUILD_CFLAGS += $(mflags-y)
+ KBUILD_AFLAGS += $(mflags-y)
+
++ifneq ($(filter-out headers_install,$(MAKECMDGOALS)),)
+ archscripts: scripts_basic
+ $(Q)$(MAKE) $(build)=arch/x86/tools relocs
++endif
+
+ ###
+ # Syscall table generation
+--
+2.2.1
+
diff --git a/3.19/00_all_0007-timerfd-export-defines-to-userspace.patch b/3.19/00_all_0007-timerfd-export-defines-to-userspace.patch
new file mode 100644
index 0000000..d01d945
--- /dev/null
+++ b/3.19/00_all_0007-timerfd-export-defines-to-userspace.patch
@@ -0,0 +1,74 @@
+From 98b140fc7288dbe379417d7c0d334c596ef8a5d4 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 30 Dec 2014 19:14:51 -0500
+Subject: [PATCH] timerfd: export defines to userspace
+
+Since userspace is expected to call timerfd syscalls directly with these
+flags/ioctls, make sure we export them so they don't have to duplicate
+the values themselves.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/linux/timerfd.h | 20 +-------------------
+ include/uapi/linux/Kbuild | 1 +
+ include/uapi/linux/timerfd.h | 36 ++++++++++++++++++++++++++++++++++++
+ 3 files changed, 38 insertions(+), 19 deletions(-)
+ create mode 100644 include/uapi/linux/timerfd.h
+
+diff --git a/include/uapi/linux/Kbuild b/include/uapi/linux/Kbuild
+index 00b10002..874f431 100644
+--- a/include/uapi/linux/Kbuild
++++ b/include/uapi/linux/Kbuild
+@@ -389,6 +389,7 @@ header-y += telephony.h
+ header-y += termios.h
+ header-y += thermal.h
+ header-y += time.h
++header-y += timerfd.h
+ header-y += times.h
+ header-y += timex.h
+ header-y += tiocl.h
+diff --git a/include/uapi/linux/timerfd.h b/include/uapi/linux/timerfd.h
+new file mode 100644
+index 0000000..6fcfaa8
+--- /dev/null
++++ b/include/uapi/linux/timerfd.h
+@@ -0,0 +1,36 @@
++/*
++ * include/linux/timerfd.h
++ *
++ * Copyright (C) 2007 Davide Libenzi <davidel@xmailserver.org>
++ *
++ */
++
++#ifndef _UAPI_LINUX_TIMERFD_H
++#define _UAPI_LINUX_TIMERFD_H
++
++#include <linux/types.h>
++
++/* For O_CLOEXEC and O_NONBLOCK */
++#include <linux/fcntl.h>
++
++/* For _IO helpers */
++#include <linux/ioctl.h>
++
++/*
++ * CAREFUL: Check include/asm-generic/fcntl.h when defining
++ * new flags, since they might collide with O_* ones. We want
++ * to re-use O_* flags that couldn't possibly have a meaning
++ * from eventfd, in order to leave a free define-space for
++ * shared O_* flags.
++ *
++ * Also make sure to update the masks in include/linux/timerfd.h
++ * when adding new flags.
++ */
++#define TFD_TIMER_ABSTIME (1 << 0)
++#define TFD_TIMER_CANCEL_ON_SET (1 << 1)
++#define TFD_CLOEXEC O_CLOEXEC
++#define TFD_NONBLOCK O_NONBLOCK
++
++#define TFD_IOC_SET_TICKS _IOW('T', 0, __u64)
++
++#endif /* _UAPI_LINUX_TIMERFD_H */
+--
+2.2.1
+
diff --git a/3.19/00_all_0008-KVM-ia64-drop-kvm.h-from-installed-user-headers.patch b/3.19/00_all_0008-KVM-ia64-drop-kvm.h-from-installed-user-headers.patch
new file mode 100644
index 0000000..0c9cf4c
--- /dev/null
+++ b/3.19/00_all_0008-KVM-ia64-drop-kvm.h-from-installed-user-headers.patch
@@ -0,0 +1,27 @@
+From c28f41d7bb080caaf04eb7779ebcbe87bba17333 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 9 Feb 2015 12:25:32 -0500
+Subject: [PATCH] KVM: ia64: drop kvm.h from installed user headers
+
+The header was deleted, so stop trying to install it.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ arch/ia64/include/uapi/asm/Kbuild | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/arch/ia64/include/uapi/asm/Kbuild b/arch/ia64/include/uapi/asm/Kbuild
+index 1b3f5eb..891002b 100644
+--- a/arch/ia64/include/uapi/asm/Kbuild
++++ b/arch/ia64/include/uapi/asm/Kbuild
+@@ -18,7 +18,6 @@ header-y += intrinsics.h
+ header-y += ioctl.h
+ header-y += ioctls.h
+ header-y += ipcbuf.h
+-header-y += kvm.h
+ header-y += kvm_para.h
+ header-y += mman.h
+ header-y += msgbuf.h
+--
+2.2.1
+