summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '4.3/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch')
-rw-r--r--4.3/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/4.3/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch b/4.3/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch
new file mode 100644
index 0000000..9d4e579
--- /dev/null
+++ b/4.3/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch
@@ -0,0 +1,33 @@
+From 48837d5aa61532f18c8ca96fc7cb92f775f04a57 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 15 Nov 2014 03:37:38 -0500
+Subject: [PATCH] x86: do not build relocs tool when installing headers
+
+This isn't needed to install headers, so don't bother building it.
+Otherwise we run into a chicken/egg issue where we need the kernel
+headers in order to install the kernel headers. It's also a waste
+of time.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ arch/x86/Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/arch/x86/Makefile b/arch/x86/Makefile
+index 747860c..8bafc7b 100644
+--- a/arch/x86/Makefile
++++ b/arch/x86/Makefile
+@@ -181,8 +181,10 @@ KBUILD_CFLAGS += -fno-asynchronous-unwind-tables
+ KBUILD_CFLAGS += $(mflags-y)
+ KBUILD_AFLAGS += $(mflags-y)
+
++ifneq ($(filter-out headers_install,$(MAKECMDGOALS)),)
+ archscripts: scripts_basic
+ $(Q)$(MAKE) $(build)=arch/x86/tools relocs
++endif
+
+ ###
+ # Syscall table generation
+--
+2.5.2
+