summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2009-10-23 16:39:55 +0200
committerSebastian Pipping <sebastian@pipping.org>2009-10-23 16:39:55 +0200
commiteda035948a6b35edadfbb8ac8e810d6ee6886469 (patch)
treec34debaa80be251a8f0977f35eda935a105261ee /net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild
parentSet repo_name (diff)
downloadturbogears2-eda035948a6b35edadfbb8ac8e810d6ee6886469.tar.gz
turbogears2-eda035948a6b35edadfbb8ac8e810d6ee6886469.tar.bz2
turbogears2-eda035948a6b35edadfbb8ac8e810d6ee6886469.zip
Add ebuilds from sping overlay
Diffstat (limited to 'net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild')
-rw-r--r--net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild b/net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild
new file mode 100644
index 0000000..7f3281b
--- /dev/null
+++ b/net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+
+inherit distutils
+
+MY_PN="${PN/zope/zope.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Minimal Zope/SQLAlchemy transaction integration"
+HOMEPAGE="http://pypi.python.org/pypi/zope.sqlalchemy"
+SRC_URI="http://pypi.python.org/packages/source/z/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="ZPL"
+KEYWORDS=""
+SLOT="0"
+IUSE="test"
+
+RDEPEND="|| (
+ ( >=dev-python/sqlalchemy-0.4.7 <=dev-python/sqlalchemy-0.5 )
+ >=dev-python/sqlalchemy-0.5.1
+ )
+ dev-python/transaction
+ net-zope/zopeinterface"
+DEPEND="dev-python/setuptools
+ test? ( net-zope/zopetesting dev-python/docutils )"
+
+S="${WORKDIR}/${MY_P}"