aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Harvey <chris@basementcode.com>2010-06-11 21:57:14 -0400
committerChristopher Harvey <chris@basementcode.com>2010-06-11 21:57:14 -0400
commit923502f0e863d5902e52d20fa302481427ca77e1 (patch)
treea466eda54667db5e7c1a686b9c8e51ab8e95748c /setup.py
parentMerged frontend and backend into 'ventoo' (diff)
downloadventoo-923502f0e863d5902e52d20fa302481427ca77e1.tar.gz
ventoo-923502f0e863d5902e52d20fa302481427ca77e1.tar.bz2
ventoo-923502f0e863d5902e52d20fa302481427ca77e1.zip
Added ventoo executable, for /usr/bin
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 1d665e6..78f04aa 100644
--- a/setup.py
+++ b/setup.py
@@ -12,6 +12,9 @@ for dirpath, dirnames, filenames in os.walk('modules'):
if dirname.startswith('.'): del dirnames[i]
built_data_files.append([os.path.join('/usr/share/ventoo/', dirpath), [os.path.join(dirpath, f) for f in filenames]])
+#install the executable
+built_data_files.append(['/usr/bin', ['ventoo']])
+
#update module search paths for install location
f = open("src/ventoo/search_paths.py", 'a')
f.write("\nmodules = ['/usr/share/ventoo/modules']\n")