summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--006-vim-8.2.5066-crosscompile.patch10
1 files changed, 4 insertions, 6 deletions
diff --git a/006-vim-8.2.5066-crosscompile.patch b/006-vim-8.2.5066-crosscompile.patch
index a78a43e..984c2af 100644
--- a/006-vim-8.2.5066-crosscompile.patch
+++ b/006-vim-8.2.5066-crosscompile.patch
@@ -2,22 +2,20 @@ Skip failing configure checks during cross-compile builds (bug #473372).
--- a/src/configure.ac
+++ b/src/configure.ac
-@@ -3441,7 +3441,7 @@ else
+@@ -3443,7 +3443,7 @@ else
# include <stddef.h>
#endif
- main() {char *s; s=(char *)tgoto("%p1%d", 0, 1); exit(0); }])],
+ int main() {char *s; s=(char *)tgoto("%p1%d", 0, 1); exit(0); }])],
- res="OK", res="FAIL", res="FAIL")
+ res="OK", res="FAIL", res="OK")
if test "$res" = "OK"; then
break
fi
-@@ -3512,7 +3512,7 @@ main()
+@@ -3514,7 +3514,7 @@ int main()
],[
vim_cv_tgetent=non-zero
],[
- AC_MSG_ERROR(failed to compile test program.)
-+ vim_cv_tgent=zero
++ vim_cv_tgent=zero
])
])
-
---