summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Rossi <rossi.f@inwind.it>2016-08-17 14:08:10 +0200
committerFabio Rossi <rossi.f@inwind.it>2016-08-17 14:08:10 +0200
commitf5e136467b79ef82f237004c60f5bc8dd4e486ef (patch)
tree05f0e1000644a9a97a51956477c2635704f2a12e
parenttrying to version bump vmware 11 (diff)
downloadvmware-f5e136467b79ef82f237004c60f5bc8dd4e486ef.tar.gz
vmware-f5e136467b79ef82f237004c60f5bc8dd4e486ef.tar.bz2
vmware-f5e136467b79ef82f237004c60f5bc8dd4e486ef.zip
app-emulation/vmware-modules: add support to kernel 4.8
upstream kernel commit 4b9d0fab7166c9323f06d708518a35cf3a90426c renamed a symbol, add a patch to fix the problem. This solves the bug #591284.
-rw-r--r--app-emulation/vmware-modules/files/304-4.8-00-nr_anon_mapped.patch14
-rw-r--r--app-emulation/vmware-modules/files/308-4.08-00-nr_anon_mapped.patch14
-rw-r--r--app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild1
-rw-r--r--app-emulation/vmware-modules/vmware-modules-304.4.ebuild1
-rw-r--r--app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild1
5 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/304-4.8-00-nr_anon_mapped.patch b/app-emulation/vmware-modules/files/304-4.8-00-nr_anon_mapped.patch
new file mode 100644
index 0000000..f806ccd
--- /dev/null
+++ b/app-emulation/vmware-modules/files/304-4.8-00-nr_anon_mapped.patch
@@ -0,0 +1,14 @@
+diff -uprNb a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
+--- a/vmmon-only/linux/hostif.c 2016-08-13 16:54:18.935207507 +0300
++++ b/vmmon-only/linux/hostif.c 2016-08-13 16:53:52.981424256 +0300
+@@ -140,6 +140,10 @@ static DECLARE_TASKLET(timerTasklet, Hos
+ */
+ #define LOCKED_PAGE_SLACK 10000
+
++#if LINUX_VERSION_CODE > KERNEL_VERSION(4, 7, 99)
++#define NR_ANON_PAGES NR_ANON_MAPPED
++#endif
++
+ static struct {
+ Atomic_uint64 uptimeBase;
+ VersionedAtomic version;
diff --git a/app-emulation/vmware-modules/files/308-4.08-00-nr_anon_mapped.patch b/app-emulation/vmware-modules/files/308-4.08-00-nr_anon_mapped.patch
new file mode 100644
index 0000000..f806ccd
--- /dev/null
+++ b/app-emulation/vmware-modules/files/308-4.08-00-nr_anon_mapped.patch
@@ -0,0 +1,14 @@
+diff -uprNb a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
+--- a/vmmon-only/linux/hostif.c 2016-08-13 16:54:18.935207507 +0300
++++ b/vmmon-only/linux/hostif.c 2016-08-13 16:53:52.981424256 +0300
+@@ -140,6 +140,10 @@ static DECLARE_TASKLET(timerTasklet, Hos
+ */
+ #define LOCKED_PAGE_SLACK 10000
+
++#if LINUX_VERSION_CODE > KERNEL_VERSION(4, 7, 99)
++#define NR_ANON_PAGES NR_ANON_MAPPED
++#endif
++
+ static struct {
+ Atomic_uint64 uptimeBase;
+ VersionedAtomic version;
diff --git a/app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild b/app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild
index ba97b17..a10a9f4 100644
--- a/app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild
@@ -104,6 +104,7 @@ src_prepare() {
kernel_is ge 4 6 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.6-00-user-pages.patch"
kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.7-00-trans_start.patch"
kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.7-01-readlink_copy.patch"
+ kernel_is ge 4 8 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.8-00-nr_anon_mapped.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user
diff --git a/app-emulation/vmware-modules/vmware-modules-304.4.ebuild b/app-emulation/vmware-modules/vmware-modules-304.4.ebuild
index ba97b17..a10a9f4 100644
--- a/app-emulation/vmware-modules/vmware-modules-304.4.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-304.4.ebuild
@@ -104,6 +104,7 @@ src_prepare() {
kernel_is ge 4 6 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.6-00-user-pages.patch"
kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.7-00-trans_start.patch"
kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.7-01-readlink_copy.patch"
+ kernel_is ge 4 8 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.8-00-nr_anon_mapped.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user
diff --git a/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild b/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild
index da4a7a1..b3faaaf 100644
--- a/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild
@@ -104,6 +104,7 @@ src_prepare() {
kernel_is ge 4 6 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.06-00-user-pages.patch"
kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.07-00-trans_start.patch"
kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.07-01-readlink_copy.patch"
+ kernel_is ge 4 8 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.08-00-nr_anon_mapped.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user