summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2012-05-04 10:15:13 -0400
committerVadim Kuznetsov <vadimk@gentoo.org>2012-05-04 10:15:13 -0400
commit569f99518c8e6cc9dd673827f8588687d95cc667 (patch)
tree1f6c1c504738060007e6a1ca77b021fa72353168 /app-emulation/vmware-modules/files/264.2-3.2.0.patch
parentfixed path (diff)
downloadvmware-569f99518c8e6cc9dd673827f8588687d95cc667.tar.gz
vmware-569f99518c8e6cc9dd673827f8588687d95cc667.tar.bz2
vmware-569f99518c8e6cc9dd673827f8588687d95cc667.zip
VMware desktop build 703057
modified: app-emulation/vmware-modules/files/264-3.2.0.patch deleted: app-emulation/vmware-modules/files/264.2-3.2.0.patch modified: app-emulation/vmware-modules/metadata.xml renamed: app-emulation/vmware-modules/vmware-modules-264.2-r2.ebuild -> app-emulation/vmware-modules/vmware-modules-264.3.ebuild modified: app-emulation/vmware-player/Manifest renamed: app-emulation/vmware-player/vmware-player-4.0.2.591240-r1.ebuild -> app-emulation/vmware-player/vmware-player-4.0.3.703057.ebuild modified: app-emulation/vmware-workstation/Manifest renamed: app-emulation/vmware-workstation/vmware-workstation-8.0.2.591240.ebuild -> app-emulation/vmware-workstation/vmware-workstation-8.0.3.703057.ebuild
Diffstat (limited to 'app-emulation/vmware-modules/files/264.2-3.2.0.patch')
-rw-r--r--app-emulation/vmware-modules/files/264.2-3.2.0.patch86
1 files changed, 0 insertions, 86 deletions
diff --git a/app-emulation/vmware-modules/files/264.2-3.2.0.patch b/app-emulation/vmware-modules/files/264.2-3.2.0.patch
deleted file mode 100644
index 87f8914..0000000
--- a/app-emulation/vmware-modules/files/264.2-3.2.0.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-diff --git a/vmnet-only/filter.c b/vmnet-only/filter.c
-index 491add5..74f7a3b 100644
---- a/vmnet-only/filter.c
-+++ b/vmnet-only/filter.c
-@@ -40,6 +40,10 @@
- #include "vnetInt.h"
- #include "vmnetInt.h"
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 2, 0)
-+#include <linux/export.h>
-+#endif
-+
- // VNet_FilterLogPacket.action for dropped packets
- #define VNET_FILTER_ACTION_DRP (1)
- #define VNET_FILTER_ACTION_DRP_SHORT (2)
-diff --git a/vmnet-only/netif.c b/vmnet-only/netif.c
-index 4bdb643..5b71339 100644
---- a/vmnet-only/netif.c
-+++ b/vmnet-only/netif.c
-@@ -62,7 +62,9 @@ static int VNetNetifClose(struct net_device *dev);
- static int VNetNetifStartXmit(struct sk_buff *skb, struct net_device *dev);
- static struct net_device_stats *VNetNetifGetStats(struct net_device *dev);
- static int VNetNetifSetMAC(struct net_device *dev, void *addr);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
- static void VNetNetifSetMulticast(struct net_device *dev);
-+#endif
- #if 0
- static void VNetNetifTxTimeout(struct net_device *dev);
- #endif
-@@ -131,7 +133,9 @@ VNetNetIfSetup(struct net_device *dev) // IN:
- .ndo_stop = VNetNetifClose,
- .ndo_get_stats = VNetNetifGetStats,
- .ndo_set_mac_address = VNetNetifSetMAC,
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
- .ndo_set_multicast_list = VNetNetifSetMulticast,
-+#endif
- /*
- * We cannot stuck... If someone will report problems under
- * low memory conditions or some such, we should enable it.
-@@ -152,7 +156,9 @@ VNetNetIfSetup(struct net_device *dev) // IN:
- dev->stop = VNetNetifClose;
- dev->get_stats = VNetNetifGetStats;
- dev->set_mac_address = VNetNetifSetMAC;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
- dev->set_multicast_list = VNetNetifSetMulticast;
-+#endif
- /*
- * We cannot stuck... If someone will report problems under
- * low memory conditions or some such, we should enable it.
-@@ -612,11 +618,12 @@ VNetNetifSetMAC(struct net_device *dev, // IN:
- *----------------------------------------------------------------------
- */
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
- void
- VNetNetifSetMulticast(struct net_device *dev) // IN: unused
- {
- }
--
-+#endif
-
- /*
- *----------------------------------------------------------------------
-diff --git a/vmnet-only/userif.c b/vmnet-only/userif.c
-index 541187b..77e0089 100644
---- a/vmnet-only/userif.c
-+++ b/vmnet-only/userif.c
-@@ -517,10 +517,18 @@ VNetCsumCopyDatagram(const struct sk_buff *skb, // IN: skb to copy
- unsigned int tmpCsum;
- const void *vaddr;
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 2, 0)
-+ vaddr = kmap(skb_frag_page(frag));
-+#else
- vaddr = kmap(frag->page);
-+#endif
- tmpCsum = csum_and_copy_to_user(vaddr + frag->page_offset,
- curr, frag->size, 0, &err);
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 2, 0)
-+ kunmap(skb_frag_page(frag));
-+#else
- kunmap(frag->page);
-+#endif
- if (err) {
- return err;
- }