summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2013-06-21 22:42:06 +0200
committerAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2013-06-21 22:52:33 +0200
commit0b930fa4b0735f835d56fdfcd92bb4dbbd488f50 (patch)
tree01c5c69116b30eef224b199d0981e6cbb83cae00 /app-emulation/vmware-modules
parentopen-vm-tools: version bump (not tested); dropped maintainer (diff)
downloadvmware-0b930fa4b0735f835d56fdfcd92bb4dbbd488f50.tar.gz
vmware-0b930fa4b0735f835d56fdfcd92bb4dbbd488f50.tar.bz2
vmware-0b930fa4b0735f835d56fdfcd92bb4dbbd488f50.zip
add epatch_user support
Package-Manager: portage-2.2.0_alpha183
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/vmware-modules-238.6.ebuild3
-rw-r--r--app-emulation/vmware-modules/vmware-modules-264.5.ebuild3
-rw-r--r--app-emulation/vmware-modules/vmware-modules-271.2.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/vmware-modules-238.6.ebuild b/app-emulation/vmware-modules/vmware-modules-238.6.ebuild
index d4c527a..447af26 100644
--- a/app-emulation/vmware-modules/vmware-modules-238.6.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-238.6.ebuild
@@ -67,6 +67,9 @@ src_prepare() {
epatch "${FILESDIR}/${PV_MAJOR}-netdevice.patch"
epatch "${FILESDIR}/${PV_MAJOR}-3.2.0.patch"
epatch "${FILESDIR}/${PV_MAJOR}-d-make-root.patch"
+
+ # Allow user patches so they can support RC kernels and whatever else
+ epatch_user
}
src_install() {
diff --git a/app-emulation/vmware-modules/vmware-modules-264.5.ebuild b/app-emulation/vmware-modules/vmware-modules-264.5.ebuild
index c8daa43..9635470 100644
--- a/app-emulation/vmware-modules/vmware-modules-264.5.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-264.5.ebuild
@@ -66,6 +66,9 @@ src_prepare() {
use pax_kernel && epatch "${FILESDIR}/hardened.patch"
epatch "${FILESDIR}/${PV_MAJOR}-apic.patch"
kernel_is ge 3 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-putname.patch"
+
+ # Allow user patches so they can support RC kernels and whatever else
+ epatch_user
}
src_install() {
diff --git a/app-emulation/vmware-modules/vmware-modules-271.2.ebuild b/app-emulation/vmware-modules/vmware-modules-271.2.ebuild
index 5c5ce2c..d874dca 100644
--- a/app-emulation/vmware-modules/vmware-modules-271.2.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-271.2.ebuild
@@ -65,6 +65,9 @@ src_prepare() {
use pax_kernel && epatch "${FILESDIR}/hardened.patch"
epatch "${FILESDIR}/${PV_MAJOR}-apic.patch"
kernel_is ge 3 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-putname.patch"
+
+ # Allow user patches so they can support RC kernels and whatever else
+ epatch_user
}
src_install() {