summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvan Teran <evan.teran@gmail.com>2014-10-11 11:43:43 -0400
committerEvan Teran <evan.teran@gmail.com>2014-10-11 11:43:43 -0400
commit1a5f058793742777d3e60ca3b930fc54bb42a344 (patch)
tree0a88c1d5063c786d816d6df0e06017a2d83d760c /app-emulation/vmware-modules
parentadding vmware-modules-279.2-r1, (workstation 10) which compiles cleanrly on 3... (diff)
downloadvmware-1a5f058793742777d3e60ca3b930fc54bb42a344.tar.gz
vmware-1a5f058793742777d3e60ca3b930fc54bb42a344.tar.bz2
vmware-1a5f058793742777d3e60ca3b930fc54bb42a344.zip
now supports 3.13.0
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/files/279-3.13-00-vmnet.patch36
-rw-r--r--app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild1
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/279-3.13-00-vmnet.patch b/app-emulation/vmware-modules/files/279-3.13-00-vmnet.patch
new file mode 100644
index 0000000..4e9d7e9
--- /dev/null
+++ b/app-emulation/vmware-modules/files/279-3.13-00-vmnet.patch
@@ -0,0 +1,36 @@
+--- work/vmnet-only/filter.c 2013-08-27 20:29:04.000000000 +0100
++++ patched/vmnet-only/filter.c 2014-01-26 01:09:05.184893854 +0000
+@@ -27,6 +27,7 @@
+ #include "compat_module.h"
+ #include <linux/mutex.h>
+ #include <linux/netdevice.h>
++#include <linux/version.h>
+ #if COMPAT_LINUX_VERSION_CHECK_LT(3, 2, 0)
+ # include <linux/module.h>
+ #else
+@@ -203,7 +204,11 @@
+ #endif
+
+ static unsigned int
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0)
+ VNetFilterHookFn(unsigned int hooknum, // IN:
++#else
++VNetFilterHookFn(const struct nf_hook_ops *ops, // IN:
++#endif
+ #ifdef VMW_NFHOOK_USES_SKB
+ struct sk_buff *skb, // IN:
+ #else
+@@ -252,7 +257,12 @@
+
+ /* When the host transmits, hooknum is VMW_NF_INET_POST_ROUTING. */
+ /* When the host receives, hooknum is VMW_NF_INET_LOCAL_IN. */
+- transmit = (hooknum == VMW_NF_INET_POST_ROUTING);
++
++ #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0)
++ transmit = (hooknum == VMW_NF_INET_POST_ROUTING);
++ #else
++ transmit = (ops->hooknum == VMW_NF_INET_POST_ROUTING);
++ #endif
+
+ packetHeader = compat_skb_network_header(skb);
+ ip = (struct iphdr*)packetHeader;
diff --git a/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild b/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild
index 1212ca8..cd4419a 100644
--- a/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-279.2-r1.ebuild
@@ -90,6 +90,7 @@ src_prepare() {
kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-05-hub.patch"
kernel_is ge 3 11 0 && epatch "${FILESDIR}/${PV_MAJOR}-filldir.patch"
+ kernel_is ge 3 13 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.13-00-vmnet.patch"
# Allow user patches so they can support RC kernels and whatever else