summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvan Teran <evan.teran@gmail.com>2015-08-12 05:42:45 +0000
committerEvan Teran <evan.teran@gmail.com>2015-08-12 05:42:45 +0000
commit41a052f41c8a06d2a1690754385678993b4dc035 (patch)
tree97230f031d0c7d8dbb3fd842d0bddee812f5d55e /app-emulation/vmware-player/vmware-player-7.1.0.2496824.ebuild
parentupdating tools (diff)
downloadvmware-41a052f41c8a06d2a1690754385678993b4dc035.tar.gz
vmware-41a052f41c8a06d2a1690754385678993b4dc035.tar.bz2
vmware-41a052f41c8a06d2a1690754385678993b4dc035.zip
fixing issue from: https://github.com/gentoo/vmware/issues/7
Despite /etc/vmware/config telling it to look for the libs in /opt/vmware/lib, it still insisted in looking in /usr/lib/vmware. So a symlink solves the issue fairly cleanly. Also added a minor improvement to the build Package-Manager: portage-2.2.20
Diffstat (limited to 'app-emulation/vmware-player/vmware-player-7.1.0.2496824.ebuild')
-rw-r--r--app-emulation/vmware-player/vmware-player-7.1.0.2496824.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/vmware-player/vmware-player-7.1.0.2496824.ebuild b/app-emulation/vmware-player/vmware-player-7.1.0.2496824.ebuild
index 0a7ea6a..7d271f1 100644
--- a/app-emulation/vmware-player/vmware-player-7.1.0.2496824.ebuild
+++ b/app-emulation/vmware-player/vmware-player-7.1.0.2496824.ebuild
@@ -134,6 +134,9 @@ src_install() {
dosym "${VM_INSTALL_DIR}"/lib/vmware/lib/libssl.so.0.9.8/libssl.so.0.9.8 \
"${VM_INSTALL_DIR}"/lib/vmware/lib/libvmwarebase.so.0/libssl.so.0.9.8
+ # https://github.com/gentoo/vmware/issues/7
+ dosym "${VM_INSTALL_DIR}"lib/vmware/ /usr/$(get_libdir)/vmware
+
# install the ancillaries
insinto /usr
doins -r share
@@ -203,7 +206,7 @@ src_install() {
local initscript="${T}/vmware.rc"
sed -e "s:@@BINDIR@@:${VM_INSTALL_DIR}/bin:g" \
- "${FILESDIR}/vmware-11.0.rc" > "${initscript}" || die
+ "${FILESDIR}/vmware-11.${PV_MINOR}.rc" > "${initscript}" || die
newinitd "${initscript}" vmware || die
# fill in variable placeholders