summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2012-06-16 16:25:04 -0400
committerVadim Kuznetsov <vadimk@gentoo.org>2012-06-16 16:25:04 -0400
commite2c1ba0216a61ac2c7a2a190779f2701740e6b4f (patch)
treedaa94e1590d7991cbdc30fa145d5ddebc86ab081 /app-emulation
parentvmware-vix: version bump (diff)
downloadvmware-e2c1ba0216a61ac2c7a2a190779f2701740e6b4f.tar.gz
vmware-e2c1ba0216a61ac2c7a2a190779f2701740e6b4f.tar.bz2
vmware-e2c1ba0216a61ac2c7a2a190779f2701740e6b4f.zip
added configure-hostd.sh
new file: files/configure-hostd.sh modified: vmware-workstation-8.0.4.744019.ebuild
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-workstation/files/configure-hostd.sh20
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-8.0.4.744019.ebuild15
2 files changed, 24 insertions, 11 deletions
diff --git a/app-emulation/vmware-workstation/files/configure-hostd.sh b/app-emulation/vmware-workstation/files/configure-hostd.sh
new file mode 100644
index 0000000..480e903
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/configure-hostd.sh
@@ -0,0 +1,20 @@
+#!/bin/bash
+
+action="$1"
+
+case $action in
+ add)
+ rc-update -q add vmware-workstation-server default
+ rc-service vmware-workstation-server start
+ ;;
+ remove)
+ rc-update -q del vmware-workstation-server default
+ rc-service vmware-workstation-server stop
+ ;;
+ status)
+ rc-service -q vmware-workstation-server status
+ ;;
+ *)
+ exit 1
+ ;;
+esac
diff --git a/app-emulation/vmware-workstation/vmware-workstation-8.0.4.744019.ebuild b/app-emulation/vmware-workstation/vmware-workstation-8.0.4.744019.ebuild
index 3bd4064..3ef4c82 100644
--- a/app-emulation/vmware-workstation/vmware-workstation-8.0.4.744019.ebuild
+++ b/app-emulation/vmware-workstation/vmware-workstation-8.0.4.744019.ebuild
@@ -21,7 +21,7 @@ SRC_URI="
LICENSE="vmware"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE="cups doc gnome kde ovftool server vix vmware-tools"
+IUSE="cups doc ovftool server vix vmware-tools"
RESTRICT="binchecks fetch mirror strip"
# vmware-workstation should not use virtual/libc as this is a
@@ -57,8 +57,6 @@ RDEPEND="dev-cpp/cairomm
sys-libs/glibc
sys-libs/zlib
x11-libs/cairo
- gnome? ( x11-libs/gksu )
- kde? ( kde-base/kdesu )
x11-libs/gtk+:2
x11-libs/libgksu
x11-libs/libICE
@@ -205,6 +203,8 @@ src_install() {
into "${VM_INSTALL_DIR}"/lib/vmware
dobin bin/*
+ dobin "${FILESDIR}"/configure-hostd.sh
+
# install the libraries
insinto "${VM_INSTALL_DIR}"/lib/vmware/lib
doins -r lib/*
@@ -287,14 +287,6 @@ src_install() {
dosym "${VM_INSTALL_DIR}"/lib/vmware/bin/vmware "${VM_INSTALL_DIR}"/bin/vmware
dosym "${VM_INSTALL_DIR}"/lib/vmware/icu /etc/vmware/icu
- # fixing gksu problem
- if use gnome; then
- dosym /usr/bin/gksu "${VM_INSTALL_DIR}"/bin/vmware-gksu
- fi
- if use kde; then
- dosym /usr/bin/kdesu "${VM_INSTALL_DIR}"/bin/vmware-gksu
- fi
-
# fix permissions
fperms 0755 "${VM_INSTALL_DIR}"/lib/vmware/bin/{appLoader,fusermount,launcher.sh,mkisofs,vmware-remotemks}
fperms 0755 "${VM_INSTALL_DIR}"/lib/vmware/lib/{wrapper-gtk24.sh,libgksu2.so.0/gksu-run-helper}
@@ -304,6 +296,7 @@ src_install() {
if use server; then
fperms 0755 "${VM_INSTALL_DIR}"/lib/vmware/bin/vmware-{hostd,vim-cmd,wssc-adminTool}
fperms 4711 "${VM_INSTALL_DIR}"/sbin/vmware-authd
+ fperms 1777 "${VM_DATA_STORE_DIR}"
fi
if use vix; then
fperms 0755 "${VM_INSTALL_DIR}"/lib/vmware-vix/setup/vmware-config