summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvan Teran <evan.teran@gmail.com>2014-10-11 17:52:59 -0400
committerEvan Teran <evan.teran@gmail.com>2014-10-11 17:52:59 -0400
commitf62a01d79a2143ae65c3669126970134259a0396 (patch)
tree7afc7be15fe6e8b6c5e96aa4845d4a06ac1be9f3 /app-emulation
parentadding missing file (diff)
parentSync with main tree (diff)
downloadvmware-f62a01d79a2143ae65c3669126970134259a0396.tar.gz
vmware-f62a01d79a2143ae65c3669126970134259a0396.tar.bz2
vmware-f62a01d79a2143ae65c3669126970134259a0396.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/vmware
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild6
-rw-r--r--app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719-r1.ebuild (renamed from app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719.ebuild)18
2 files changed, 12 insertions, 12 deletions
diff --git a/app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild b/app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild
index 4fd4533..4971693 100644
--- a/app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild
+++ b/app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild,v 1.1 2012/06/17 13:11:52 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild,v 1.2 2012/10/29 14:51:08 flameeyes Exp $
EAPI="4"
@@ -21,7 +21,7 @@ LICENSE="vmware"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="doc"
-RESTRICT="binchecks fetch mirror strip"
+RESTRICT="fetch mirror strip"
# vmware-workstation should not use virtual/libc as this is a
# precompiled binary package thats linked to glibc.
diff --git a/app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719.ebuild b/app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719-r1.ebuild
index e3a06bb..94b8255 100644
--- a/app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719.ebuild
+++ b/app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719-r1.ebuild
@@ -6,7 +6,7 @@
# to download VMWare. The agreeing to a licence is part of the configure step
# which the user must run manually.
-EAPI="2"
+EAPI=5
inherit eutils perl-module versionator
@@ -44,9 +44,9 @@ DEPEND="
dev-perl/XML-SAX
dev-perl/libwww-perl
dev-perl/libxml-perl
- perl-core/Compress-Raw-Zlib
- perl-core/IO-Compress
- perl-core/version
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-IO-Compress
+ virtual/perl-version
sys-fs/e2fsprogs
sys-libs/zlib"
# !app-emulation/vmware-server
@@ -83,7 +83,7 @@ src_prepare() {
epatch "${FILESDIR}"/makefile.patch
- perl-module_src_prepare || die
+ perl-module_src_prepare
}
src_install() {
@@ -97,12 +97,12 @@ src_install() {
fi
done
- perl-module_src_install || die
+ perl-module_src_install
# init script
if [[ -e "${FILESDIR}/${PN}.rc" ]]
then
- newinitd "${FILESDIR}"/${PN}.rc ${product} || die "newinitd"
+ newinitd "${FILESDIR}"/${PN}.rc ${product}
fi
# create the environment
@@ -117,13 +117,13 @@ src_install() {
if [[ -e "${FILESDIR}/${PN}.xml" ]]
then
insinto /usr/share/mime/packages
- doins "${FILESDIR}"/${PN}.xml || die "mimetypes"
+ doins "${FILESDIR}"/${PN}.xml
fi
if [[ -e doc/EULA ]]
then
insinto "${VMWARE_INSTALL_DIR}"/doc
- doins doc/EULA || die "copying EULA"
+ doins doc/EULA
fi
doman man/*