summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-09-27 13:00:59 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-09-27 13:00:59 +0000
commitbbec2ab6c9b5902713b5731670f6e6880426863c (patch)
tree857b698567e95c1ffc4738e697ca30323585baa3 /eclass
parentWe should be setting MY_P if we expect our tarball to be unpacked. Ooops... (diff)
downloadvmware-bbec2ab6c9b5902713b5731670f6e6880426863c.tar.gz
vmware-bbec2ab6c9b5902713b5731670f6e6880426863c.tar.bz2
vmware-bbec2ab6c9b5902713b5731670f6e6880426863c.zip
Updated vmware.eclass and vmware-mods.eclass from portage.
svn path=/trunk/; revision=108
Diffstat (limited to 'eclass')
-rw-r--r--eclass/vmware-mod.eclass9
-rw-r--r--eclass/vmware.eclass6
2 files changed, 3 insertions, 12 deletions
diff --git a/eclass/vmware-mod.eclass b/eclass/vmware-mod.eclass
index 9c41e5e..213b8f4 100644
--- a/eclass/vmware-mod.eclass
+++ b/eclass/vmware-mod.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/eclass/vmware-mod.eclass,v 1.2 2006/08/08 19:16:42 ikelos Exp $
# Ensure vmware comes before linux-mod since we want linux-mod's pkg_preinst and
@@ -72,9 +72,6 @@ vmware-mod_src_unpack() {
# rm getversion.pl
EPATCH_SUFFIX="patch"
epatch "${FILESDIR}"/patches
- if [ -e "${FILESDIR}"/${PV} ]; then
- epatch "${FILESDIR}"/${PV}
- fi
convert_to_m "${S}"/${mod}-only/Makefile
done
}
@@ -84,13 +81,13 @@ vmware-mod_src_install() {
if [[ -n "`echo ${VMWARE_MODULE_LIST} | grep vmmon`" ]];
then
dodir /etc/udev/rules.d
- echo 'KERNEL=="vmmon*", GROUP="'$VMWARE_GROUP'" MODE=660' > "${D}/etc/udev/rules.d/60-vmware.rules" || die
+ echo 'KERNEL=="vmmon*", GROUP="'$VMWARE_GROUP'" MODE=660' >> "${D}/etc/udev/rules.d/60-vmware.rules" || die
+ echo 'KERNEL=="vmnet*", GROUP="'$VMWARE_GROUP'" MODE=660' >> "${D}/etc/udev/rules.d/60-vmware.rules" || die
fi
linux-mod_src_install
}
-
# Current VMWARE product mappings
# 'VME_TOT' = .0
# 'VME_GSX1' = .1
diff --git a/eclass/vmware.eclass b/eclass/vmware.eclass
index 4dbc08b..f304edf 100644
--- a/eclass/vmware.eclass
+++ b/eclass/vmware.eclass
@@ -276,12 +276,6 @@ vmware_src_install() {
"${config_dir}"/init.d/${product}
[ "${shortname}" == "server" ] && dosed "s:%SHORTNAME%:wgs:" \
"${config_dir}"/init.d/${product}
-
- # Then we "fix" it.
- dosed -e 's/mknod -m 600/mknod -m 660/' \
- -e '/c 119 "$vHubNr"/ a\
- chown root:'${VMWARE_GROUP}' /dev/vmnet*\
- ' "${config_dir}"/init.d/${product} || die
fi
# Finally, we run the "questions"