summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vmware-player')
-rw-r--r--app-emulation/vmware-player/Manifest3
-rw-r--r--app-emulation/vmware-player/vmware-player-4.0.2.591240.ebuild248
2 files changed, 251 insertions, 0 deletions
diff --git a/app-emulation/vmware-player/Manifest b/app-emulation/vmware-player/Manifest
index cde62c5..167f1d7 100644
--- a/app-emulation/vmware-player/Manifest
+++ b/app-emulation/vmware-player/Manifest
@@ -6,6 +6,9 @@ DIST VMware-Player-3.1.5-491717.i386.bundle 107094686 RMD160 293941018c9dec86eee
DIST VMware-Player-3.1.5-491717.x86_64.bundle 103019114 RMD160 b1a2544e5718474a1987389136a42034dfbc2ff2 SHA1 a253a486d6c6848620de200ef1837ced903daa1c SHA256 5aa1f01d09a1c39da06f3a314d3e47e75e80b4a345ef76dabe14e538fe3bc511
DIST VMware-Player-4.0.1-528992.i386.bundle 131763315 RMD160 bd26399b4044079fc95ecba62042b8ddab8709a7 SHA1 1f686ea7a6f3e13a390a5644581b809a27021ed5 SHA256 13eabb650f6746cad64a334abea3446dd8ab66ca386a4e13b7a3e77db8a95d6e
DIST VMware-Player-4.0.1-528992.x86_64.bundle 129509694 RMD160 c530e38d42222c2eec0f63e24ee24057b8d3dce9 SHA1 7332763867b6ed1978271a3335c7e135a1293210 SHA256 57f5e22c28827e4edf000aa44054cf62d886ed4c174cbb0ebe5e0e0eb6e9995c
+DIST VMware-Player-4.0.2-591240.i386.bundle 131962526 RMD160 fd624e21895c8cd2c05e4bfe59f719e67aae0736 SHA1 a3973dd32a1a39644d30532dc4cb4c6216869415 SHA256 774bc82e6079b723d57029f6511c8f10ebba5f41d1ba862151a41040e172052a
+DIST VMware-Player-4.0.2-591240.x86_64.bundle 129693508 RMD160 4b626e85a5828cb2023e181f71d94c609568665d SHA1 d417eb8538660db4ef07271fcc08152a3494bb58 SHA256 4aa09bed05c7fffa2e96b788f24626abcbe7d59749da544f37aedd15e1f459a8
EBUILD vmware-player-3.1.5.491717.ebuild 6334 RMD160 ee39299fbfb01c28c1890c862d3f39a4e3d7c163 SHA1 8b90cfe522e17a5c15b742afbc139d60decf9ca6 SHA256 ea378d1d5d1308689bacf2104f618dec655f732eff2c3e52ee11acb26656c57e
EBUILD vmware-player-4.0.1.528992-r2.ebuild 6344 RMD160 f84f1b01f325e57bc3f1a44240da971a9c6ffb79 SHA1 bc85f6e9ae5049bc9608190026665a4ce15cc4a7 SHA256 cd8a5e19a9b5e632ac93db1e9ebabe2ca01c5b86a4abeece82a5ae5b9f02924a
+EBUILD vmware-player-4.0.2.591240.ebuild 6344 RMD160 7dae786c1f34c568b0cb22d0374126c9d3a0c603 SHA1 a779a3a4fcb3aa31a76bd5025c23296db11d00fb SHA256 2df82b9645f707be5e573121cd62143802a078322a4952308a11c760696c6fff
MISC metadata.xml 238 RMD160 beef158e0603e5808d104743feba4be3e7a7e8c4 SHA1 276217c6f03ae24c0196519197240031a6961254 SHA256 8374f3a2a8f05bf0690ab35f79a20980026aefa9fabae93fe81442f54291018b
diff --git a/app-emulation/vmware-player/vmware-player-4.0.2.591240.ebuild b/app-emulation/vmware-player/vmware-player-4.0.2.591240.ebuild
new file mode 100644
index 0000000..0242f8d
--- /dev/null
+++ b/app-emulation/vmware-player/vmware-player-4.0.2.591240.ebuild
@@ -0,0 +1,248 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit eutils versionator fdo-mime gnome2-utils vmware-bundle
+
+MY_PN="VMware-Player"
+MY_PV="$(replace_version_separator 3 - $PV)"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Emulate a complete PC on your PC without the usual performance overhead of most emulators"
+HOMEPAGE="http://www.vmware.com/products/player/"
+SRC_URI="
+ x86? ( ${MY_P}.i386.bundle )
+ amd64? ( ${MY_P}.x86_64.bundle )
+ "
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cups doc +vmware-tools"
+RESTRICT="binchecks fetch strip"
+
+# vmware-workstation should not use virtual/libc as this is a
+# precompiled binary package thats linked to glibc.
+RDEPEND="dev-cpp/cairomm
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-cpp/libgnomecanvasmm:2.6
+ dev-cpp/libsexymm
+ dev-cpp/pangomm:1.4
+ dev-libs/atk
+ dev-libs/glib:2
+ dev-libs/libaio
+ dev-libs/libsigc++
+ dev-libs/libxml2
+ =dev-libs/openssl-0.9.8*
+ dev-libs/xmlrpc-c
+ gnome-base/libgnomecanvas
+ gnome-base/libgtop:2
+ gnome-base/librsvg:2
+ gnome-base/orbit
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libart_lgpl
+ =media-libs/libpng-1.2*
+ net-misc/curl
+ cups? ( net-print/cups )
+ sys-devel/gcc
+ sys-fs/fuse
+ sys-libs/glibc
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libgksu
+ x11-libs/libICE
+ x11-libs/libsexy
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+ x11-libs/startup-notification
+ !app-emulation/vmware-server
+ !app-emulation/vmware-workstation"
+PDEPEND="~app-emulation/vmware-modules-264.2
+ vmware-tools? ( app-emulation/vmware-tools )"
+
+S=${WORKDIR}
+VM_INSTALL_DIR="/opt/vmware"
+
+pkg_nofetch() {
+ local bundle
+
+ if use x86; then
+ bundle="${MY_P}.i386.bundle"
+ elif use amd64; then
+ bundle="${MY_P}.x86_64.bundle"
+ fi
+
+ einfo "Please download ${bundle}"
+ einfo "from ${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_unpack() {
+ local component ; for component in \
+ vmware-player \
+ vmware-player-app \
+ vmware-vmx \
+ vmware-usbarbitrator \
+ vmware-network-editor \
+ vmware-player-setup
+ #vmware-ovftool
+ do
+ vmware-bundle_extract-bundle-component "${DISTDIR}/${A}" "${component}" "${S}"
+ done
+}
+
+src_prepare() {
+ rm -f bin/vmware-modconfig
+ rm -rf lib/modules/binary
+}
+
+clean_bundled_libs() {
+ ebegin 'Removing superfluous libraries'
+ # exclude OpenSSL from unbundling until the AES-NI patch gets into the tree
+ # see http://forums.gentoo.org/viewtopic-t-835867.html
+ # must use shipped libgcr.so.0 or else "undefined symbol: gcr_certificate_widget_new"
+ ldconfig -p | sed 's:^\s\+\([^(]*[^( ]\).*=> \(/.*\)$:\1 \2:g;t;d' | fgrep -v 'libcrypto.so.0.9.8
+libssl.so.0.9.8
+libgcr.so.0' | while read -r libname libpath ; do
+ dosym "${libpath}" "${VM_INSTALL_DIR}/lib/vmware/lib/${libname}/${libname}"
+ done
+ eend
+}
+
+src_install() {
+ local major_minor_revision=$(get_version_component_range 1-3 "${PV}")
+ local build=$(get_version_component_range 4 "${PV}")
+
+ # install the binaries
+ into "${VM_INSTALL_DIR}"
+ dobin bin/* || die "failed to install bin"
+
+ # install the libraries
+ insinto "${VM_INSTALL_DIR}"/lib/vmware
+ doins -r lib/*
+
+ # install the ancillaries
+ insinto /usr
+ doins -r share
+
+ if use cups; then
+ exeinto $(cups-config --serverbin)/filter
+ doexe extras/thnucups
+
+ insinto /etc/cups
+ doins -r etc/cups/*
+ fi
+
+ # install documentation
+ if use doc; then
+ dodoc doc/*
+ fi
+
+ exeinto "${VM_INSTALL_DIR}"/lib/vmware/setup
+ doexe vmware-config
+
+ # create symlinks for the various tools
+ local tool ; for tool in thnuclnt vmplayer{,-daemon} \
+ vmware-{acetool,unity-helper,modconfig{,-console},gksu,fuseUI} ; do
+ dosym appLoader "${VM_INSTALL_DIR}"/lib/vmware/bin/"${tool}"
+ done
+ dosym "${VM_INSTALL_DIR}"/lib/vmware/bin/vmplayer "${VM_INSTALL_DIR}"/bin/vmplayer
+ dosym "${VM_INSTALL_DIR}"/lib/vmware/icu /etc/vmware/icu
+
+ # fix permissions
+ fperms 0755 "${VM_INSTALL_DIR}"/lib/vmware/bin/{appLoader,fusermount,launcher.sh,mkisofs,vmware-remotemks}
+ fperms 0755 "${VM_INSTALL_DIR}"/lib/vmware/lib/{wrapper-gtk24.sh,libgksu2.so.0/gksu-run-helper}
+ fperms 4711 "${VM_INSTALL_DIR}"/lib/vmware/bin/vmware-vmx{,-debug,-stats}
+
+ # create the environment
+ local envd="${T}/90vmware"
+ cat > "${envd}" <<-EOF
+ PATH='${VM_INSTALL_DIR}/bin'
+ ROOTPATH='${VM_INSTALL_DIR}/bin'
+ EOF
+ doenvd "${envd}" || die
+
+ # create the configuration
+ dodir /etc/vmware || die
+
+ cat > "${D}"/etc/vmware/bootstrap <<-EOF
+ BINDIR='${VM_INSTALL_DIR}/bin'
+ LIBDIR='${VM_INSTALL_DIR}/lib'
+ EOF
+
+ cat > "${D}"/etc/vmware/config <<-EOF
+ bindir = "${VM_INSTALL_DIR}/bin"
+ libdir = "${VM_INSTALL_DIR}/lib/vmware"
+ initscriptdir = "/etc/init.d"
+ authd.fullpath = "${VM_INSTALL_DIR}/sbin/vmware-authd"
+ gksu.rootMethod = "su"
+ VMCI_CONFED = "yes"
+ VMBLOCK_CONFED = "yes"
+ VSOCK_CONFED = "yes"
+ NETWORKING = "yes"
+ player.product.version = "${major_minor_revision}"
+ product.buildNumber = "${build}"
+ EOF
+
+ # install the init.d script
+ local initscript="${T}/vmware.rc"
+
+ sed -e "s:@@BINDIR@@:${VM_INSTALL_DIR}/bin:g" \
+ "${FILESDIR}/vmware-3.0.rc" > "${initscript}" || die
+ newinitd "${initscript}" vmware || die
+
+ # fill in variable placeholders
+ sed -e "s:@@LIBCONF_DIR@@:${VM_INSTALL_DIR}/lib/vmware/libconf:g" \
+ -i "${D}${VM_INSTALL_DIR}"/lib/vmware/libconf/etc/{gtk-2.0/{gdk-pixbuf.loaders,gtk.immodules},pango/pango{.modules,rc}} || die
+ sed -e "s:@@BINARY@@:${VM_INSTALL_DIR}/bin/vmplayer:g" \
+ -i "${D}/usr/share/applications/${PN}.desktop" || die
+}
+
+pkg_config() {
+ "${VM_INSTALL_DIR}"/bin/vmware-networks --postinstall ${PN},old,new
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ ewarn "/etc/env.d was updated. Please run:"
+ ewarn "env-update && source /etc/profile"
+ ewarn ""
+ ewarn "Before you can use vmware-player, you must configure a default network setup."
+ ewarn "You can do this by running 'emerge --config ${PN}'."
+}
+
+pkg_prerm() {
+ einfo "Stopping ${PN} for safe unmerge"
+ /etc/init.d/vmware stop
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}