summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vmware-workstation/vmware-workstation-12.1.0.3272444-r1.ebuild')
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-12.1.0.3272444-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-emulation/vmware-workstation/vmware-workstation-12.1.0.3272444-r1.ebuild b/app-emulation/vmware-workstation/vmware-workstation-12.1.0.3272444-r1.ebuild
index 9c4e95f..e489c4e 100644
--- a/app-emulation/vmware-workstation/vmware-workstation-12.1.0.3272444-r1.ebuild
+++ b/app-emulation/vmware-workstation/vmware-workstation-12.1.0.3272444-r1.ebuild
@@ -237,14 +237,15 @@ clean_bundled_libs() {
# in libcds.so to be able to use system libs.
pushd >/dev/null .
einfo "Patching libcds.so"
- cd "${S}"/lib/lib/libcds.so
- cp libcds.so "${T}"/libcds.so
- # The patch is created with patchelf > 0.8 (so using the live repository) and bsdiff:
+ cd "${S}"/lib/lib/libcds.so || die
+ cp libcds.so "${T}"/libcds.so || die
+ # The patch is created with patchelf > 0.8 (so using the live repository), bsdiff, and base64:
# The following command should be replaced in the future with:
# patchelf --replace-needed libssl.so.1.0.{1,0} \
# --replace-needed libcrypto.so.1.0.{1,0} \
# libcds.so
- bspatch "${T}"/libcds.so libcds.so "${FILESDIR}"/${P}-unbundle-libcds.patch
+ base64 -d "${FILESDIR}"/${P}-unbundle-libcds.patch.base64 > "${T}"/${P}-unbundle-libcds.patch || die
+ bspatch "${T}"/libcds.so libcds.so "${T}"/${P}-unbundle-libcds.patch || die
popd >/dev/null
}