summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-modules/files/271-putname.patch13
-rw-r--r--app-emulation/vmware-modules/vmware-modules-271.1-r1.ebuild (renamed from app-emulation/vmware-modules/vmware-modules-271.1.ebuild)1
2 files changed, 14 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/271-putname.patch b/app-emulation/vmware-modules/files/271-putname.patch
new file mode 100644
index 0000000..6e76130
--- /dev/null
+++ b/app-emulation/vmware-modules/files/271-putname.patch
@@ -0,0 +1,13 @@
+diff --git a/vmblock-only/linux/control.c b/vmblock-only/linux/control.c
+index 79716bd..2dd83fe 100644
+--- a/vmblock-only/linux/control.c
++++ b/vmblock-only/linux/control.c
+@@ -293,7 +293,7 @@ ExecuteBlockOp(const char __user *buf, // IN: buffer with name
+
+ retval = i < 0 ? -EINVAL : blockOp(name, blocker);
+
+- putname(name);
++ __putname(name);
+
+ return retval;
+ }
diff --git a/app-emulation/vmware-modules/vmware-modules-271.1.ebuild b/app-emulation/vmware-modules/vmware-modules-271.1-r1.ebuild
index ae88b23..3cc601c 100644
--- a/app-emulation/vmware-modules/vmware-modules-271.1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-271.1-r1.ebuild
@@ -64,6 +64,7 @@ src_prepare() {
epatch "${FILESDIR}/${PV_MAJOR}-netdevice.patch"
use pax_kernel && epatch "${FILESDIR}/hardened.patch"
epatch "${FILESDIR}/${PV_MAJOR}-apic.patch"
+ kernel_is 3 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-putname.patch"
}
src_install() {