summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTais M. Hansen <mellen@osd.dk>2008-01-23 18:06:42 +0000
committerTais M. Hansen <mellen@osd.dk>2008-01-23 18:06:42 +0000
commit2e43d416da100688db1b2c8a3f9350a559bf9d70 (patch)
treef8476d3ce0d9029243e7b0f66d576dc648d127aa /net-voip
parentmark siproxd ~x86 ~amd64 (diff)
downloadvoip-2e43d416da100688db1b2c8a3f9350a559bf9d70.tar.gz
voip-2e43d416da100688db1b2c8a3f9350a559bf9d70.tar.bz2
voip-2e43d416da100688db1b2c8a3f9350a559bf9d70.zip
Added yate-svn for pulling yate 2 prereleases.
svn path=/trunk/; revision=643
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/yate-svn/ChangeLog8
-rw-r--r--net-voip/yate-svn/files/yate.confd6
-rw-r--r--net-voip/yate-svn/files/yate.initd21
-rw-r--r--net-voip/yate-svn/yate-svn-9999.ebuild103
4 files changed, 138 insertions, 0 deletions
diff --git a/net-voip/yate-svn/ChangeLog b/net-voip/yate-svn/ChangeLog
new file mode 100644
index 0000000..1e0bda5
--- /dev/null
+++ b/net-voip/yate-svn/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-voip/yate-svn
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 23 Jan 2008; Tais M. Hansen <mellen@osd.dk> +files/yate.confd,
+ +files/yate.initd, +yate-svn-9999.ebuild:
+ Added yate-svn.
+
diff --git a/net-voip/yate-svn/files/yate.confd b/net-voip/yate-svn/files/yate.confd
new file mode 100644
index 0000000..c43c951
--- /dev/null
+++ b/net-voip/yate-svn/files/yate.confd
@@ -0,0 +1,6 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# YATE commandline options.
+OPTS=""
diff --git a/net-voip/yate-svn/files/yate.initd b/net-voip/yate-svn/files/yate.initd
new file mode 100644
index 0000000..ea23990
--- /dev/null
+++ b/net-voip/yate-svn/files/yate.initd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need net
+ use mysql postgresql wanpipe zaptel
+}
+
+start() {
+ ebegin "Starting YATE"
+ start-stop-daemon --start --exec /usr/bin/yate -- -d -p /var/run/yate.pid ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping YATE"
+ start-stop-daemon --stop --pidfile=/var/run/yate.pid
+ eend $?
+}
diff --git a/net-voip/yate-svn/yate-svn-9999.ebuild b/net-voip/yate-svn/yate-svn-9999.ebuild
new file mode 100644
index 0000000..a7ee169
--- /dev/null
+++ b/net-voip/yate-svn/yate-svn-9999.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils subversion
+
+DESCRIPTION="YATE - Yet Another Telephony Engine"
+HOMEPAGE="http://yate.null.ro/"
+SRC_URI=""
+
+EAPI="1"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gsm gtk h323 ilbc mysql postgres pri qt4 spandsp speex wanpipe zaptel"
+
+COMMONDEPEND="gsm? ( media-sound/gsm )
+ gtk? ( >=x11-libs/gtk+-2.6.8 )
+ h323? ( dev-libs/pwlib >=net-libs/openh323-1.15.3 )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ pri? ( net-libs/libpri )
+ qt4? ( x11-libs/qt:4 )
+ spandsp? ( media-libs/spandsp )
+ speex? ( media-libs/speex )
+ wanpipe? ( net-misc/wanpipe )
+ zaptel? ( net-misc/zaptel )"
+DEPEND="${COMMONDEPEND}
+ media-sound/sox
+ doc? ( || ( app-doc/doxygen >=dev-util/kdoc-2.0_alpha54 ) )"
+RDEPEND="${COMMONDEPEND}"
+
+ESVN_REPO_URI="http://yate.null.ro/svn/yate/trunk"
+ESVN_BOOTSTRAP="./autogen.sh"
+
+pkg_setup() {
+ if use qt4 && ! built_with_use x11-libs/qt:4 accessibility; then
+ eerror "Please make sure x11-libs/qt:4 is built with:"
+ eerror "\taccessibility"
+ die "Package dependencies not set up correctly"
+ fi
+}
+
+src_compile() {
+ local extraopts
+
+ # Figure out which doc generators are available.
+ if use doc && has_version app-doc/doxygen; then
+ extraopts+=" --with-doxygen"
+ else
+ extraopts+=" --without-doxygen"
+ fi
+
+ if use doc && has_version dev-util/kdoc; then
+ extraopts+=" --with-kdoc"
+ else
+ extraopts+=" --without-kdoc"
+ fi
+
+ econf \
+ $(use_enable ilbc) \
+ $(use_enable wanpipe) \
+ $(use_with gsm libgsm) \
+ $(use_with gtk libgtk2) \
+ $(use_with h323 openh323 /usr) \
+ $(use_with h323 pwlib /usr) \
+ $(use_with mysql mysql /usr) \
+ $(use_with postgres libpq /usr) \
+ $(use_with pri libpri) \
+ $(use_with qt4 libqt4) \
+ $(use_with spandsp) \
+ $(use_with speex libspeex) \
+ $(use_with wanpipe wphwec /usr/include/wanpipe) \
+ ${extraopts} \
+ || die "Configure failed"
+
+ emake DEBUG="-DNDEBUG" all || die "Building all failed"
+
+ if use doc; then
+ emake apidocs || die "Building API docs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR=${D} install-noapi || die "emake install-noapi failed"
+
+ if use doc; then
+ emake DESTDIR=${D} install-api || die "emake install-api failed"
+ fi
+
+ newinitd ${FILESDIR}/yate.initd yate
+ newconfd ${FILESDIR}/yate.confd yate
+
+ if [ "${P}" != "${PF}" ]; then
+ cd ${D}/usr/share/doc
+ mv ${P} ${PF}
+ fi
+
+ insinto /usr/share/doc/${PF}/scripts
+ cp -a ${S}/share/scripts/* ${D}/usr/share/doc/${PF}/scripts/
+ rm -fr ${D}/usr/share/doc/${PF}/scripts/{Makefile*,.cvsignore}
+ find ${D}/usr/share/doc/${PF}/scripts/ -depth -delete -name ".svn" -a -type d
+}