summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-01-10 16:09:54 +0000
committerChristian Heim <phreak@gentoo.org>2006-01-10 16:09:54 +0000
commit113f06ab1f0ed462ad37db2d10ec2ba0b4ecc400 (patch)
tree0a0ad5220280ea5a3b020397900b3e5468338644
parentFixing spelling :P (diff)
downloadbaselayout-vserver-113f06ab1f0ed462ad37db2d10ec2ba0b4ecc400.tar.gz
baselayout-vserver-113f06ab1f0ed462ad37db2d10ec2ba0b4ecc400.tar.bz2
baselayout-vserver-113f06ab1f0ed462ad37db2d10ec2ba0b4ecc400.zip
Importing the latest (r1798) changes uberlord made just before I've hit the commit button
svn path=/baselayout-vserver/trunk/; revision=200
-rw-r--r--ChangeLog.vserver16
-rw-r--r--net-scripts/conf.d/wireless.example3
-rw-r--r--net-scripts/net.modules.d/bonding8
-rw-r--r--net-scripts/net.modules.d/iwconfig7
-rw-r--r--net-scripts/net.modules.d/wpa_supplicant2
5 files changed, 19 insertions, 17 deletions
diff --git a/ChangeLog.vserver b/ChangeLog.vserver
index 8e13a5c..0e7ab51 100644
--- a/ChangeLog.vserver
+++ b/ChangeLog.vserver
@@ -3,11 +3,10 @@
10 Jan 2005; Christian Heim <phreak@gentoo.org>:
Importing latest baselayout/trunk changes. This merge is based upon
- revision 1797.
+ revision 1798.
ChangeLog | 114 ++++++++++++------
- ChangeLog.vserver | 57 +++++++++
- bin/rc-status | 2
+ ChangeLog.vserver | 58 +++++++++
etc/conf.d/domainname | 4
etc/profile | 14 --
init.d/bootmisc | 2
@@ -20,12 +19,12 @@
init.d/rmnologin | 2
init.d/shutdown.sh | 2
net-scripts/conf.d/net.example | 4
- net-scripts/conf.d/wireless.example | 12 +
+ net-scripts/conf.d/wireless.example | 15 +-
net-scripts/init.d/net.lo | 14 +-
net-scripts/net.modules.d/adsl | 2
net-scripts/net.modules.d/apipa | 2
net-scripts/net.modules.d/arping | 2
- net-scripts/net.modules.d/bonding | 2
+ net-scripts/net.modules.d/bonding | 10 -
net-scripts/net.modules.d/bridge | 10 -
net-scripts/net.modules.d/dhclient | 2
net-scripts/net.modules.d/dhcpcd | 2
@@ -40,8 +39,8 @@
net-scripts/net.modules.d/helpers.d/pump-wrapper | 2
net-scripts/net.modules.d/helpers.d/udhcpc-wrapper | 2
net-scripts/net.modules.d/iproute2 | 1
- net-scripts/net.modules.d/iwconfig | 45 ++++---
- net-scripts/net.modules.d/wpa_supplicant | 12 +
+ net-scripts/net.modules.d/iwconfig | 48 ++++---
+ net-scripts/net.modules.d/wpa_supplicant | 14 +-
sbin/MAKEDEV | 3
sbin/functions.sh | 29 ++--
sbin/init-common-post.sh | 2
@@ -56,8 +55,7 @@
src/Makefile | 2
src/awk/genenviron.awk | 2
src/core/ChangeLog.0 | 2
- tarball.sh | 2
- 52 files changed, 316 insertions(+), 174 deletions(-)
+ 50 files changed, 324 insertions(+), 178 deletions(-)
22 Dec 2005; Christian Heim <phreak@gentoo.org>:
Importing latest baselayout/trunk changes. This is a merge with
diff --git a/net-scripts/conf.d/wireless.example b/net-scripts/conf.d/wireless.example
index b50afdc..a73a488 100644
--- a/net-scripts/conf.d/wireless.example
+++ b/net-scripts/conf.d/wireless.example
@@ -104,6 +104,9 @@
# "set EncrypType=TKIP"
# "set WPAPSK=yourpasskey"
#)
+#NOTE: Even though you can use WPA like so, you may have to set a WEP key
+#if your driver claims the AP is encrypted. The WEP key itself will not be
+#used though.
# Seconds to wait before scanning
# Some drivers need to wait until they have finished "loading"
diff --git a/net-scripts/net.modules.d/bonding b/net-scripts/net.modules.d/bonding
index 7e1cb3d..a717ccb 100644
--- a/net-scripts/net.modules.d/bonding
+++ b/net-scripts/net.modules.d/bonding
@@ -53,14 +53,14 @@ bonding_pre_start() {
einfo "${!slaves}"
# Check that our slaves exist
- for s in "${!slaves}" ; do
+ for s in ${!slaves} ; do
interface_exists "${s}" && continue
ewarn "interface ${s} does not exist"
return 1
done
# Must force the slaves to a particular state before adding them
- for s in "${!slaves}" ; do
+ for s in ${!slaves} ; do
interface_del_addresses "${s}"
interface_up "${s}"
done
@@ -70,7 +70,7 @@ bonding_pre_start() {
# finally add in slaves
eoutdent
- /sbin/ifenslave "${iface}" "${!slaves}" >/dev/null
+ eval /sbin/ifenslave "${iface}" "${!slaves}" >/dev/null
eend $?
return 0 #important
@@ -95,7 +95,7 @@ bonding_stop() {
eindent
einfo "${slaves}"
eoutdent
- /sbin/ifenslave -d "${iface}" ${slaves} &>${devnull}
+ /sbin/ifenslave -d "${iface}" ${slaves}
# reset all slaves
for s in ${slaves}; do
diff --git a/net-scripts/net.modules.d/iwconfig b/net-scripts/net.modules.d/iwconfig
index 232cf0a..98c929e 100644
--- a/net-scripts/net.modules.d/iwconfig
+++ b/net-scripts/net.modules.d/iwconfig
@@ -244,7 +244,7 @@ iwconfig_setup_specific() {
# Returns true if the AP MAC address is valid or not
iwconfig_associate_mac() {
# Checks if a MAC address has been assigned
- local mac=$( iwconfig_get_ap_mac_address "$1" ) i
+ local mac="$( iwconfig_get_ap_mac_address $1 )" i
local -a invalid_macs=(
"00:00:00:00:00:00"
"44:44:44:44:44:44"
@@ -340,7 +340,8 @@ iwconfig_associate() {
ESSIDVAR=$( bash_variable "${ESSID}" )
key=$( iwconfig_get_wep_key "${mac}" )
if [[ ${wep_required} == "on" && ${key} == "off" ]]; then
- ewarn "WEP key is not set for \"${dessid}\""
+ eerror "WEP key is not set for \"${dessid}\" - not connecting"
+ return 1
fi
if [[ ${wep_required} == "off" && ${key} != "off" ]]; then
key="off"
@@ -429,7 +430,7 @@ iwconfig_scan() {
fi
# Set the essid to any. This is required for scanning
- iwconfig "${iface}" essid any
+ #iwconfig "${iface}" essid any
veinfo "Scanning for access points"
diff --git a/net-scripts/net.modules.d/wpa_supplicant b/net-scripts/net.modules.d/wpa_supplicant
index 8458c0f..4f621d1 100644
--- a/net-scripts/net.modules.d/wpa_supplicant
+++ b/net-scripts/net.modules.d/wpa_supplicant
@@ -208,7 +208,7 @@ wpa_supplicant_pre_start() {
opts="wpa_supplicant_${ifvar}"
opts=" ${!opts} "
[[ ${opts} != *" -D"* ]] \
- && ewarn "wpa_supplicant_${ifvar} does not define a driver"
+ && vewarn "wpa_supplicant_${ifvar} does not define a driver"
# We only work on wirelesss interfaces unless a driver for wired
# has been defined