summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog16
-rw-r--r--Makefile2
-rw-r--r--etc/rc.conf2
-rw-r--r--net-scripts/conf.d/net.example2
-rw-r--r--net-scripts/net/ifconfig.sh2
-rw-r--r--net-scripts/net/iproute2.sh2
-rw-r--r--net-scripts/net/iwconfig.sh4
-rw-r--r--net-scripts/net/pppd.sh3
-rw-r--r--net-scripts/net/tuntap.sh2
-rw-r--r--net-scripts/net/udhcpc.sh2
-rwxr-xr-xsbin/rc-update6
-rwxr-xr-xsbin/runscript.sh4
-rwxr-xr-xtarball.sh4
13 files changed, 35 insertions, 16 deletions
diff --git a/ChangeLog b/ChangeLog
index 5e77865..7527cbe 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for Gentoo System Intialization ("rc") scripts
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPLv2
+* baselayout-1.12.6 (02 Nov 2006)
+
+ 02 Nov 2006; Roy Marples <uberlord@gentoo.org>:
+
+ We no longer unmount ramfs in halt.sh, #151128
+ We no longer use =~ for the 1.12 branch only as we should work on all
+ bash versions, #151108
+
+ 01 Nov 2006; Roy Marples <uberlord@gentoo.org>:
+
+ Clarified pppd maxfail usage, #153657 thanks to Toralf Förster.
+
+ 31 Oct 2006; Roy Marples <uberlord@gentoo.org>:
+
+ tuntap should come before bridge, #150520.
+
30 Sep 2006; Roy Marples <uberlord@gentoo.org>:
Added warning about clamping MSS when running ppp on a router, #149525
diff --git a/Makefile b/Makefile
index 2c870b4..a3618a5 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@
# without an ebuild style package manager.
NAME = baselayout-vserver
-VERSION = 1.12.4
+VERSION = 1.12.2
PKG = $(NAME)-$(VERSION)
ARCH = x86
diff --git a/etc/rc.conf b/etc/rc.conf
index 0c137ca..871636a 100644
--- a/etc/rc.conf
+++ b/etc/rc.conf
@@ -13,6 +13,8 @@ EDITOR="/bin/nano"
#EDITOR="/usr/bin/vim"
#EDITOR="/usr/bin/emacs"
+# DISPLAYMANAGER has moved to /etc/conf.d/xdm
+#
# XSESSION is a new variable to control what window manager to start
# default with X if run with xdm, startx or xinit. The default behavior
# is to look in /etc/X11/Sessions/ and run the script in matching the
diff --git a/net-scripts/conf.d/net.example b/net-scripts/conf.d/net.example
index cf6f648..e1f7d08 100644
--- a/net-scripts/conf.d/net.example
+++ b/net-scripts/conf.d/net.example
@@ -418,7 +418,7 @@
# and may seem daunting, it is recommended that you read the pppd man page
# before enabling any of them
#pppd_ppp0=(
-# "maxfail 0" # WARNING: It's not recommended you use change this
+# "maxfail 0" # WARNING: It's not recommended you use this
# # if you don't specify maxfail then we assume 0
# "updetach" # If not set, "/etc/init.d/net.ppp0 start" will return
# # immediately, without waiting the link to come up
diff --git a/net-scripts/net/ifconfig.sh b/net-scripts/net/ifconfig.sh
index 48ae2ba..d28f4b2 100644
--- a/net-scripts/net/ifconfig.sh
+++ b/net-scripts/net/ifconfig.sh
@@ -182,7 +182,7 @@ ifconfig_set_name() {
# Outputs a space-separated list on stdout, in reverse order, for
# example "eth0:2 eth0:1"
ifconfig_get_aliases_rev() {
- ifconfig | grep -o "^$1:[0-9]* " | tac
+ ifconfig | grep -Eo "^$1:[^ ]+" | tac
}
# bool ifconfig_del_addresses(char *interface, bool onlyinet)
diff --git a/net-scripts/net/iproute2.sh b/net-scripts/net/iproute2.sh
index 377dc1e..d059f3f 100644
--- a/net-scripts/net/iproute2.sh
+++ b/net-scripts/net/iproute2.sh
@@ -132,7 +132,7 @@ iproute2_set_name() {
# example "eth0:2 eth0:1"
iproute2_get_aliases_rev() {
local iface=$( interface_device "$1" )
- ip addr show dev "${iface}" | grep -o "${iface}:[0-9].*" | tac
+ ip addr show dev "${iface}" | grep -Eo "${iface}:[^ ]+" | tac
}
# bool iproute2_del_addresses(char *interface, bool onlyinet)
diff --git a/net-scripts/net/iwconfig.sh b/net-scripts/net/iwconfig.sh
index e2ea762..4093078 100644
--- a/net-scripts/net/iwconfig.sh
+++ b/net-scripts/net/iwconfig.sh
@@ -64,7 +64,7 @@ iwconfig_exists() {
&& return 0
[[ ! -e /proc/net/wireless ]] && return 1
- [[ $(</proc/net/wireless) =~ $'\n'"[ \t]*$1:" ]]
+ grep -q "^[ \t]*$1:" /proc/net/wireless
}
# char* iwconfig_get_wep_status(char *interface)
@@ -74,7 +74,7 @@ iwconfig_exists() {
iwconfig_get_wep_status() {
local mode= status="disabled"
- if [[ $(iwconfig "$1") =~ $'\n'" +Encryption key:[0-9,A-F]" ]]; then
+ if iwconfig "$1" | grep -qE "^ +Encryption key:[0-9,A-F]" ; then
status="enabled"
mode=$(iwconfig "$1" | sed -n -e 's/^.*Security mode:\(.*[^ ]\).*/\1/p')
[[ -n ${mode} ]] && mode=" - ${mode}"
diff --git a/net-scripts/net/pppd.sh b/net-scripts/net/pppd.sh
index 7a19185..3b3a5b9 100644
--- a/net-scripts/net/pppd.sh
+++ b/net-scripts/net/pppd.sh
@@ -177,7 +177,8 @@ pppd_start() {
fi
if [[ " ${opts} " == *" plugin pppoatm.so "* ]] ; then
- if [[ ${!link} =~ '^[ \t]*([1-9]*[0-9]\.){1,2}[1-9]*[0-9][ \t]*$' ]] ; then
+ #if [[ ${!link} =~ '^[ \t]*([1-9]*[0-9]\.){1,2}[1-9]*[0-9][ \t]*$' ]] ; then
+ if echo "${!link}" | grep -qE '^[ \t]*([1-9]*[0-9]\.){1,2}[1-9]*[0-9][ \t]*$' ; then
insert_link_in_opts=0
else
ewarn "WARNING: An [itf.]vpi.vci ATM address was expected in ${link}"
diff --git a/net-scripts/net/tuntap.sh b/net-scripts/net/tuntap.sh
index 921438e..f5b316c 100644
--- a/net-scripts/net/tuntap.sh
+++ b/net-scripts/net/tuntap.sh
@@ -17,7 +17,7 @@ tunctl() {
#
# Sets up the dependancies for the module
tuntap_depend() {
- before interface macchanger
+ before bridge interface macchanger
functions interface_exists interface_type
variables tunctl
}
diff --git a/net-scripts/net/udhcpc.sh b/net-scripts/net/udhcpc.sh
index c374139..3dcf061 100644
--- a/net-scripts/net/udhcpc.sh
+++ b/net-scripts/net/udhcpc.sh
@@ -82,7 +82,7 @@ udhcpc_start() {
[[ -z ${!d} ]] && d="dhcp"
if [[ " ${!d} " != *" nosendhost "* ]]; then
- if [[ ! " ${opts}" =~ " -([hH] |-hostname=)" ]]; then
+ if [[ " ${opts} " != *" -"[hH]" "* && " ${opts} " != *" --hostname="* ]] ; then
local hname=$(hostname)
[[ -n ${hname} && ${hname} != "(none)" && ${hname} != "localhost" ]] \
&& opts="${opts} --hostname=${hname}"
diff --git a/sbin/rc-update b/sbin/rc-update
index 82120cf..5e52353 100755
--- a/sbin/rc-update
+++ b/sbin/rc-update
@@ -139,10 +139,10 @@ show() {
myscripts=$(cd "${ROOT}"etc/init.d; ls)
# Sanity check to make sure everything is kosher ...
- for x in $(find "${ROOT}"etc/runlevels -xtype l) ; do
- ewarn "Broken runlevel entry: ${x}"
+ for x in $(find "${ROOT}"etc/runlevels -type l) ; do
+ [[ -e ${x} ]] || ewarn "Broken runlevel entry: ${x}"
done
- for x in $(find "${ROOT}"etc/runlevels ! -type l -a ! -type d) ; do
+ for x in $(find "${ROOT}"etc/runlevels -maxdepth 1 ! -type l -a ! -type d) ; do
ewarn "Invalid runlevel entry: ${x}"
done
diff --git a/sbin/runscript.sh b/sbin/runscript.sh
index 2206f7a..deafe4c 100755
--- a/sbin/runscript.sh
+++ b/sbin/runscript.sh
@@ -591,7 +591,7 @@ for arg in $* ; do
rm -rf "${svcdir}/snapshot/$$"
mkdir -p "${svcdir}/snapshot/$$"
cp -pP "${svcdir}"/started/* "${svcdir}"/inactive/* \
- "${svcdir}/snapshot/$$/"
+ "${svcdir}/snapshot/$$/" 2>/dev/null
rm -f "${svcdir}/snapshot/$$/${SVCNAME}"
fi
@@ -637,7 +637,7 @@ for arg in $* ; do
rm -rf "${svcdir}/snapshot/$$"
mkdir -p "${svcdir}/snapshot/$$"
cp -pP "${svcdir}"/started/* "${svcdir}"/inactive/* \
- "${svcdir}/snapshot/$$/"
+ "${svcdir}/snapshot/$$/" 2>/dev/null
rm -f "${svcdir}/snapshot/$$/${SVCNAME}"
# Simple way to try and detect if the service use svc_{start,stop}
diff --git a/tarball.sh b/tarball.sh
index fb10d1d..23d356d 100755
--- a/tarball.sh
+++ b/tarball.sh
@@ -1,6 +1,6 @@
#!/bin/bash
export TMP="${TMP:-/tmp}"
-export V="1.12.3"
+export V="1.12.6"
export NAME="baselayout-vserver"
export DEST="${TMP}/${NAME}-${V}"
@@ -8,7 +8,7 @@ if [[ $1 != "-f" ]] ; then
echo "Performing sanity checks (run with -f to skip) ..."
# Check that we're updated
- svnfiles=$( svn status 2>&1 | egrep -v '^(U|P)' )
+ svnfiles=$( svn status --no-ignore 2>&1 | egrep -v '^(U|P)' )
if [[ -n ${svnfiles} ]] ; then
echo "Refusing to package tarball until svn is in sync:"
echo "$svnfiles"