summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-10-11 15:19:50 +0000
committerChristian Heim <phreak@gentoo.org>2006-10-11 15:19:50 +0000
commit509fde05d1bb67c4706099c2c02c372871f9f337 (patch)
tree08c5c001d4a7e6bab32d7cb01bc635062576f040 /vzctl/patches
parentUpdating the patch. (diff)
downloadmisc-509fde05d1bb67c4706099c2c02c372871f9f337.tar.gz
misc-509fde05d1bb67c4706099c2c02c372871f9f337.tar.bz2
misc-509fde05d1bb67c4706099c2c02c372871f9f337.zip
Removing unneeded patches.
svn path=/; revision=497
Diffstat (limited to 'vzctl/patches')
-rw-r--r--vzctl/patches/3.0.12/010_all_dev-nul.patch23
-rw-r--r--vzctl/patches/3.0.12/015_all_fix-cast-pointers.patch34
-rw-r--r--vzctl/patches/3.0.12/020_all_memleak-realloc.patch121
-rw-r--r--vzctl/patches/3.0.12/025_all_off-by-one.patch23
-rw-r--r--vzctl/patches/3.0.12/030_all_vzctl-sprintf-snprintf.patch107
-rw-r--r--vzctl/patches/3.0.12/035_all_remove-vename-on-destroy.patch35
-rw-r--r--vzctl/patches/3.0.12/040_all_segfault-long-opts.patch25
-rw-r--r--vzctl/patches/3.0.12/045_all_vzctl-enter-exit-msg.patch26
-rw-r--r--vzctl/patches/3.0.12/050_all_vzctl-enter-forward-msg-from-child.patch38
-rw-r--r--vzctl/patches/3.0.12/055_all_udev_rules.patch40
-rw-r--r--vzctl/patches/3.0.12/200_all_incorrect-spelling.patch76
-rw-r--r--vzctl/patches/3.0.12/205_all_ve-light.conf-sample.patch27
-rw-r--r--vzctl/patches/3.0.12/215_all_vzmigrate-mawk.patch25
13 files changed, 0 insertions, 600 deletions
diff --git a/vzctl/patches/3.0.12/010_all_dev-nul.patch b/vzctl/patches/3.0.12/010_all_dev-nul.patch
deleted file mode 100644
index 02145ef..0000000
--- a/vzctl/patches/3.0.12/010_all_dev-nul.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Kirill Korotaev <dev@openvz.org>
-Date: Tue, 22 Aug 2006 10:29:52 +0000 (+0400)
-Subject: Fix misprints in distro scripts
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=6b349c3d3adea85c73452d269a8278d86a35795f
-
-text misprints and /dev/nul fixes.
-
-http://bugzilla.openvz.org/show_bug.cgi?id=228
----
-
-Index: vzctl-3.0.11/etc/dists/scripts/debian-add_ip.sh
-===================================================================
---- vzctl-3.0.11.orig/etc/dists/scripts/debian-add_ip.sh
-+++ vzctl-3.0.11/etc/dists/scripts/debian-add_ip.sh
-@@ -82,7 +82,7 @@ d
- wq" | ed ${CFGFILE}.bak >/dev/null 2>&1
- echo -e "/iface ${iface}\\>
- .,+3d
--wq" | ed ${CFGFILE}.bak >/dev/nul 2>&1
-+wq" | ed ${CFGFILE}.bak >/dev/null 2>&1
- }
-
- function get_all_aliasid()
diff --git a/vzctl/patches/3.0.12/015_all_fix-cast-pointers.patch b/vzctl/patches/3.0.12/015_all_fix-cast-pointers.patch
deleted file mode 100644
index 86f6dd8..0000000
--- a/vzctl/patches/3.0.12/015_all_fix-cast-pointers.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Dmitry V. Levin <ldv@altlinux.org>
-Date: Fri, 25 Aug 2006 08:03:34 +0000 (+0400)
-Subject: vzlist: Fix cast from pointer to integer of different size warnings
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=3a772bf0e3145a1c255d823bca4f4cea6e035f7f
-
-vzlist: Fix cast from pointer to integer of different size warnings
-id_search_fn(): Take veid by reference like in veid_search_fn().
-find_ve(): Pass veid by reference like in check_veid_restr().
-
-Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
----
-
-Index: vzctl-3.0.11/src/vzlist.c
-===================================================================
---- vzctl-3.0.11.orig/src/vzlist.c
-+++ vzctl-3.0.11/src/vzlist.c
-@@ -607,7 +607,7 @@ void usage()
-
- int id_search_fn(const void* val1, const void* val2)
- {
-- return ((int)val1 - ((struct Cveinfo*)val2)->veid);
-+ return (*(int *)val1 - ((struct Cveinfo*)val2)->veid);
- }
-
- int veid_search_fn(const void* val1, const void* val2)
-@@ -708,7 +708,7 @@ void add_elem(struct Cveinfo *ve)
-
- inline struct Cveinfo *find_ve(int veid)
- {
-- return (struct Cveinfo *) bsearch((void*)veid, veinfo, n_veinfo,
-+ return (struct Cveinfo *) bsearch(&veid, veinfo, n_veinfo,
- sizeof(struct Cveinfo), id_search_fn);
- }
-
diff --git a/vzctl/patches/3.0.12/020_all_memleak-realloc.patch b/vzctl/patches/3.0.12/020_all_memleak-realloc.patch
deleted file mode 100644
index 98ae0e5..0000000
--- a/vzctl/patches/3.0.12/020_all_memleak-realloc.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-From: Igor Sukhih <igor@openvz.org>
-Date: Tue, 22 Aug 2006 13:39:35 +0000 (+0400)
-Subject: Fixed memory leaks in realloc()
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=48bada8af358255c7b54f437ba0002eabf0df368
-
-Fixed memory leaks in realloc()
----
-
-Index: vzctl-3.0.11/src/lib/list.c
-===================================================================
---- vzctl-3.0.11.orig/src/lib/list.c
-+++ vzctl-3.0.11/src/lib/list.c
-@@ -24,7 +24,7 @@
-
- char *list2str_c(char *name, char c, list_head_t *head)
- {
-- char *buf = NULL;
-+ char *buf = NULL, *tmp;
- int buf_len, len, r;
- char *sp, *ep;
- const int delta = 256;
-@@ -61,9 +61,12 @@ char *list2str_c(char *name, char c, lis
- int cur_len = sp - buf;
-
- buf_len += delta > len ? delta : len + 1;
-- buf = realloc(buf, buf_len);
-- if (buf == NULL)
-+ tmp = realloc(buf, buf_len);
-+ if (tmp == NULL) {
-+ free(buf);
- return NULL;
-+ }
-+ buf = tmp;
- ep = buf + buf_len;
- sp = buf + cur_len;
- }
-Index: vzctl-3.0.11/src/lib/net.c
-===================================================================
---- vzctl-3.0.11.orig/src/lib/net.c
-+++ vzctl-3.0.11/src/lib/net.c
-@@ -349,7 +349,7 @@ static inline int get_vps_ip_ioctl(vps_h
- {
- int ret = -1;
- struct vzlist_veipv4ctl veip;
-- uint32_t *addr;
-+ uint32_t *addr, *tmp;
- char buf[16];
- int i;
-
-@@ -366,9 +366,12 @@ static inline int get_vps_ip_ioctl(vps_h
- else if (ret <= veip.num)
- break;
- veip.num = ret;
-- addr = realloc(addr, veip.num * sizeof(*veip.ip));
-- if (addr == NULL)
-- return -1;
-+ tmp = realloc(addr, veip.num * sizeof(*veip.ip));
-+ if (tmp == NULL) {
-+ ret = -1;
-+ goto out;
-+ }
-+ addr = tmp;
- }
- if (ret > 0) {
- for (i = ret - 1; i >= 0; i--) {
-Index: vzctl-3.0.11/src/lib/script.c
-===================================================================
---- vzctl-3.0.11.orig/src/lib/script.c
-+++ vzctl-3.0.11/src/lib/script.c
-@@ -42,7 +42,7 @@ static char *envp_bash[] = {"HOME=/", "T
- int read_script(const char *fname, char *include, char **buf)
- {
- struct stat st;
-- char *p = NULL;
-+ char *tmp, *p = NULL;
- int fd, len = 0;
- char *inc;
-
-@@ -74,9 +74,10 @@ int read_script(const char *fname, char
- goto err;
- }
- if (*buf != NULL) {
-- *buf = realloc(*buf, st.st_size + len + 2);
-- if (*buf == NULL)
-+ tmp = realloc(*buf, st.st_size + len + 2);
-+ if (tmp == NULL)
- goto err;
-+ *buf = tmp;
- p = *buf + len;
- } else {
- *buf = malloc(st.st_size + 2);
-Index: vzctl-3.0.11/src/vzlist.c
-===================================================================
---- vzctl-3.0.11.orig/src/vzlist.c
-+++ vzctl-3.0.11/src/vzlist.c
-@@ -581,11 +581,13 @@ void *x_malloc(int size)
-
- void *x_realloc(void *ptr, int size)
- {
-- if ((ptr = realloc(ptr, size)) == NULL) {
-+ void *tmp;
-+
-+ if ((tmp = realloc(ptr, size)) == NULL) {
- printf("Error: unable to allocate %d bytes\n", size);
- exit(1);
- }
-- return ptr;
-+ return tmp;
- }
-
- void usage()
-@@ -1637,5 +1639,9 @@ int main(int argc, char **argv)
- return ret;
- print_ve();
- free_veinfo();
-+ if (host_pattern != NULL) free(host_pattern);
-+ if (name_pattern != NULL) free(name_pattern);
-+ if (f_order != NULL) free(f_order);
-+
- return 0;
- }
diff --git a/vzctl/patches/3.0.12/025_all_off-by-one.patch b/vzctl/patches/3.0.12/025_all_off-by-one.patch
deleted file mode 100644
index 58e4de2..0000000
--- a/vzctl/patches/3.0.12/025_all_off-by-one.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Dmitry V. Levin <ldv@altlinux.org>
-Date: Fri, 25 Aug 2006 07:57:09 +0000 (+0400)
-Subject: vzctl enter: Fix off-by-one error which resulted to uninitialized PATH.
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=24807ad04c47c4c799b9b7bb7188c07cdd9c31ca
-
-vzctl enter: Fix off-by-one error which resulted to uninitialized PATH.
-
-Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
----
-
-Index: vzctl-3.0.11/src/enter.c
-===================================================================
---- vzctl-3.0.11.orig/src/enter.c
-+++ vzctl-3.0.11/src/enter.c
-@@ -265,7 +265,7 @@ int do_enter(vps_handler *h, envid_t vei
- close(slave);
- if ((term = getenv("TERM")) != NULL) {
- snprintf(buf, sizeof(buf), "TERM=%s", term);
-- env[2] = buf;
-+ env[3] = buf;
- }
- execve("/bin/bash", arg, env);
- execve("/bin/sh", arg, env);
diff --git a/vzctl/patches/3.0.12/030_all_vzctl-sprintf-snprintf.patch b/vzctl/patches/3.0.12/030_all_vzctl-sprintf-snprintf.patch
deleted file mode 100644
index eeac84c..0000000
--- a/vzctl/patches/3.0.12/030_all_vzctl-sprintf-snprintf.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-From: Igor Sukhih <igor@openvz.org>
-Date: Tue, 22 Aug 2006 13:47:40 +0000 (+0400)
-Subject: Replace sprintf() -> snprintf() to avoid possible buffer overflow.
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=134f49e8f03dd3f74a73d13cf32a612946c36505
-
-Replace sprintf() -> snprintf() to avoid possible buffer overflow.
----
-
-Index: vzctl-3.0.11/src/vzlist.c
-===================================================================
---- vzctl-3.0.11.orig/src/vzlist.c
-+++ vzctl-3.0.11/src/vzlist.c
-@@ -48,6 +48,7 @@ static int n_veinfo = 0;
-
- static char g_outbuffer[4096] = "";
- static char *p_outbuffer = g_outbuffer;
-+static char *e_buf = g_outbuffer + sizeof(g_outbuffer) - 1;
- static char *host_pattern = NULL;
- static char *name_pattern = NULL;
- static int vzctlfd;
-@@ -90,29 +91,29 @@ static void print_ip(struct Cveinfo *p,
- /* Print functions */
- static void print_veid(struct Cveinfo *p, int index)
- {
-- p_outbuffer += sprintf(p_outbuffer, "%10d", p->veid);
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%10d", p->veid);
- }
-
- static void print_status(struct Cveinfo *p, int index)
- {
-- p_outbuffer += sprintf(p_outbuffer, "%-7s", ve_status[p->status]);
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%-7s", ve_status[p->status]);
- }
-
- static void print_laverage(struct Cveinfo *p, int index)
- {
- if (p->la == NULL)
-- p_outbuffer += sprintf(p_outbuffer, "%14s", "-");
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%14s", "-");
- else
-- p_outbuffer += sprintf(p_outbuffer, "%1.2f/%1.2f/%1.2f",
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%1.2f/%1.2f/%1.2f",
- p->la->la[0], p->la->la[1], p->la->la[2]);
- }
-
- static void print_cpulimit(struct Cveinfo *p, int index)
- {
- if (p->cpu == NULL)
-- p_outbuffer += sprintf(p_outbuffer, "%7s", "-");
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%7s", "-");
- else
-- p_outbuffer += sprintf(p_outbuffer, "%7lu",
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%7lu",
- p->cpu->limit[index]);
- }
-
-@@ -122,9 +123,9 @@ static void fn(struct Cveinfo *p, int in
- if (p->res == NULL || \
- (p->status != VE_RUNNING && \
- (index == 0 || index == 1 || index == 4))) \
-- p_outbuffer += sprintf(p_outbuffer, "%10s", "-"); \
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%10s", "-"); \
- else \
-- p_outbuffer += sprintf(p_outbuffer, "%10lu", \
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%10lu", \
- p->res->name[index]); \
- } \
-
-@@ -154,9 +155,9 @@ static void fn(struct Cveinfo *p, int in
- { \
- if (p->res == NULL || \
- (p->status != VE_RUNNING && (index == 0))) \
-- p_outbuffer += sprintf(p_outbuffer, "%10s", "-"); \
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%10s", "-"); \
- else \
-- p_outbuffer += sprintf(p_outbuffer, "%10lu", \
-+ p_outbuffer += snprintf(p_outbuffer, e_buf - p_outbuffer, "%10lu", \
- p->res->name[index]); \
- } \
-
-@@ -519,7 +520,7 @@ static void print_hostname(struct Cveinf
-
- if (p->hostname != NULL)
- str = p->hostname;
-- r = sprintf(p_outbuffer, "%-32s", str);
-+ r = snprintf(p_outbuffer, e_buf - p_outbuffer, "%-32s", str);
- if (last_field != NULL &&
- field_names[last_field->order].res_type != RES_HOSTNAME)
- {
-@@ -535,7 +536,7 @@ static void print_name(struct Cveinfo *p
-
- if (p->name != NULL)
- str = p->name;
-- r = sprintf(p_outbuffer, "%-32s", str);
-+ r = snprintf(p_outbuffer, e_buf - p_outbuffer, "%-32s", str);
- if (last_field != NULL &&
- field_names[last_field->order].res_type != RES_NAME)
- {
-@@ -559,7 +560,7 @@ static void print_ip(struct Cveinfo *p,
- if ((ch = strchr(str, ' ')) != NULL)
- *ch = 0;
- }
-- r = sprintf(p_outbuffer, "%-15s", str);
-+ r = snprintf(p_outbuffer, e_buf - p_outbuffer, "%-15s", str);
- if (last_field != NULL &&
- field_names[last_field->order].res_type != RES_IP)
- {
diff --git a/vzctl/patches/3.0.12/035_all_remove-vename-on-destroy.patch b/vzctl/patches/3.0.12/035_all_remove-vename-on-destroy.patch
deleted file mode 100644
index edb958b..0000000
--- a/vzctl/patches/3.0.12/035_all_remove-vename-on-destroy.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Igor Sukhih <igor@openvz.org>
-Date: Tue, 22 Aug 2006 13:40:41 +0000 (+0400)
-Subject: Remove VE name information on destroy
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=57f3c25ff637984a467936aec2cab1d849bfde49
-
-Remove VE name information on destroy
-
-http://bugzilla.openvz.org/show_bug.cgi?id=236
----
-
-Index: vzctl-3.0.11/src/vzctl-actions.c
-===================================================================
---- vzctl-3.0.11.orig/src/vzctl-actions.c
-+++ vzctl-3.0.11/src/vzctl-actions.c
-@@ -222,7 +222,19 @@ static int create(vps_handler *h, envid_
- static int destroy(vps_handler *h, envid_t veid, vps_param *g_p,
- vps_param *cmd_p)
- {
-- return vps_destroy(h, veid, &g_p->res.fs);
-+ int ret, id;
-+ char buf[STR_SIZE];
-+ char *name = g_p->res.name.name;
-+
-+ ret = vps_destroy(h, veid, &g_p->res.fs);
-+ if (!ret && name != NULL) {
-+ id = get_veid_by_name(name);
-+ if (id == veid) {
-+ snprintf(buf, sizeof(buf), VENAME_DIR "/%s.conf", name);
-+ unlink(buf);
-+ }
-+ }
-+ return ret;
- }
-
- static int parse_chkpnt_opt(int argc, char **argv, vps_param *vps_p)
diff --git a/vzctl/patches/3.0.12/040_all_segfault-long-opts.patch b/vzctl/patches/3.0.12/040_all_segfault-long-opts.patch
deleted file mode 100644
index 783396e..0000000
--- a/vzctl/patches/3.0.12/040_all_segfault-long-opts.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From: Dmitry V. Levin <ldv@altlinux.org>
-Date: Fri, 25 Aug 2006 07:59:19 +0000 (+0400)
-Subject: arpsend: Fix segfault when parsing long options
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=8ae927daa4a5c391e02bf15db02fde1ec92365f5
-
-arpsend: Fix segfault when parsing long options
-parse_options(): NULL-terminate long_options array.
-
-Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
----
-
-Index: vzctl-3.0.11/src/arpsend.c
-===================================================================
---- vzctl-3.0.11.orig/src/arpsend.c
-+++ vzctl-3.0.11/src/arpsend.c
-@@ -165,7 +165,8 @@ void parse_options (int argc, char **arg
- {"trg-arp", 1, NULL, 'T'},
- {"src-ip", 1, NULL, 'i'},
- {"trg-ip", 1, NULL, 'e'},
-- {"at-once", 0, NULL, 'o'}
-+ {"at-once", 0, NULL, 'o'},
-+ {NULL, 0, NULL, 0}
- };
-
- while ((c = getopt_long(argc, argv, short_options, long_options, NULL)) != -1)
diff --git a/vzctl/patches/3.0.12/045_all_vzctl-enter-exit-msg.patch b/vzctl/patches/3.0.12/045_all_vzctl-enter-exit-msg.patch
deleted file mode 100644
index 4b8cf44..0000000
--- a/vzctl/patches/3.0.12/045_all_vzctl-enter-exit-msg.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Igor Sukhih <igor@openvz.org>
-Date: Fri, 25 Aug 2006 07:55:33 +0000 (+0400)
-Subject: vzctl enter: fixed print exit message.
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=7b115e65ffce24039253b3cf14cf3021c18048cd
-
-vzctl enter: fixed print exit message.
-Extra \n was printed.
----
-
-Index: vzctl-3.0.11/src/enter.c
-===================================================================
---- vzctl-3.0.11.orig/src/enter.c
-+++ vzctl-3.0.11/src/enter.c
-@@ -303,10 +303,10 @@ err:
- if (errno != EINTR)
- break;
- if (WIFSIGNALED(status))
-- logger(0, 0, "got signal %d", WTERMSIG(status));
-+ fprintf(stdout, "got signal %d\n", WTERMSIG(status));
- if (!ret) {
- raw_off();
-- logger(0, 0, "exited from VPS %d\n", veid);
-+ fprintf(stdout, "exited from VPS %d\n", veid);
- }
- close(in[1]); close(out[0]);
- return 0;
diff --git a/vzctl/patches/3.0.12/050_all_vzctl-enter-forward-msg-from-child.patch b/vzctl/patches/3.0.12/050_all_vzctl-enter-forward-msg-from-child.patch
deleted file mode 100644
index ee8bd6f..0000000
--- a/vzctl/patches/3.0.12/050_all_vzctl-enter-forward-msg-from-child.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From: Dmitry V. Levin <ldv@altlinux.org>
-Date: Fri, 25 Aug 2006 07:42:05 +0000 (+0400)
-Subject: vzctl enter: Forward error messages from child process
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=52b79699c9e5f7b9f3bebd6141395c374b80e22a
-
-vzctl enter: Forward error messages from child process
-vzctl: do_enter():
- - In child, redirect stdout and stderr to pipe.
- - In parent, read child's output from pipe even if enter failed.
-
-Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
----
-
-Index: vzctl-3.0.11/src/enter.c
-===================================================================
---- vzctl-3.0.11.orig/src/enter.c
-+++ vzctl-3.0.11/src/enter.c
-@@ -231,6 +231,8 @@ int do_enter(vps_handler *h, envid_t vei
- close(in[1]); close(out[0]); close(st[0]);
- /* list of skipped fds -1 the end mark */
- close_fds(1, in[0], out[1], st[1], h->vzfd, -1);
-+ dup2(out[1], 1);
-+ dup2(out[1], 2);
- if ((ret = vz_chroot(root)))
- goto err;
- ret = vz_env_create_ioctl(h, veid, VE_ENTER);
-@@ -297,7 +299,10 @@ err:
- raw_on();
- e_loop(fileno(stdin), in[1], out[0], fileno(stdout));
- } else {
-- fprintf(stdout, "enter failed\n");
-+ fprintf(stdout, "enter into VPS %d failed\n", veid);
-+ set_not_blk(out[0]);
-+ while (stdredir(out[0], fileno(stdout)) == 0)
-+ ;
- }
- while ((waitpid(pid, &status, 0)) == -1)
- if (errno != EINTR)
diff --git a/vzctl/patches/3.0.12/055_all_udev_rules.patch b/vzctl/patches/3.0.12/055_all_udev_rules.patch
deleted file mode 100644
index e1d1e02..0000000
--- a/vzctl/patches/3.0.12/055_all_udev_rules.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/src/Makefile b/src/Makefile
-index 3008f1c..4f74157 100644
---- vzctl-3.0.11.orig/src/Makefile
-+++ vzctl-3.0.11/src/Makefile
-@@ -27,6 +27,7 @@ LIBSCRIPTSDIR = /usr/lib/vzctl/scripts/
- NETSCRIPTDIR = /etc/sysconfig/network-scripts
- CRONDDIR = /etc/cron.d
- INITDDIR = /etc/init.d
-+UDEVRULESDIR = /etc/udev/rules.d
- VZDIR = /vz
- CACHEDIR = $(VZDIR)/template/cache
- VZLOCKDIR = $(VZDIR)/lock
-@@ -73,6 +74,7 @@ LIBS = $(LIB_vzctl) $(LIB_fs)
-
- INITSCRIPTS = vz
- CRONSCRIPTS = vpsreboot vpsnetclean
-+UDEVRULES = 60-vzctl.rules
- SCRIPTS = vpsreboot vpsnetclean
- NETSCRIPTS = ifcfg-venet0 ifdown-venet ifup-venet
- VE0CONFIG = 0.conf
-@@ -189,6 +191,11 @@ inst-cron:
- $(INSTALL) -m 644 ../etc/cron.d/$$file $(DESTDIR)$(CRONDDIR)/$$file; \
- done
-
-+inst-udev:
-+ for file in $(UDEVRULES); do \
-+ $(INSTALL) -m 644 ../etc/udev/$$file $(DESTDIR)$(UDEVDIR)/$$file; \
-+ done
-+
- inst-dirs:
- $(INSTALL) -d $(DESTDIR)$(CONFDIR)
- $(INSTALL) -d $(DESTDIR)$(SBINDIR)
-@@ -197,6 +204,7 @@ inst-dirs:
- $(INSTALL) -d $(DESTDIR)$(SCRIPTSDIR)
- $(INSTALL) -d $(DESTDIR)$(CRONDDIR)
- $(INSTALL) -d $(DESTDIR)$(INITDDIR)
-+ $(INSTALL) -d $(DESTDIR)$(UDEVRULESDIR)
- $(INSTALL) -d $(DESTDIR)$(VZLOCKDIR)
- $(INSTALL) -d $(DESTDIR)$(VZDUMPDIR)
- $(INSTALL) -d $(DESTDIR)$(NAMESDIR)
diff --git a/vzctl/patches/3.0.12/200_all_incorrect-spelling.patch b/vzctl/patches/3.0.12/200_all_incorrect-spelling.patch
deleted file mode 100644
index f6c6738..0000000
--- a/vzctl/patches/3.0.12/200_all_incorrect-spelling.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From: Kirill Korotaev <dev@openvz.org>
-Date: Tue, 22 Aug 2006 10:29:52 +0000 (+0400)
-Subject: Fix misprints in distro scripts
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=6b349c3d3adea85c73452d269a8278d86a35795f
-
-Fix misprints in distro scripts
-text misprints fixes.
-
-http://bugzilla.openvz.org/show_bug.cgi?id=228
----
-
-Index: vzctl-3.0.11/etc/dists/scripts/debian-add_ip.sh
-===================================================================
---- vzctl-3.0.11.orig/etc/dists/scripts/debian-add_ip.sh
-+++ vzctl-3.0.11/etc/dists/scripts/debian-add_ip.sh
-@@ -25,7 +25,7 @@
- # Optional parameters:
- # VE_STATE - state of VE; could be one of:
- # starting | stopping | running | stopped
--# IPDELALL - deleet all ip addresse
-+# IPDELALL - delete all ip addresses
- #
- VENET_DEV=venet0
- LOOPBACK=lo
-Index: vzctl-3.0.11/etc/dists/scripts/redhat-del_ip.sh
-===================================================================
---- vzctl-3.0.11.orig/etc/dists/scripts/redhat-del_ip.sh
-+++ vzctl-3.0.11/etc/dists/scripts/redhat-del_ip.sh
-@@ -22,7 +22,7 @@
- # Required parameters:
- # IP_ADDR - IPs to delete, several addresses should be divided by space
- # Optional parameters:
--# IPDELALL - deleet all ip addresses
-+# IPDELALL - delete all ip addresses
- VENET_DEV=venet0
- VENET_DEV_CFG=ifcfg-${VENET_DEV}
- IFCFG_DIR=/etc/sysconfig/network-scripts/
-Index: vzctl-3.0.11/etc/dists/scripts/slackware-9.x_del_ip.sh
-===================================================================
---- vzctl-3.0.11.orig/etc/dists/scripts/slackware-9.x_del_ip.sh
-+++ vzctl-3.0.11/etc/dists/scripts/slackware-9.x_del_ip.sh
-@@ -22,7 +22,7 @@
- # Required parameters:
- # IP_ADDR - IPs to delete, several addresses should be divided by space
- # Optional parameters:
--# IPDELALL - deleet all ip addresses
-+# IPDELALL - delete all ip addresses
- IFCFG=/etc/rc.d/rc.inet1
-
- function del_ip()
-Index: vzctl-3.0.11/etc/dists/scripts/slackware-del_ip.sh
-===================================================================
---- vzctl-3.0.11.orig/etc/dists/scripts/slackware-del_ip.sh
-+++ vzctl-3.0.11/etc/dists/scripts/slackware-del_ip.sh
-@@ -22,7 +22,7 @@
- # Required parameters:
- # IP_ADDR - IPs to delete, several addresses should be divided by space
- # Optional parameters:
--# IPDELALL - deleet all ip addresses
-+# IPDELALL - delete all ip addresses
- IFCFG=/etc/rc.d/rc.inet1.conf
-
- function del_ip()
-Index: vzctl-3.0.11/etc/dists/scripts/suse-8.x_del_ip.sh
-===================================================================
---- vzctl-3.0.11.orig/etc/dists/scripts/suse-8.x_del_ip.sh
-+++ vzctl-3.0.11/etc/dists/scripts/suse-8.x_del_ip.sh
-@@ -22,7 +22,7 @@
- # Required parameters:
- # IP_ADDR - IPs to delete, several addresses should be divided by space
- # Optional parameters:
--# IPDELALL - deleet all ip addresses
-+# IPDELALL - delete all ip addresses
- VENET_DEV=venet0
- VENET_DEV_CFG=ifcfg-${VENET_DEV}
- IFCFG_DIR=/etc/sysconfig/network/
diff --git a/vzctl/patches/3.0.12/205_all_ve-light.conf-sample.patch b/vzctl/patches/3.0.12/205_all_ve-light.conf-sample.patch
deleted file mode 100644
index 2358576..0000000
--- a/vzctl/patches/3.0.12/205_all_ve-light.conf-sample.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From: Igor Sukhih <igor@openvz.org>
-Date: Tue, 22 Aug 2006 13:34:37 +0000 (+0400)
-Subject: Increase dgramrcvbuf and othersockbuf in ve-light.conf-sample
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=5478976ff1f979e52dec140df556d1df7f2790de
-
-Increase dgramrcvbuf and othersockbuf in ve-light.conf-sample
-ve-light.conf-sample is too much light,
-so that vzcfgvalidate recommends to increase the limits.
-
-http://bugzilla.openvz.org/show_bug.cgi?id=234
----
-
-Index: vzctl-3.0.11/etc/ve-light.conf-sample
-===================================================================
---- vzctl-3.0.11.orig/etc/ve-light.conf-sample
-+++ vzctl-3.0.11/etc/ve-light.conf-sample
-@@ -28,8 +28,8 @@ VMGUARPAGES="1725:2147483647"
- KMEMSIZE="1740800:1847296"
- TCPSNDBUF="159744:262144"
- TCPRCVBUF="159744:262144"
--OTHERSOCKBUF="61440:163840"
--DGRAMRCVBUF="32768:32768"
-+OTHERSOCKBUF="135168:196608"
-+DGRAMRCVBUF="135168:196608"
- OOMGUARPAGES="1725:2147483647"
- # Auxiliary parameters
- LOCKEDPAGES="4:4"
diff --git a/vzctl/patches/3.0.12/215_all_vzmigrate-mawk.patch b/vzctl/patches/3.0.12/215_all_vzmigrate-mawk.patch
deleted file mode 100644
index cdb0225..0000000
--- a/vzctl/patches/3.0.12/215_all_vzmigrate-mawk.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From: Kirill Korotaev <dev@openvz.org>
-Date: Tue, 22 Aug 2006 10:34:04 +0000 (+0400)
-Subject: Fix vzmigrate to work with mawk (not gawk only)
-X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff;h=ca21ee121297cd2e230895078fd3153230e37794
-
-Fix vzmigrate to work with mawk (not gawk only)
-http://bugzilla.openvz.org/show_bug.cgi?id=231
-
-Signed-Off-By: Thorsten Schifferdecker <tsd@debian.systs.org>
-Signed-Off-By: Kirill Korotaev <dev@openvz.org>
----
-
-Index: vzctl-3.0.11/vzmigrate
-===================================================================
---- vzctl-3.0.11.orig/vzmigrate
-+++ vzctl-3.0.11/vzmigrate
-@@ -375,7 +375,7 @@ fi
-
- log 1 "Syncing private"
- if ! rsync -aH --progress "$VE_PRIVATE" "root@$host:${VE_PRIVATE%/*}" | \
-- grep "% of" | awk --assign ORS="\r" '{print $10}'; then
-+ grep "% of" | awk -v ORS="\r" '{print $10}'; then
- log 1 "Failed to sync VPS private areas"
- undo_quota_on
- exit $MIG_ERR_COPY