summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2006-06-19 07:38:00 +0000
committerBenedikt Boehm <hollow@gentoo.org>2006-06-19 07:38:00 +0000
commit0b45564ef071a2e485489a8962e8981bfbcbf30b (patch)
tree09c20990598a4dc2ade326a55f624f57c15843ab /sys-libs/libvserver-svn/libvserver-svn-9999.ebuild
downloadoverlay-0b45564ef071a2e485489a8962e8981bfbcbf30b.tar.gz
overlay-0b45564ef071a2e485489a8962e8981bfbcbf30b.tar.bz2
overlay-0b45564ef071a2e485489a8962e8981bfbcbf30b.zip
initial live svn ebuilds
svn path=/; revision=1
Diffstat (limited to 'sys-libs/libvserver-svn/libvserver-svn-9999.ebuild')
-rw-r--r--sys-libs/libvserver-svn/libvserver-svn-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-libs/libvserver-svn/libvserver-svn-9999.ebuild b/sys-libs/libvserver-svn/libvserver-svn-9999.ebuild
new file mode 100644
index 0000000..c63527a
--- /dev/null
+++ b/sys-libs/libvserver-svn/libvserver-svn-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libvserver/libvserver-0.4.ebuild,v 1.1 2005/10/01 13:07:35 hollow Exp $
+
+inherit toolchain-funcs subversion
+
+DESCRIPTION="Linux-VServer syscall library"
+HOMEPAGE="http://dev.gentoo.org/~hollow/vserver/libvserver"
+#SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+
+ESVN_REPO_URI="http://dev.croup.de/repos/libvserver/trunk"
+ESVN_BOOTSTRAP="make -f Makefile.svn"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}