summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-09-15 17:14:06 +0000
committerJakub Moc <jakub@gentoo.org>2007-09-15 17:14:06 +0000
commit8dfc18e4803bdf29d3179d6f0e2026cf403e5bbc (patch)
treef5367acaf26b4dfabe4643a63b62791a380c2183 /www-apps/linpha
parentAdd use flags for www-apps/webcalendar (diff)
downloadwebapps-experimental-8dfc18e4803bdf29d3179d6f0e2026cf403e5bbc.tar.gz
webapps-experimental-8dfc18e4803bdf29d3179d6f0e2026cf403e5bbc.tar.bz2
webapps-experimental-8dfc18e4803bdf29d3179d6f0e2026cf403e5bbc.zip
www-apps/linpha: New ebuild, Bug 192166
svn path=/experimental/; revision=646
Diffstat (limited to 'www-apps/linpha')
-rw-r--r--www-apps/linpha/ChangeLog8
-rw-r--r--www-apps/linpha/Manifest5
-rw-r--r--www-apps/linpha/files/postinstall-en.txt43
-rw-r--r--www-apps/linpha/linpha-1.3.2.ebuild62
-rw-r--r--www-apps/linpha/metadata.xml5
5 files changed, 123 insertions, 0 deletions
diff --git a/www-apps/linpha/ChangeLog b/www-apps/linpha/ChangeLog
new file mode 100644
index 0000000..3b03780
--- /dev/null
+++ b/www-apps/linpha/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for www-apps/linpha
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 15 Sep 2007; Jakub Moc <jakub@gentoo.org> +files/postinstall-en.txt,
+ +metadata.xml, +linpha-1.3.2.ebuild:
+ New ebuild, Bug 192166
+
diff --git a/www-apps/linpha/Manifest b/www-apps/linpha/Manifest
new file mode 100644
index 0000000..6b589d9
--- /dev/null
+++ b/www-apps/linpha/Manifest
@@ -0,0 +1,5 @@
+AUX postinstall-en.txt 1559 RMD160 300beec1bc6d329f04598b48239af746805d4f95 SHA1 786d72334e34a890086bad2a41b9eb33ebc39345 SHA256 23ba767641745277b4bc7870733d96f424e3e07959a7d77517174b213dd8e0cb
+DIST linpha-1.3.2.tar.bz2 1212566 RMD160 83887a2a5aebf0ba33d2302e27d4b9d3f1cdf3b5 SHA1 f73b62c110a9c22c17eb998c79d2e8fc5f092b8c SHA256 418c0877aa26877bf3dc7d39bb756dd7c4ce40788bcf6b2b89393b1624ecd3da
+EBUILD linpha-1.3.2.ebuild 1636 RMD160 a231b8cd1268adb06b9a82b4da89b14597f5466c SHA1 90fd2cf3fce5b6be76855bf91b5e0416507b39e6 SHA256 aaa550600539419afb4b19cd681e8ef8d621df33bee05e2ae9dd80a0f753e460
+MISC ChangeLog 253 RMD160 78e86811d8127dbb071355fd2d2621692b05a3c8 SHA1 4fdca145e36aa6bf99a9dc42f95d0029e54cfc20 SHA256 63369389ef2d235eb11d6456957bf59106386ed54a0bbf79a94be8c40ab0335a
+MISC metadata.xml 162 RMD160 0b015f5ff17c4d8e7aee826d48b326cc19b1fed4 SHA1 671b30dafbea01228c8bb606af451a0795922840 SHA256 84ff2fc6c9a4af1b9dbe32aa81ab84c2958bc1bd65a9977686df2dcab6e420d0
diff --git a/www-apps/linpha/files/postinstall-en.txt b/www-apps/linpha/files/postinstall-en.txt
new file mode 100644
index 0000000..e552ff9
--- /dev/null
+++ b/www-apps/linpha/files/postinstall-en.txt
@@ -0,0 +1,43 @@
+0. Finishing install
+Now point your browser to http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/install/install.php
+and follow the install instructions.
+
+1. PHP requirements
+
+The following settings are required to run LinPHA:
+
+ * session.save_handler = files
+ * session.save_path = /tmp (or set to a valid writable directory)
+
+Suggested PHP settings:
+
+NOTE: Gentoo does NOT recommend turning safe_mode off, despite the
+below upstream recommendations.
+
+${PN} should work correctly even if these settings aren't set to our
+suggested values, but if you are able to change them, do it...
+
+ * magic_quotes_gpc = On
+ * magic_quotes_runtime = Off
+ * magic_quotes_sybase = Off
+ * max_execution_ time = 300
+ * memory_limit = "20M"
+ * session.use_cookies = 1
+ * session.use_trans_sid = 0
+ * file_uploads = On
+ * upload_tmp_dir = /tmp (or set to a valid writable directory)
+ * upload_max_filesize "8M"
+ * safe_mode = Off
+ * open_basedir not set
+ * disable_functions not set
+
+Restricted features if safe_mode is on:
+
+ * No special characters in album- and filenames allowed. (spaces are allowed).
+ Characters and signs like ', ", etc. are not valid - only in combination with ImageMagick
+ * Watermark only works with images but not with text overlays (because the convert string
+ contains " ' " ...) - only in combination with ImageMagick.
+ * Download of zipped albums requires some manual hacks.
+ * To get best compatibility, all files should have the same owner and group,
+ even the images itself.
+
diff --git a/www-apps/linpha/linpha-1.3.2.ebuild b/www-apps/linpha/linpha-1.3.2.ebuild
new file mode 100644
index 0000000..9e0a50e
--- /dev/null
+++ b/www-apps/linpha/linpha-1.3.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit webapp depend.php
+
+DESCRIPTION="An easy to use, multilingual, flexible photo/image archive/album/gallery written in PHP."
+HOMEPAGE="http://linpha.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 || ( BSD LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="imagemagick"
+
+RDEPEND="virtual/httpd-cgi
+ imagemagick? ( media-gfx/imagemagick )"
+
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ local dbflags="mysql mysqli postgres sqlite"
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} || \
+ ( ! use imagemagick && ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ) ; then
+ eerror
+ eerror "${PN} requires PHP with at least one of ${dbflags} USE flags enabled"
+ ! use imagemagick && eerror "and either gd or gd-external USE flag enabled"
+ eerror
+ die "Re-install ${PHP_PKG}."
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ChangeLog
+ rm -f ChangeLog README
+ dohtml docs/*
+
+ cp -R * "${D}"${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/include/db_connect.php
+ webapp_serverowned ${MY_HTDOCSDIR}/albums
+ webapp_serverowned ${MY_HTDOCSDIR}/sql
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "Using some sort of PHP optimizer is highly recommended for ${PN}."
+ elog "If you have not installed one yet, emerge one of the following ebuilds:"
+ elog "\t dev-php[45]/eaccelerator"
+ elog "\t dev-php[45]/pecl-apc"
+ elog "\t dev-php[45]/ZendOptimizer"
+ elog
+
+ webapp_pkg_postinst
+}
diff --git a/www-apps/linpha/metadata.xml b/www-apps/linpha/metadata.xml
new file mode 100644
index 0000000..6632069
--- /dev/null
+++ b/www-apps/linpha/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+</pkgmetadata>