summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2008-02-19 13:51:27 +0000
committerJakub Moc <jakub@gentoo.org>2008-02-19 13:51:27 +0000
commit0a292ba4efbf22b9fdead9208db037264837f910 (patch)
tree9a51678ba9d3fc9e35ade9d920b916bb9dd84de3 /www-apps/openx
parentNuke pointless variable (diff)
downloadwebapps-experimental-0a292ba4efbf22b9fdead9208db037264837f910.tar.gz
webapps-experimental-0a292ba4efbf22b9fdead9208db037264837f910.tar.bz2
webapps-experimental-0a292ba4efbf22b9fdead9208db037264837f910.zip
www-apps/openx: New ebuild, Bug 203725
svn path=/experimental/; revision=821
Diffstat (limited to 'www-apps/openx')
-rw-r--r--www-apps/openx/ChangeLog8
-rw-r--r--www-apps/openx/Manifest5
-rw-r--r--www-apps/openx/files/postinstall-en-2.4.txt21
-rw-r--r--www-apps/openx/metadata.xml5
-rw-r--r--www-apps/openx/openx-2.4.4.ebuild69
5 files changed, 108 insertions, 0 deletions
diff --git a/www-apps/openx/ChangeLog b/www-apps/openx/ChangeLog
new file mode 100644
index 0000000..70c37a0
--- /dev/null
+++ b/www-apps/openx/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for www-apps/openx
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 19 Feb 2008; Jakub Moc <jakub@gentoo.org> +files/postinstall-en-2.4.txt,
+ +metadata.xml, +openx-2.4.4.ebuild:
+ New ebuild, Bug 203725
+
diff --git a/www-apps/openx/Manifest b/www-apps/openx/Manifest
new file mode 100644
index 0000000..b59fa3c
--- /dev/null
+++ b/www-apps/openx/Manifest
@@ -0,0 +1,5 @@
+AUX postinstall-en-2.4.txt 811 RMD160 3d6fe14ccb7e45d3f7ec8b61c8e0c2b903a42696 SHA1 5fea7e22805595018b1db6fa5c00f73808f3ffac SHA256 8dc80a1f56956f5fc5b3f88bae37f8ae29a4adfb6220bfe2bffd1bc51fdcf11d
+DIST openx-2.4.4.zip 6978678 RMD160 42ec449d717d4f80659aa750a5bbfff9ff6fe02c SHA1 9ee0cbdfe627b1c4b5fe7ac5a08777f4ae78852a SHA256 751f60e4b7323c5817050c33787de76751b3a58c15967e26248682ca5f4b91bd
+EBUILD openx-2.4.4.ebuild 2221 RMD160 2b7bf57f127c524cc327d33ab316f0fe4169a220 SHA1 d12c69815fb87edc2083e5490e89fec9e0528282 SHA256 9b3c1564661b4976788f067693cb13e22e929c9118ffed68c7e67f47e341d109
+MISC ChangeLog 254 RMD160 775d17b2f9110c5084537c25778599d25feeeff1 SHA1 d6d0c7ccb8b8a22f9c85860f007258aff50fdb40 SHA256 884afed6c65e5816057d71403da50f501b508cb20c3f94a5b457ce063436a8a2
+MISC metadata.xml 162 RMD160 0b015f5ff17c4d8e7aee826d48b326cc19b1fed4 SHA1 671b30dafbea01228c8bb606af451a0795922840 SHA256 84ff2fc6c9a4af1b9dbe32aa81ab84c2958bc1bd65a9977686df2dcab6e420d0
diff --git a/www-apps/openx/files/postinstall-en-2.4.txt b/www-apps/openx/files/postinstall-en-2.4.txt
new file mode 100644
index 0000000..bffba21
--- /dev/null
+++ b/www-apps/openx/files/postinstall-en-2.4.txt
@@ -0,0 +1,21 @@
+To complete the install:
+
+1) Use a web browser to visit http://${VHOST_HOSTNAME}${VHOST_APPDIR}
+ and follow the instructions in the installation wizard to complete the installation.
+
+ Recommended PHP settings to check before configuring:
+
+ magic_quotes_runtime Off
+ safe_mode Off
+ file_uploads On
+
+2) After the configuration is finished, do not forget to change the permissions
+ on ${MY_INSTALLDIR}/config.inc.php to safer ones so that the file is not writeable
+ by your webserver!
+
+3) Use cron to run the scripts/maintenance/maintenance.php
+ script, with the domain of your site as a parameter, every hour, eg:
+
+ 0 * * * * /usr/bin/php -q ${MY_INSTALLDIR}/scripts/maintenance/maintenance.php ${VHOST_HOSTNAME}
+
+See http://www.openx.org/support/documentation for detailed documentation.
diff --git a/www-apps/openx/metadata.xml b/www-apps/openx/metadata.xml
new file mode 100644
index 0000000..6632069
--- /dev/null
+++ b/www-apps/openx/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+</pkgmetadata>
diff --git a/www-apps/openx/openx-2.4.4.ebuild b/www-apps/openx/openx-2.4.4.ebuild
new file mode 100644
index 0000000..e9b6d50
--- /dev/null
+++ b/www-apps/openx/openx-2.4.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit webapp depend.php
+
+DESCRIPTION="Advanced web-based ad management"
+HOMEPAGE="http://www.openx.org/"
+SRC_URI="http://www.openx.org/downloads/${P}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="gd"
+
+# TODO: Wipe all the bundled PEAR stuff and depend on appropriate
+# dev-php/PEAR-* ebuilds instead.
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/cron"
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ local flags="crypt ctype pcre session unicode xml zlib"
+ local dbflags="mysql mysqli postgres"
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli postgres \
+ || use gd && ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "${flags}"
+ eerror
+ eerror "as well as at least one of ${dbflags} USE flags enabled"
+ use gd && eerror "and either gd or gd-external USE flag enabled."
+ # die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="README.txt RELEASE_NOTES.txt UPGRADE.txt docs/KNOWN_ISSUES.txt"
+ dodoc ${docs}
+ rm -rf ${docs} INSTALL.txt docs/
+
+ cp -r . "${D}${MY_HTDOCSDIR}"
+
+ touch "${D}${MY_HTDOCSDIR}"/config.inc.php
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.4.txt
+
+ for dir in var var/cache var/plugins var/plugins/cache var/plugins/config var/templates_compiled www/images ; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${dir}
+ done
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ if ! use gd ; then
+ ewarn "If you would like to have support for displaying graphs in the ${PN}"
+ ewarn "statistics pages, you will also need to make sure that PHP is installed"
+ ewarn "with support for GD."
+ fi
+ webapp_pkg_postinst
+}