summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2005-12-13 13:48:05 +0000
committerRenat Lumpau <rl03@gentoo.org>2005-12-13 13:48:05 +0000
commit699f58b966380eb50227703b9e9b69798a40a9b5 (patch)
treef08057f0754a2f77e2812cc5efe042766abf5383 /www-apps/phpdig
parentReorganizing part 2 (diff)
downloadwebapps-experimental-699f58b966380eb50227703b9e9b69798a40a9b5.tar.gz
webapps-experimental-699f58b966380eb50227703b9e9b69798a40a9b5.tar.bz2
webapps-experimental-699f58b966380eb50227703b9e9b69798a40a9b5.zip
Mass move to experimental
svn path=/experimental/; revision=19
Diffstat (limited to 'www-apps/phpdig')
-rw-r--r--www-apps/phpdig/ChangeLog7
-rw-r--r--www-apps/phpdig/Manifest4
-rw-r--r--www-apps/phpdig/files/digest-phpdig-1.8.9_rc11
-rw-r--r--www-apps/phpdig/files/postinstall-en.txt8
-rw-r--r--www-apps/phpdig/phpdig-1.8.9_rc1.ebuild45
5 files changed, 65 insertions, 0 deletions
diff --git a/www-apps/phpdig/ChangeLog b/www-apps/phpdig/ChangeLog
new file mode 100644
index 0000000..ceea5ab
--- /dev/null
+++ b/www-apps/phpdig/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for www-apps/phpdig
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 11 Dec 2005; Renat Lumpau <rl03@gentoo.org> ChangeLog:
+ Initial ebuild wrt bug #78388.
+
diff --git a/www-apps/phpdig/Manifest b/www-apps/phpdig/Manifest
new file mode 100644
index 0000000..6e44907
--- /dev/null
+++ b/www-apps/phpdig/Manifest
@@ -0,0 +1,4 @@
+MD5 242292bf24c7f9a62a5924b16a015ea5 phpdig-1.8.9_rc1.ebuild 1025
+MD5 f8ef8a517dee600405e2fc5e25817915 ChangeLog 207
+MD5 f327bec0ced162edbe6e035376793546 files/digest-phpdig-1.8.9_rc1 65
+MD5 915df1bdd9fc0d0155ff8953691f277c files/postinstall-en.txt 212
diff --git a/www-apps/phpdig/files/digest-phpdig-1.8.9_rc1 b/www-apps/phpdig/files/digest-phpdig-1.8.9_rc1
new file mode 100644
index 0000000..f2bac1b
--- /dev/null
+++ b/www-apps/phpdig/files/digest-phpdig-1.8.9_rc1
@@ -0,0 +1 @@
+MD5 28b784436da45bbabea11900ca58c4ff phpdig-1.8.9-rc1.zip 564442
diff --git a/www-apps/phpdig/files/postinstall-en.txt b/www-apps/phpdig/files/postinstall-en.txt
new file mode 100644
index 0000000..f42553c
--- /dev/null
+++ b/www-apps/phpdig/files/postinstall-en.txt
@@ -0,0 +1,8 @@
+You are almost done!
+
+ 0. Edit ${MY_INSTALLDIR}/includes/config.php
+ to set your username and password.
+
+ 1. Login on
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/admin/install.php
+ and follow the directions.
diff --git a/www-apps/phpdig/phpdig-1.8.9_rc1.ebuild b/www-apps/phpdig/phpdig-1.8.9_rc1.ebuild
new file mode 100644
index 0000000..ccf2003
--- /dev/null
+++ b/www-apps/phpdig/phpdig-1.8.9_rc1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Source: http://bugs.gentoo.org/show_bug.cgi?id=78388
+# Submitted-By: Daniel Webert
+# Reviewed-By: rl03 2005-12-11
+
+inherit webapp
+
+MY_PV=${PV/_/-}
+DESCRIPTION="PhpDig is a web spider and search engine written in PHP, using a
+MySQL database and flat file support"
+HOMEPAGE="http://www.phpdig.net"
+SRC_URI="http://www.phpdig.net/scripts/${PN}-${MY_PV}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+S=${WORKDIR}/${PN}-${MY_PV}
+
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-db/mysql
+ virtual/php
+ net-www/apache"
+
+src_install () {
+ webapp_src_preinst
+ local files="admin/temp includes text_content"
+
+ dodoc documentation/*.txt UPGRADE.txt
+ dohtml documentation/*.html
+
+ cp -R . ${D}/${MY_HTDOCSDIR}
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_configfile ${MY_HTDOCSDIR}/includes/config.php
+
+ webapp_src_install
+}