summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-11-25 14:17:37 +0000
committerJakub Moc <jakub@gentoo.org>2007-11-25 14:17:37 +0000
commit8f44fa073e1470ceff989750ef4fb6eff2be4bad (patch)
treeb61d0f780ec5b254413cfe6e093529162a7b3d4f /www-apps/sugarcrm/sugarcrm-4.5.1h.ebuild
parentwww-apps/sphpblog: Version bump, remove old. (diff)
downloadwebapps-experimental-8f44fa073e1470ceff989750ef4fb6eff2be4bad.tar.gz
webapps-experimental-8f44fa073e1470ceff989750ef4fb6eff2be4bad.tar.bz2
webapps-experimental-8f44fa073e1470ceff989750ef4fb6eff2be4bad.zip
www-apps/sugarcrm: Version bump, remove old, drop PHP4 support.
svn path=/experimental/; revision=701
Diffstat (limited to 'www-apps/sugarcrm/sugarcrm-4.5.1h.ebuild')
-rw-r--r--www-apps/sugarcrm/sugarcrm-4.5.1h.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/www-apps/sugarcrm/sugarcrm-4.5.1h.ebuild b/www-apps/sugarcrm/sugarcrm-4.5.1h.ebuild
new file mode 100644
index 0000000..46aff9a
--- /dev/null
+++ b/www-apps/sugarcrm/sugarcrm-4.5.1h.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Source: http://bugs.gentoo.org/show_bug.cgi?id=103295
+# Submitted-By: SteveB
+# Reviewed-By: wrobel 2005-12-19
+
+inherit webapp depend.php
+
+MY_PN="SugarOS"
+DESCRIPTION="A complete CRM and groupware system for businesses of all sizes."
+HOMEPAGE="http://www.sugarcrm.com"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.zip"
+
+LICENSE="MPL-1.1 SPL-1.1.3"
+KEYWORDS="~x86"
+S=${WORKDIR}/${MY_PN}-Full-${PV}
+
+IUSE="curl imap json zlib"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-php/PEAR-DB
+ dev-php/PEAR-Cache_Lite
+ dev-php/PEAR-Mail_Mime
+ virtual/httpd-cgi"
+
+need_php5_httpd
+
+pkg_setup() {
+ local flags="mysql ssl unicode xml"
+ for f in curl imap json zlib ; do
+ use ${f} && flags="${flags} ${f}"
+ done
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} ; then
+ eerror "${PHP_PKG} needs to be reinstalled with all of ${flags} USE flags enabled"
+ die "Reinstall ${PHP_PKG} with the above-stated USE flags."
+ fi
+
+ webapp_pkg_setup
+}
+
+src_install () {
+ webapp_src_preinst
+
+ cd "${S}"
+
+ dodoc README.txt
+ rm -f {INSTALLATION,LICENSE,PATCH,README,UPGRADE}.txt
+
+ einfo "Installing main files"
+ cp -R . "${D}"/${MY_HTDOCSDIR}
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_configfile ${MY_HTDOCSDIR}/config.php
+ webapp_configfile ${MY_HTDOCSDIR}/.htaccess
+
+ for foo in cache custom data modules ; do
+ webapp_serverowned -R ${MY_HTDOCSDIR}/${foo}
+ done
+ webapp_serverowned ${MY_HTDOCSDIR}/config.php
+
+ webapp_src_install
+}