summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ganglia-webfrontend/ganglia-webfrontend-3.0.4.ebuild')
-rw-r--r--sys-cluster/ganglia-webfrontend/ganglia-webfrontend-3.0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-cluster/ganglia-webfrontend/ganglia-webfrontend-3.0.4.ebuild b/sys-cluster/ganglia-webfrontend/ganglia-webfrontend-3.0.4.ebuild
new file mode 100644
index 0000000..3a0c347
--- /dev/null
+++ b/sys-cluster/ganglia-webfrontend/ganglia-webfrontend-3.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit webapp depend.php depend.apache
+
+DESCRIPTION="Web front end for ganglia cluster monitoring software"
+HOMEPAGE="http://ganglia.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ganglia/ganglia-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=sys-cluster/ganglia-3"
+
+need_php_httpd
+want_apache
+
+S=${WORKDIR}/ganglia-${PV}/web
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_gd
+}
+
+src_install () {
+ webapp_src_preinst
+
+ dodoc AUTHORS ChangeLog
+ rm -f AUTHORS ChangeLog COPYING Makefile.am
+
+ cp -R . "${D}"/${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf.php
+ webapp_src_install
+}