summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/flyspray/flyspray-0.9.9.3.ebuild')
-rw-r--r--www-apps/flyspray/flyspray-0.9.9.3.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/www-apps/flyspray/flyspray-0.9.9.3.ebuild b/www-apps/flyspray/flyspray-0.9.9.3.ebuild
deleted file mode 100644
index 9dabe12..0000000
--- a/www-apps/flyspray/flyspray-0.9.9.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-# Source: http://bugs.gentoo.org/show_bug.cgi?id=91078
-# Submitted-By: Maciek Ligenza
-# Reviewed-By: rl03 2005-12-10
-
-inherit webapp depend.php depend.apache
-
-DESCRIPTION="Bug Tracking System - easy and less advanced bugzilla replacement"
-HOMEPAGE="http://flyspray.rocks.cc/"
-SRC_URI="http://flyspray.org/${P}.zip"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="~x86"
-
-IUSE="graphviz"
-
-DEPEND="app-arch/unzip"
-RDEPEND="virtual/httpd-cgi
- graphviz? ( media-gfx/graphviz )"
-
-need_php_httpd
-want_apache
-
-pkg_setup() {
- if ! PHPCHECKNODIE="yes" require_php_with_use xml || \
- ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli postgres ; then
- die "Re-install ${PHP_PKG} with xml and at least one of mysql mysqli postgres in USE."
- fi
- webapp_pkg_setup
-}
-
-src_install () {
- webapp_src_preinst
-
- cp -R . "${D}"/${MY_HTDOCSDIR}
-
- dodoc docs/*
- rm -rf "${D}"/${MY_HTDOCSDIR}/docs
-
- webapp_serverowned "${MY_HTDOCSDIR}/attachments"
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
- webapp_configfile ${MY_HTDOCSDIR}/${PN}.conf.php
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
- elog "${PN} requires that you disable safe_mode in PHP. :("
- elog "Is highly reccommended that both magic_quotes and register_globals"
- elog "are set to off due to security reasons."
- use apache2 && elog "Also see the htaccess.dist file."
-}