summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/phpbt/phpbt-1.0.1.ebuild')
-rw-r--r--www-apps/phpbt/phpbt-1.0.1.ebuild44
1 files changed, 24 insertions, 20 deletions
diff --git a/www-apps/phpbt/phpbt-1.0.1.ebuild b/www-apps/phpbt/phpbt-1.0.1.ebuild
index c01b1b5..5d2f5bc 100644
--- a/www-apps/phpbt/phpbt-1.0.1.ebuild
+++ b/www-apps/phpbt/phpbt-1.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@
# Submitted-By: F. Steinel
# Reviewed-By: rl03 2005-12-10
-inherit webapp
+inherit webapp depend.apache depend.php
DESCRIPTION="phpBugTracker, A PHP replacement for bugzilla"
HOMEPAGE="http://phpbt.sourceforge.net/"
@@ -14,34 +14,38 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~x86"
-IUSE="jpgraph"
+IUSE="jpgraph mysql mysqli oci8 postgres"
-RDEPEND="|| ( dev-db/mysql dev-db/postgresql )
- virtual/php
- net-www/apache
- dev-php/PEAR-DB
- jpgraph? ( dev-php/jpgraph )"
+RDEPEND="dev-php/PEAR-DB
+ jpgraph? ( || ( dev-php5/jpgraph dev-php4/jpgraph ) )"
+
+need_php_httpd
+want_apache
pkg_setup() {
+ local flags
+ for i in mysql mysqli oci8 postgres ; do
+ use ${i} && flags="${flags} ${i}"
+ done
+ require_php_with_use ${flags}
webapp_pkg_setup
- einfo "Please make sure your PHP is compiled with PEAR-DB support"
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # make sure we don't clobber existing config.php
- rm config.php
}
src_install () {
+ # make sure we don't clobber existing config.php with empty one
+ rm -f config.php
+ cp config-dist.php config.php
+
webapp_src_preinst
- dodoc CHANGELOG INSTALL README TODO UPGRADING
- dohtml docs/html/*
+ local DOCS="CHANGELOG INSTALL README TODO UPGRADING"
+ dodoc ${DOCS}
+ dohtml -r docs/html/*
+ rm -rf ${DOCS} docs/
- cp -R . ${D}/${MY_HTDOCSDIR}
+ cp -R . "${D}"/${MY_HTDOCSDIR}
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_configfile ${MY_HTDOCSDIR}/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}