summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2015-03-01 11:23:48 -0800
committerMatt Turner <mattst88@gmail.com>2015-03-01 11:23:48 -0800
commit4305e9d51bb7c848f127e2d7d5f3bdb585a13877 (patch)
tree7b1066b69e0f9c34a88cadd901e6dc7f93610bae
parentmedia-libs/mesa: Add bindist restriction. (diff)
downloadx11-4305e9d51bb7c848f127e2d7d5f3bdb585a13877.tar.gz
x11-4305e9d51bb7c848f127e2d7d5f3bdb585a13877.tar.bz2
x11-4305e9d51bb7c848f127e2d7d5f3bdb585a13877.zip
media-libs/llvm: Drop r600-llvm-compiler USE flag.
The flag enabled the R600 LLVM compiler backend for graphics shaders (the LLVM backend is used for OpenCL regardless), but it's disabled by default at build-time and even after you enable it you have to enable it at runtime as well. See http://cgit.freedesktop.org/mesa/mesa/commit/?id=7286739b9beea4683a29fe91850688a07ce23e1a for details.
-rw-r--r--media-libs/mesa/mesa-9999.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 20011776..1add486f 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -43,29 +43,22 @@ done
IUSE="${IUSE_VIDEO_CARDS}
bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
- +nptl opencl osmesa pax_kernel openmax pic r600-llvm-compiler selinux
- +udev vaapi vdpau wayland xvmc xa kernel_FreeBSD"
+ +nptl opencl osmesa pax_kernel openmax pic selinux +udev vaapi vdpau
+ wayland xvmc xa kernel_FreeBSD"
REQUIRED_USE="
d3d9? ( dri3 gallium )
llvm? ( gallium )
- opencl? (
- gallium
- llvm
- video_cards_r600? ( r600-llvm-compiler )
- video_cards_radeon? ( r600-llvm-compiler )
- video_cards_radeonsi? ( r600-llvm-compiler )
- )
+ opencl? ( gallium llvm )
openmax? ( gallium )
gles1? ( egl )
gles2? ( egl )
- r600-llvm-compiler? ( gallium llvm || ( video_cards_r600 video_cards_radeonsi video_cards_radeon ) )
vaapi? ( gallium )
vdpau? ( gallium )
wayland? ( egl gbm )
xa? ( gallium )
video_cards_freedreno? ( gallium )
- video_cards_intel? ( || ( classic ) )
+ video_cards_intel? ( classic )
video_cards_i915? ( || ( classic gallium ) )
video_cards_i965? ( classic )
video_cards_ilo? ( gallium )
@@ -147,7 +140,6 @@ done
DEPEND="${RDEPEND}
${PYTHON_DEPS}
llvm? (
- r600-llvm-compiler? ( sys-devel/llvm[video_cards_radeon] )
video_cards_radeonsi? ( sys-devel/llvm[video_cards_radeon] )
)
opencl? (
@@ -232,7 +224,6 @@ multilib_src_configure() {
$(use_enable d3d9 nine)
$(use_enable llvm gallium-llvm)
$(use_enable openmax omx)
- $(use_enable r600-llvm-compiler)
$(use_enable vaapi va)
$(use_enable vdpau)
$(use_enable xa)