summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-11 00:08:33 +0200
committerMichał Górny <mgorny@gentoo.org>2013-08-11 15:40:53 +0200
commit750600a71007054cdf2f69322be84a7425bf405e (patch)
tree5e32211230e53b4f3f98d85134c19222fbdd038c /dev-libs
parentConvert OpenGL protos to multilib. (diff)
downloadx11-750600a71007054cdf2f69322be84a7425bf405e.tar.gz
x11-750600a71007054cdf2f69322be84a7425bf405e.tar.bz2
x11-750600a71007054cdf2f69322be84a7425bf405e.zip
dev-libs/wayland: Convert to autotools-multilib.
Package-Manager: portage-2.2.0_alpha196
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index 20e4b893..099c4b88 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -8,9 +8,10 @@ if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
GIT_ECLASS="git-2"
EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
fi
-inherit autotools toolchain-funcs $GIT_ECLASS
+inherit autotools-multilib toolchain-funcs $GIT_ECLASS
DESCRIPTION="Wayland protocol libraries"
HOMEPAGE="http://wayland.freedesktop.org/"
@@ -33,19 +34,16 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
virtual/pkgconfig"
-src_prepare() {
- if [[ ${PV} = 9999* ]]; then
- eautoreconf
- fi
-}
-
src_configure() {
- myconf="$(use_enable static-libs static) \
- $(use_enable doc documentation)"
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable doc documentation)
+ )
if tc-is-cross-compiler ; then
- myconf+=" --disable-scanner"
+ myeconfargs+=( --disable-scanner )
fi
- econf ${myconf}
+
+ autotools-multilib_src_configure
}
src_test() {
@@ -53,5 +51,5 @@ src_test() {
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
- default
+ autotools-multilib_src_test
}