summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2013-05-26 20:33:40 +0200
committerChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2013-05-26 20:33:40 +0200
commitd917a072dda6811bf5eb4cdf0687a3c3b943513a (patch)
tree9f0a98dd94ba77ac38d62a8a34c62ea9302389b8 /media-libs
parentmedia-libs/mesa: build ilo only when user explicitly requests it (diff)
downloadx11-d917a072dda6811bf5eb4cdf0687a3c3b943513a.tar.gz
x11-d917a072dda6811bf5eb4cdf0687a3c3b943513a.tar.bz2
x11-d917a072dda6811bf5eb4cdf0687a3c3b943513a.zip
media-libs/mesa: add freedreno support
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index bb75b6b3..44d2e44f 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -42,7 +42,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
INTEL_CARDS="i915 i965 ilo intel"
RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
-VIDEO_CARDS="${INTEL_CARDS} ${RADEON_CARDS} nouveau vmware"
+VIDEO_CARDS="${INTEL_CARDS} ${RADEON_CARDS} freedreno nouveau vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -63,6 +63,7 @@ REQUIRED_USE="
wayland? ( egl )
xa? ( gallium )
xorg? ( gallium )
+ video_cards_freedreno? ( gallium )
video_cards_intel? ( || ( classic gallium ) )
video_cards_i915? ( || ( classic gallium ) )
video_cards_i965? ( classic )
@@ -104,7 +105,7 @@ RDEPEND="
x11-libs/libdrm[libkms]
)
xvmc? ( >=x11-libs/libXvMC-1.0.6 )
- ${LIBDRM_DEPSTRING}[video_cards_nouveau?,video_cards_vmware?]
+ ${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_nouveau?,video_cards_vmware?]
"
for card in ${INTEL_CARDS}; do
RDEPEND="${RDEPEND}
@@ -201,7 +202,7 @@ src_configure() {
driver_enable video_cards_i915 i915
driver_enable video_cards_i965 i965
if ! use video_cards_i915 && \
- ! use video_cards_i965 && \
+ ! use video_cards_i965; then
driver_enable video_cards_intel i915 i965
fi
@@ -249,6 +250,8 @@ src_configure() {
! use video_cards_r600; then
gallium_enable video_cards_radeon r300 r600
fi
+
+ gallium_enable video_cards_freedreno freedreno
# opencl stuff
if use opencl; then
myconf+="