summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2011-10-31 22:15:13 +0100
committerChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2011-10-31 22:15:13 +0100
commita3c32017488b7194093fc0857410221ce0bf4a44 (patch)
treeb6e8165c1100ee7bb445a641cb8d783aa6506d61 /x11-base
parentx11-libs/libxkbcommon: add configure option to allow cross-compiling, patch f... (diff)
downloadx11-a3c32017488b7194093fc0857410221ce0bf4a44.tar.gz
x11-a3c32017488b7194093fc0857410221ce0bf4a44.tar.bz2
x11-a3c32017488b7194093fc0857410221ce0bf4a44.zip
x11-base/wayland: add configure option to allow cross-compiling, patch from Mandeep Singh Baines in bug #385963.
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/wayland/Manifest2
-rw-r--r--x11-base/wayland/wayland-9999.ebuild8
2 files changed, 7 insertions, 3 deletions
diff --git a/x11-base/wayland/Manifest b/x11-base/wayland/Manifest
index 3f8dd1bd..850c4b7f 100644
--- a/x11-base/wayland/Manifest
+++ b/x11-base/wayland/Manifest
@@ -1 +1 @@
-EBUILD wayland-9999.ebuild 552 RMD160 ff9d56315b65b44ea7a3e85df59efe82ae4290a1 SHA1 5ea2f6b29ebbfc81d6a961726a7a2d25e4472995 SHA256 9f269975d7c52b57d9c1a7383ff325f043d5468fb500bcd8f88fedb44dcb8681
+EBUILD wayland-9999.ebuild 670 RMD160 3b0abc8be4b938da5487c50e54df3ce4384e5699 SHA1 0ba1951e6d474f97db826ac8dc477247372f97bc SHA256 cea365962851d1de67af750d03dcf9e5a90cf6aecb4443d423f39150e63b2f30
diff --git a/x11-base/wayland/wayland-9999.ebuild b/x11-base/wayland/wayland-9999.ebuild
index 9efcfcf3..7e722756 100644
--- a/x11-base/wayland/wayland-9999.ebuild
+++ b/x11-base/wayland/wayland-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=4
-inherit git autotools
+inherit git autotools toolchain-funcs
DESCRIPTION="Wayland protocol libraries"
HOMEPAGE="http://wayland.freedesktop.org/"
@@ -24,5 +24,9 @@ src_prepare() {
}
src_configure() {
- econf $(use_enable static-libs static)
+ if tc-is-cross-compiler ; then
+ econf $(use_enable static-libs static) --disable-scanner
+ else
+ econf $(use_enable static-libs static)
+ fi
}