summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-10-14 02:04:38 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2007-10-14 02:04:38 -0700
commitb0f7dd267ecf199858391928498a3dd615b50710 (patch)
treefa983c3b34df77580cf99cec0745aeebd2b3c406 /x11-proto/glproto
parentUpdate warning to rebuild video drivers; don't require pixman git. (diff)
downloadx11-b0f7dd267ecf199858391928498a3dd615b50710.tar.gz
x11-b0f7dd267ecf199858391928498a3dd615b50710.tar.bz2
x11-b0f7dd267ecf199858391928498a3dd615b50710.zip
Add glproto git for xorg-server git, pending a glproto 1.4.9 release.
Diffstat (limited to 'x11-proto/glproto')
-rw-r--r--x11-proto/glproto/Manifest7
-rw-r--r--x11-proto/glproto/files/digest-glproto-99990
-rw-r--r--x11-proto/glproto/glproto-9999.ebuild51
3 files changed, 58 insertions, 0 deletions
diff --git a/x11-proto/glproto/Manifest b/x11-proto/glproto/Manifest
new file mode 100644
index 00000000..044aa7bc
--- /dev/null
+++ b/x11-proto/glproto/Manifest
@@ -0,0 +1,7 @@
+EBUILD glproto-9999.ebuild 1255 RMD160 c14401391185c3fa7b2d7d8ea1595f78fb612f8f SHA1 6d6a0669f2d4e2a31b90741f1cac4d8b3dfc806a SHA256 daaa1b270adf36626f8e72a40bb4ecfa693a6713b838c8294fee1224ba835448
+MD5 b449c5420a6b520373830d825aadd214 glproto-9999.ebuild 1255
+RMD160 c14401391185c3fa7b2d7d8ea1595f78fb612f8f glproto-9999.ebuild 1255
+SHA256 daaa1b270adf36626f8e72a40bb4ecfa693a6713b838c8294fee1224ba835448 glproto-9999.ebuild 1255
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-glproto-9999 0
+RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 files/digest-glproto-9999 0
+SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 files/digest-glproto-9999 0
diff --git a/x11-proto/glproto/files/digest-glproto-9999 b/x11-proto/glproto/files/digest-glproto-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-proto/glproto/files/digest-glproto-9999
diff --git a/x11-proto/glproto/glproto-9999.ebuild b/x11-proto/glproto/glproto-9999.ebuild
new file mode 100644
index 00000000..77b2fb7d
--- /dev/null
+++ b/x11-proto/glproto/glproto-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.8.ebuild,v 1.9 2007/10/09 07:50:11 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org GL protocol headers"
+
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+
+RDEPEND="app-admin/eselect-opengl"
+DEPEND=""
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ switch_opengl_implem
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ for x in "${D}"/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [[ -f ${x} || -L ${x} ]]; then
+ mv -f "${x}" "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}