summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2014-01-19 22:21:46 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2014-01-19 22:21:46 +0400
commit19756779d4538d7d904e8e9f9d713a252a1067be (patch)
tree2780937a4a5a80c7e051330b488151104862dec0 /x11-proto/xcb-proto
parentmedia-libs/mesa: Add gbm to REQUIRED_USE for wayland. (diff)
downloadx11-19756779d4538d7d904e8e9f9d713a252a1067be.tar.gz
x11-19756779d4538d7d904e8e9f9d713a252a1067be.tar.bz2
x11-19756779d4538d7d904e8e9f9d713a252a1067be.zip
[x11-proto/xcb-proto] Version bump per bug #496800 and bug #496802
Package-Manager: portage-2.2.8
Diffstat (limited to 'x11-proto/xcb-proto')
-rw-r--r--x11-proto/xcb-proto/Manifest1
-rw-r--r--x11-proto/xcb-proto/metadata.xml5
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.10.ebuild49
3 files changed, 55 insertions, 0 deletions
diff --git a/x11-proto/xcb-proto/Manifest b/x11-proto/xcb-proto/Manifest
new file mode 100644
index 00000000..681dd476
--- /dev/null
+++ b/x11-proto/xcb-proto/Manifest
@@ -0,0 +1 @@
+DIST xcb-proto-1.10.tar.bz2 138834 SHA256 7ef40ddd855b750bc597d2a435da21e55e502a0fefa85b274f2c922800baaf05 SHA512 b979d6432dcb58b5040a460ecb5285c67d288203768e2b6d032acac6593219dda9f29ae95920bc10b1d9451d928e3295f49d8e457b2bfb69d06481219745c6de WHIRLPOOL aa6905d8d402a5900c37ea411a3818820ec19c90250eb8e86b93e901e0a81f102216e7f2603a851365305c07630c91356b0e827ec85359da9eb8d66c73186830
diff --git a/x11-proto/xcb-proto/metadata.xml b/x11-proto/xcb-proto/metadata.xml
new file mode 100644
index 00000000..01c4c004
--- /dev/null
+++ b/x11-proto/xcb-proto/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-proto/xcb-proto/xcb-proto-1.10.ebuild b/x11-proto/xcb-proto/xcb-proto-1.10.ebuild
new file mode 100644
index 00000000..32f6a40f
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_export_best
+ xorg-2_src_configure
+ #Note: multilib is not supported with python, therefore use only one ABI
+ python_parallel_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ xorg-2_src_compile
+
+ python_foreach_impl autotools-utils_src_compile -C xcbgen \
+ top_builddir="${WORKDIR}/${P}-${ABI:-${DEFAULT_ABI}}"
+}
+
+src_install() {
+ xorg-2_src_install
+
+ python_foreach_impl autotools-utils_src_install -C xcbgen \
+ top_builddir="${WORKDIR}/${P}-${ABI:-${DEFAULT_ABI}}"
+
+ sed -i -e '/pythondir/s:=.*$:=/dev/null:' \
+ "${ED}"/usr/lib*/pkgconfig/xcb-proto.pc || die
+}