summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberger <david.heidelberger@ixit.cz>2014-10-04 22:51:46 +0200
committerDavid Heidelberger <david.heidelberger@ixit.cz>2014-10-04 22:51:46 +0200
commit3f0b6b8db7227fe2c6b51c2a6ac40eaf95cd6640 (patch)
treefae915e184bd99b580e2121cccae5c2ab07be9dd /x11-proto/xcb-proto
parentx11-libs/libxcb: bump 1.11 (diff)
downloadx11-3f0b6b8db7227fe2c6b51c2a6ac40eaf95cd6640.tar.gz
x11-3f0b6b8db7227fe2c6b51c2a6ac40eaf95cd6640.tar.bz2
x11-3f0b6b8db7227fe2c6b51c2a6ac40eaf95cd6640.zip
x11-proto/xcb-proto: bump 1.11
Signed-off-by: David Heidelberger <david.heidelberger@ixit.cz>
Diffstat (limited to 'x11-proto/xcb-proto')
-rw-r--r--x11-proto/xcb-proto/Manifest1
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.11.ebuild64
-rw-r--r--x11-proto/xcb-proto/xcb-proto-9999.ebuild2
3 files changed, 66 insertions, 1 deletions
diff --git a/x11-proto/xcb-proto/Manifest b/x11-proto/xcb-proto/Manifest
new file mode 100644
index 00000000..645e810a
--- /dev/null
+++ b/x11-proto/xcb-proto/Manifest
@@ -0,0 +1 @@
+DIST xcb-proto-1.11.tar.bz2 139213 SHA256 b4aceee6502a0ce45fc39b33c541a2df4715d00b72e660ebe8c5bb444771e32e SHA512 13c228d974f99e2f17a7352629b85c76674e395567474997015941780df123f9c809a76935242aaf31b7836b0478bd557e3cc9161dd4880b4fb8eb576216dbc1 WHIRLPOOL 61bac70a6e2945f881460838352190f77550e647531c5076bf926193490cf38e1e97c879a3da95f1253d5783a54a33ccc91afe39badb27a93150eee5660bd5cc
diff --git a/x11-proto/xcb-proto/xcb-proto-1.11.ebuild b/x11-proto/xcb-proto/xcb-proto-1.11.ebuild
new file mode 100644
index 00000000..19b1bc70
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.11.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_export_best
+ xorg-2_src_configure
+}
+
+multilib_src_configure() {
+ autotools-utils_src_configure
+
+ if multilib_is_native_abi; then
+ python_parallel_foreach_impl autotools-utils_src_configure
+ fi
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_compile -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}
+
+src_install() {
+ xorg-2_src_install
+
+ # pkg-config file hardcodes python sitedir, bug 486512
+ sed -i -e '/pythondir/s:=.*$:=/dev/null:' \
+ "${ED}"/usr/lib*/pkgconfig/xcb-proto.pc || die
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_install -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}
diff --git a/x11-proto/xcb-proto/xcb-proto-9999.ebuild b/x11-proto/xcb-proto/xcb-proto-9999.ebuild
index 818087e2..4ae21106 100644
--- a/x11-proto/xcb-proto/xcb-proto-9999.ebuild
+++ b/x11-proto/xcb-proto/xcb-proto-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
XORG_MULTILIB=yes
inherit python-r1 xorg-2