summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xinit/xinit-9999.ebuild')
-rw-r--r--x11-apps/xinit/xinit-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11-apps/xinit/xinit-9999.ebuild b/x11-apps/xinit/xinit-9999.ebuild
index 42d62352..f8ad4d17 100644
--- a/x11-apps/xinit/xinit-9999.ebuild
+++ b/x11-apps/xinit/xinit-9999.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=3
-inherit xorg-2 pam
+inherit x-modular-r2 pam
DESCRIPTION="X Window System initializer"
@@ -30,12 +30,12 @@ PATCHES=(
)
pkg_setup() {
- xorg-2_pkg_setup
+ x-modular-r2_pkg_setup
CONFIGURE_OPTIONS="--with-xinitdir=/etc/X11/xinit"
}
src_install() {
- xorg-2_src_install
+ x-modular-r2_src_install
exeinto /etc/X11
doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
exeinto /etc/X11/Sessions
@@ -52,7 +52,7 @@ src_install() {
}
pkg_postinst() {
- xorg-2_pkg_postinst
+ x-modular-r2_pkg_postinst
ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
ewarn "any executable. When you run startx, it will run this as the login session."