summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '0006-tools-Drop-gettext-as-a-build-dependency.patch')
-rw-r--r--0006-tools-Drop-gettext-as-a-build-dependency.patch173
1 files changed, 173 insertions, 0 deletions
diff --git a/0006-tools-Drop-gettext-as-a-build-dependency.patch b/0006-tools-Drop-gettext-as-a-build-dependency.patch
new file mode 100644
index 0000000..9aaae10
--- /dev/null
+++ b/0006-tools-Drop-gettext-as-a-build-dependency.patch
@@ -0,0 +1,173 @@
+From 708b0d75e77a8305a756b55eefa0f226212f4d36 Mon Sep 17 00:00:00 2001
+From: Andrew Cooper <andrew.cooper3@citrix.com>
+Date: Fri, 26 Mar 2021 11:25:07 +0000
+Subject: [PATCH 06/13] tools: Drop gettext as a build dependency
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+It has not been a dependency since at least 4.13. Remove its mandatory check
+from ./configure.
+
+Annotate the dependency in the CI dockerfiles, and drop them from CirrusCI and
+TravisCI.
+
+Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com>
+Acked-by: Roger Pau Monné <roger.pau@citrix.com>
+(cherry picked from commit e21a6a4f966a7e91cb0bb014dbe15d15cc0502ad)
+---
+ .cirrus.yml | 2 +-
+ .travis.yml | 1 -
+ README | 1 -
+ tools/configure | 49 ----------------------------------------------
+ tools/configure.ac | 2 --
+ 5 files changed, 1 insertion(+), 54 deletions(-)
+
+diff --git a/.cirrus.yml b/.cirrus.yml
+index 0efff6fa98..fdb1c9c94d 100644
+--- a/.cirrus.yml
++++ b/.cirrus.yml
+@@ -4,7 +4,7 @@ freebsd_template: &FREEBSD_TEMPLATE
+ APPEND_LIB: /usr/local/lib
+ APPEND_INCLUDES: /usr/local/include
+
+- install_script: pkg install -y seabios gettext-tools gmake
++ install_script: pkg install -y seabios gmake
+ pkgconf python libiconv bison perl5
+ yajl lzo2 pixman argp-standalone
+ libxml2 glib git
+diff --git a/.travis.yml b/.travis.yml
+index 2362475f7a..f3cd15b79f 100644
+--- a/.travis.yml
++++ b/.travis.yml
+@@ -54,7 +54,6 @@ addons:
+ - pkg-config
+ - flex
+ - bison
+- - gettext
+ - acpica-tools
+ - bin86
+ - bcc
+diff --git a/README b/README
+index de579080d7..efaa1451cb 100644
+--- a/README
++++ b/README
+@@ -63,7 +63,6 @@ provided by your OS distributor:
+ * bridge-utils package (/sbin/brctl)
+ * iproute package (/sbin/ip)
+ * GNU bison and GNU flex
+- * GNU gettext
+ * ACPI ASL compiler (iasl)
+
+ In addition to the above there are a number of optional build
+diff --git a/tools/configure b/tools/configure
+index bb5acf9d43..5df30df9b3 100755
+--- a/tools/configure
++++ b/tools/configure
+@@ -689,7 +689,6 @@ INSTALL_PROGRAM
+ SET_MAKE
+ AWK
+ IASL
+-XGETTEXT
+ FLEX
+ BISON
+ PERL
+@@ -847,7 +846,6 @@ PYTHON
+ PERL
+ BISON
+ FLEX
+-XGETTEXT
+ AS86
+ LD86
+ BCC
+@@ -1597,7 +1595,6 @@ Some influential environment variables:
+ PERL Path to Perl parser
+ BISON Path to Bison parser generator
+ FLEX Path to Flex lexical analyser generator
+- XGETTEXT Path to xgetttext tool
+ AS86 Path to as86 tool
+ LD86 Path to ld86 tool
+ BCC Path to bcc tool
+@@ -4738,7 +4735,6 @@ LDFLAGS="$PREPEND_LDFLAGS $LDFLAGS $APPEND_LDFLAGS"
+
+
+
+-
+ # Checks for programs.
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
+@@ -7846,51 +7842,6 @@ fi
+
+ if ! $rump; then
+
+-# Extract the first word of "xgettext", so it can be a program name with args.
+-set dummy xgettext; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_path_XGETTEXT+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- case $XGETTEXT in
+- [\\/]* | ?:[\\/]*)
+- ac_cv_path_XGETTEXT="$XGETTEXT" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_XGETTEXT="$as_dir/$ac_word$ac_exec_ext"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+- test -z "$ac_cv_path_XGETTEXT" && ac_cv_path_XGETTEXT="no"
+- ;;
+-esac
+-fi
+-XGETTEXT=$ac_cv_path_XGETTEXT
+-if test -n "$XGETTEXT"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XGETTEXT" >&5
+-$as_echo "$XGETTEXT" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+-
+-if test x"${XGETTEXT}" = x"no"
+-then
+- as_fn_error $? "Unable to find xgettext, please install xgettext" "$LINENO" 5
+-fi
+ case "$host_cpu" in
+ i[3456]86|x86_64|aarch64)
+ # Extract the first word of "iasl", so it can be a program name with args.
+diff --git a/tools/configure.ac b/tools/configure.ac
+index 636e7077be..6414fcbb44 100644
+--- a/tools/configure.ac
++++ b/tools/configure.ac
+@@ -298,7 +298,6 @@ AC_ARG_VAR([PYTHON], [Path to the Python parser])
+ AC_ARG_VAR([PERL], [Path to Perl parser])
+ AC_ARG_VAR([BISON], [Path to Bison parser generator])
+ AC_ARG_VAR([FLEX], [Path to Flex lexical analyser generator])
+-AC_ARG_VAR([XGETTEXT], [Path to xgetttext tool])
+ AC_ARG_VAR([AS86], [Path to as86 tool])
+ AC_ARG_VAR([LD86], [Path to ld86 tool])
+ AC_ARG_VAR([BCC], [Path to bcc tool])
+@@ -381,7 +380,6 @@ AS_IF([test "$cross_compiling" != yes], [
+
+ if ! $rump; then
+
+-AX_PATH_PROG_OR_FAIL([XGETTEXT], [xgettext])
+ dnl as86, ld86, bcc and iasl are only required when the host system is x86*.
+ dnl "host" here means the platform on which the hypervisor and tools is
+ dnl going to run, not the platform on which we are building (known as
+--
+2.40.0
+