summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-02-20 21:05:34 +0100
committerChristoph Mende <angelos@gentoo.org>2011-02-20 21:05:34 +0100
commit0a57768126034856bc9997c9fc1ef015c26b9b51 (patch)
tree7ea2758980a301ccedbe49d4013d211076bef502 /xfce-extra
parentxfwm4: Updated (diff)
downloadxfce-0a57768126034856bc9997c9fc1ef015c26b9b51.tar.gz
xfce-0a57768126034856bc9997c9fc1ef015c26b9b51.tar.bz2
xfce-0a57768126034856bc9997c9fc1ef015c26b9b51.zip
thunar-vfs: Updated
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-vfs/Manifest2
-rw-r--r--xfce-extra/thunar-vfs/thunar-vfs-9999.ebuild57
2 files changed, 25 insertions, 34 deletions
diff --git a/xfce-extra/thunar-vfs/Manifest b/xfce-extra/thunar-vfs/Manifest
index 9b933e4..f1c675c 100644
--- a/xfce-extra/thunar-vfs/Manifest
+++ b/xfce-extra/thunar-vfs/Manifest
@@ -1,2 +1,2 @@
-EBUILD thunar-vfs-9999.ebuild 1387 RMD160 b36be3f9c5b9d05ec07530b6bae360ffdb1e8a42 SHA1 0e572ab91e07db363faeaeab3b585e2d90c63c15 SHA256 40da80cf62945e1477e62d83f33a72571f35eab5a45da1349d4774c16c255ff3
+EBUILD thunar-vfs-9999.ebuild 1338 RMD160 030d7790ec828453bf581bce6022fed9f2acb9d5 SHA1 ab8d681cf804b492318196fa0a1b0869e5cd6a5f SHA256 ff257b6c139891f08f34d4f25d9b0bdcc9a105a1d69ab6e584c05738ffd6bc68
MISC metadata.xml 157 RMD160 d7470fe88d1b96f3a7f1ef26fb7dc646b4a1b907 SHA1 7eae91f2588bdae8667d37a98fb3090d539eeca1 SHA256 44350daa7594842894d676413708d8ea77ccb0017bed24711af5b256281f5e61
diff --git a/xfce-extra/thunar-vfs/thunar-vfs-9999.ebuild b/xfce-extra/thunar-vfs/thunar-vfs-9999.ebuild
index de330a4..2ef8de5 100644
--- a/xfce-extra/thunar-vfs/thunar-vfs-9999.ebuild
+++ b/xfce-extra/thunar-vfs/thunar-vfs-9999.ebuild
@@ -1,61 +1,52 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=3
inherit xfce4
xfce4_core
-DESCRIPTION="Separate package for (old) Thunar VFS libraries"
+DESCRIPTION="Xfce's filesystem libraries (deprecated: don't use this for future development)"
+HOMEPAGE="http://git.xfce.org/xfce/thunar-vfs/"
-KEYWORDS="~amd64 ~x86"
-IUSE="dbus debug doc gnome hal startup-notification"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug gnome startup-notification"
-RDEPEND=">=xfce-base/exo-0.5.1
+RDEPEND=">=xfce-base/exo-0.6
>=dev-libs/glib-2.12:2
>=x11-libs/gtk+-2.10:2
- >=xfce-base/libxfce4util-4.6
- >=media-libs/libpng-1.2
+ >=xfce-base/libxfce4util-4.8
+ >=media-libs/libpng-1.4
>=media-libs/freetype-2
- >=media-libs/jpeg-6b:0
- dbus? ( >=dev-libs/dbus-glib-0.34 )
+ virtual/fam
+ virtual/jpeg
+ dbus? ( >=dev-libs/dbus-glib-0.88 )
gnome? ( >=gnome-base/gconf-2 )
- hal? ( >=dev-libs/dbus-glib-0.34
- sys-apps/hal )
startup-notification? ( >=x11-libs/startup-notification-0.4 )
!<xfce-base/thunar-1.1.0"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
+ dev-util/gtk-doc
dev-util/intltool
sys-devel/gettext
- dev-lang/perl
- dev-util/gtk-doc
- doc? ( dev-libs/libxslt )"
+ dev-lang/perl"
WANT_GTKDOCIZE="yes"
pkg_setup() {
- DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
-
XFCE_CONFIG+=" --disable-dependency-tracking
$(use_enable dbus)
$(use_enable gnome gnome-thumbnailers)
- $(use_enable doc xsltproc)
- $(use_enable debug)
- --with-html-dir=${EPREFIX}/usr/share/doc/${PF}/html"
-
- if use hal; then
- XFCE_CONFIG+=" --enable-dbus --with-volume-manager=hal"
- else
- XFCE_CONFIG+=" --with-volume-manager=none"
- fi
-}
+ $(use_enable startup-notification)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --with-volume-manager=none"
-src_prepare() {
- sed -i \
- -e "/^docdir/s:=.*:= /usr/share/doc/${PF}:" \
- docs/Makefile.am || die
+ DOCS="AUTHORS HACKING NEWS README TODO"
+}
- xfce4_src_prepare
+src_install() {
+ xfce4_src_install \
+ docdir="${EPREFIX}"/usr/share/doc/${PF}
}