summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2023-01-03 09:49:39 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2023-01-03 09:50:46 -0100
commit2c144cecedebd295bbebc352197c74671d7407a3 (patch)
treeb60cee22e7739263dc3fe65a78fbd2d24ce9eed4
parentDrop old ebuild causing QA issues. (diff)
downloadjmbsvicetto-2c144cecedebd295bbebc352197c74671d7407a3.tar.gz
jmbsvicetto-2c144cecedebd295bbebc352197c74671d7407a3.tar.bz2
jmbsvicetto-2c144cecedebd295bbebc352197c74671d7407a3.zip
Several QA fixes.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--eclass/horde-v2.eclass180
-rw-r--r--net-nds/phpldapadmin/metadata.xml5
-rw-r--r--profiles/categories11
-rw-r--r--www-apps/limesurvey/Manifest1
-rw-r--r--www-apps/limesurvey/limesurvey-5.3.22.ebuild58
5 files changed, 63 insertions, 192 deletions
diff --git a/eclass/horde-v2.eclass b/eclass/horde-v2.eclass
deleted file mode 100644
index 63be48d..0000000
--- a/eclass/horde-v2.eclass
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# @ECLASS: horde-v2.eclass
-# @MAINTAINER:
-# Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-# @BLURB: Eclass to install horde project packages
-# @DESCRIPTION:
-# Help manage the horde project http://www.horde.org/
-#
-# Based on the horde eclass:
-# Author: Mike Frysinger <vapier@gentoo.org>
-# CVS additions by Chris Aniszczyk <zx@mea-culpa.net>
-# SNAP additions by Jonathan Polansky <jpolansky@lsit.ucsb.edu>
-#
-# This eclass provides generic functions to make the writing of horde
-# ebuilds fairly trivial since there are many horde applications and
-# they all share the same basic install process.
-
-# @ECLASS-VARIABLE: EHORDE_SNAP
-# @DESCRIPTION:
-# Track whether this a snapshot version or not
-
-# @ECLASS-VARIABLE: EHORDE_SNAP_BRANCH
-# @DESCRIPTION:
-# You set this via the ebuild to whatever branch you wish to grab a
-# snapshot of. Typically this is 'HEAD' or 'RELENG'.
-
-# @ECLASS-VARIABLE: EHORDE_SNAP_PV
-# @DESCRIPTION:
-# The date of the snapshot to fetch
-
-# @ECLASS-VARIABLE: EHORDE_VCS
-# @DESCRIPTION:
-# Track whether this is a live version or not
-
-# This eclass requires at least EAPI-3
-case ${EAPI:-0} in
- 5|4|3) : ;;
- *) die "EAPI=${EAPI} is not supported" ;;
-esac
-
-if [[ ${PV} == *9999 ]]; then
- EHORDE_VCS="git-2"
-fi
-
-inherit webapp eutils php-pear-r1 ${EHORDE_VCS}
-
-HOMEPAGE="http://www.horde.org/${HORDE_PN}"
-LICENSE="LGPL-2"
-
-[[ -z ${HORDE_PN} ]] && HORDE_PN="${PN/horde-}"
-[[ -z ${HORDE_MAJ} ]] && HORDE_MAJ=""
-HORDE_P="${HORDE_PN}-${PV}"
-
-S=${WORKDIR}/${HORDE_PN}${HORDE_MAJ}-${PV/_/-}
-
-case ${PV} in
- *9999)
- EGIT_REPO_URI="git://github.com/horde/${HORDE_PN}"
- SRC_URI=""
- RESTRICT="mirror"
- ;;
- *9998)
- EHORDE_SNAP="true"
- if [[ -z ${EHORDE_SNAP_PV} ]]; then
- let date=$(date +%s)-24*60*60
- EHORDE_SNAP_PV=$(date -d @${date} +%Y-%m-%d)
- fi
-
- SRC_URI="http://ftp.horde.org/pub/snaps/${EHORDE_SNAP_PV}/${HORDE_PN}-git.tar.gz"
- S=${WORKDIR}/${HORDE_PN}
- ;;
- *)
- SRC_URI="http://pear.horde.org/get/${HORDE_P}.tgz"
- ;;
-esac
-
-IUSE="vhosts"
-
-EXPORT_FUNCTIONS pkg_setup src_unpack src_install pkg_postinst
-
-# INSTALL_DIR is used by webapp.eclass when USE=-vhosts
-INSTALL_DIR="/horde"
-[[ ${HORDE_PN} != "horde" && ${HORDE_PN} != "horde-groupware" && ${HORDE_PN} != "horde-webmail" ]] && INSTALL_DIR="${INSTALL_DIR}/${HORDE_PN}"
-
-HORDE_APPLICATIONS="${HORDE_APPLICATIONS} ."
-
-horde-v2_pkg_setup() {
- webapp_pkg_setup
-}
-
-horde-v2_src_unpack() {
- if [[ -n ${EHORDE_VCS} ]] ; then
- ${EHORDE_VCS}_src_unpack
- else
- unpack ${A}
- fi
- cd "${S}"
-
- [[ -n ${EHORDE_PATCHES} ]] && epatch ${EHORDE_PATCHES}
-
- for APP in ${HORDE_APPLICATIONS}
- do
- [[ -f ${APP}/test.php ]] && chmod 000 ${APP}/test.php
- done
-}
-
-horde-v2_src_install() {
- webapp_src_preinst
-
- local destdir=${MY_HTDOCSDIR}
-
- # Work-around when dealing with live sources
- [[ -n ${EHORDE_VCS} ]] && cd ${HORDE_PN}
-
- # Install docs and then delete them (except for CREDITS which
- # many horde apps include in their help page #121003)
- dodoc README docs/*
- mv docs/CREDITS "${T}"/
- rm -rf COPYING LICENSE README docs/*
- mv "${T}"/CREDITS docs/
-
- dodir ${destdir}
- cp -r . "${D}"/${destdir}/ || die "install files"
-
- for APP in ${HORDE_APPLICATIONS}
- do
- for DISTFILE in ${APP}/config/*.dist
- do
- if [[ -f ${DISTFILE/.dist/} ]] ; then
- webapp_configfile "${MY_HTDOCSDIR}"/${DISTFILE/.dist/}
- fi
- done
- if [[ -f ${APP}/config/conf.php ]] ; then
- webapp_serverowned "${MY_HTDOCSDIR}"/${APP}/config/conf.php
- webapp_configfile "${MY_HTDOCSDIR}"/${APP}/config/conf.php
- fi
- done
-
- [[ -n ${HORDE_RECONFIG} ]] && webapp_hook_script ${HORDE_RECONFIG}
- [[ -n ${HORDE_POSTINST} ]] && webapp_postinst_txt en ${HORDE_POSTINST}
-
- webapp_src_install
-}
-
-horde-v2_pkg_postinst() {
- if [ -e ${ROOT}/usr/share/doc/${PF}/INSTALL* ] ; then
- elog "Please read the INSTALL file in /usr/share/doc/${PF}."
- fi
-
- einfo "Before this package will work, you have to setup the configuration files."
- einfo "Please review the config/ subdirectory of ${HORDE_PN} in the webroot."
-
- if [ -e ${ROOT}/usr/share/doc/${PF}/SECURITY* ] ; then
- ewarn
- ewarn "Users are HIGHLY recommended to consult the SECURITY guide in"
- ewarn "/usr/share/doc/${PF} before going into production with Horde."
- fi
-
- if [[ ${HORDE_PN} != "horde" && ${HORDE_PN} != "horde-groupware" && ${HORDE_PN} != "horde-webmail" ]] ; then
- ewarn
- ewarn "Make sure ${HORDE_PN} is accounted for in Horde\'s root"
- ewarn " config/registry.php"
- fi
-
- if [[ -n ${EHORDE_VCS} ]] ; then
- ewarn
- ewarn "Use these live versions at your own risk."
- ewarn "They tend to break things when working with the non live versions of horde."
- fi
-
- if use vhosts ; then
- ewarn
- ewarn "When installing Horde into a vhost dir, you will need to use the"
- ewarn "-d option so that it is installed into the proper location."
- fi
-
- webapp_pkg_postinst
-}
diff --git a/net-nds/phpldapadmin/metadata.xml b/net-nds/phpldapadmin/metadata.xml
index 79c647a..784fca0 100644
--- a/net-nds/phpldapadmin/metadata.xml
+++ b/net-nds/phpldapadmin/metadata.xml
@@ -9,10 +9,7 @@
<email>web-apps@gentoo.org</email>
<name>Gentoo Webapps</name>
</maintainer>
- <longdescription>
- phpLDAPadmin is a web-based tool for managing all aspects of your LDAP server.
-</longdescription>
<upstream>
- <remote-id type="sourceforge">phpldapadmin</remote-id>
+ <remote-id type="github">leenooks/phpLDAPadmin</remote-id>
</upstream>
</pkgmetadata>
diff --git a/profiles/categories b/profiles/categories
index f9195e8..ee73d62 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1,13 +1,8 @@
app-admin
-app-misc
-dev-perl
-dev-php
-dev-python
-games-strategy
+dev-db
net-analyzer
net-misc
-sci-geosciences
-www-apache
+net-nds
+net-vpn
www-apps
www-misc
-www-servers
diff --git a/www-apps/limesurvey/Manifest b/www-apps/limesurvey/Manifest
index 78c3807..7cf2f1f 100644
--- a/www-apps/limesurvey/Manifest
+++ b/www-apps/limesurvey/Manifest
@@ -4,3 +4,4 @@ DIST limesurvey-2.57.1.tar.gz 75910330 SHA256 10dd9675eb7e02873d45a147f1a695faac
DIST limesurvey-2.63.1.tar.gz 73655219 SHA256 6165b7fbaae9dbcd7ff28a734889439fdcd60a40bdaf01a0fe23a3d323d0874a SHA512 e6a72ff5b4d5fa53cc8092f02cb6321d427ec9c7067dbb301b055249a42c6238b159b2d580b63955245cc22728ef2453ef4e60884cc254aa98b81f661466384e WHIRLPOOL 03c23cbf40d3f0e5cfd68343d23e858268e83f277beeec9e8ffdb26890057e019c30bc4e657b5f780ef0027d9cd9637c8ad1c70b038f728d2fb2366bb7e2cfec
DIST limesurvey-2.64.1.tar.gz 29598 SHA256 5e1ec9035ca4213c0107b177085d033bd8832bcfbac292a049a1220ca0abf483 SHA512 3cdf4677e7bf0cf51f2038c9fc2d9e63c4223a034e6e29baf41f85029197dbdffd07d1cc2bdfde6dd410511068be8272e5e0bede67fef378beb90b70dc0285f9 WHIRLPOOL ed3c52b592eccd703c31fed152a54494ef95451771ca7e167976b632f736879cc9387916e7cf114fc441f158ce2bccef19735118ebb02defe2f0d9f2ede471e9
DIST limesurvey-2.72.5.tar.gz 75156451 SHA256 35aee519db72aede8f677bfcbaeaa332c50ca4095d4ba4d34ae51f7f660bad67 SHA512 2c1c388b2e4d7faa267adc04e04ca0f0d5984d61b7ea02be01af865fcafefa1513550ec35db5e2093d0e1f1a42e0c3480f83a8aa21b35599814e903b69c3303f WHIRLPOOL 4ee9cce6672173ecc2c084be3a4559ab4305be2c82c6fca88da3b31c27f194ea937dc3c00b0e505ed2bad746a3aeeff26d484abeb585bebb6261c2b3dc8bd9b4
+DIST limesurvey5.3.22+220628.zip 83649913 BLAKE2B c769828e67e3f22c277f7e3feb1f7cb7dd4c420b6f7a5ada264a9c26e7ac99806b6599b50fa8776077e8e7d32802eda98eac75ea23f9376af9d1500ccad3dc94 SHA512 747c05ea9bf65c3231afa8e2a0c10500b5ee8081e572d5e6609f5a5314b738606c4d90d57047039cbe84027a26f5e9d814ea12a3e61747cca8683a39186ef555
diff --git a/www-apps/limesurvey/limesurvey-5.3.22.ebuild b/www-apps/limesurvey/limesurvey-5.3.22.ebuild
new file mode 100644
index 0000000..846a7d9
--- /dev/null
+++ b/www-apps/limesurvey/limesurvey-5.3.22.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN="LimeSurvey"
+MY_DATE="220628"
+MY_PV="${PV}+${MY_DATE}"
+
+DESCRIPTION="LimeSurvey is a popular Free Open Source Software survey tool"
+HOMEPAGE="https://www.limesurvey.org/"
+#SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://download.limesurvey.org/latest-stable-release/$PN$MY_PV.zip"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gd ldap mssql mysql postgres zip"
+REQUIRED_USE="^^ ( mssql mysql postgres )"
+
+DEPEND="
+ app-admin/webapp-config
+"
+RDEPEND="
+ dev-lang/php[gd?,hash,ldap?,session,zip?,zlib]
+ mssql? ( dev-lang/php[mssql] )
+ mysql? ( dev-lang/php[mysqli] )
+ postgres? ( dev-lang/php[postgres] )
+"
+S="${WORKDIR}/${MY_PN}-${PV}-${MY_DATE}"
+
+pkg_config () {
+
+ webapp_pkg_setup
+}
+
+src_install () {
+
+ webapp_src_preinst
+
+ einfo "Installing files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}
+
+pkg_preinst () {
+
+ fowners -R root:apache "${MY_HTDOCSDIR}"
+ fperms -R g-w,o-rwx "${MY_HTDOCSDIR}"
+
+ # Allow writing to the tmp, upload and application/config directories
+ for dir in tmp upload application/config ; do
+
+ fperms -R g+w "${MY_HTDOCSDIR}/${dir}"
+ done
+}