summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-12-01 20:01:25 +0100
committerMichał Górny <mgorny@gentoo.org>2011-12-01 20:01:25 +0100
commit821cc1f6cbafb8d559e63d13879fc1ce11f10ed0 (patch)
tree2b4bccabc7d269e264136ec71840e9da545924d4
parentautotools-utils: rewrite some more autotools code to make it faster. (diff)
downloadmgorny-821cc1f6cbafb8d559e63d13879fc1ce11f10ed0.tar.gz
mgorny-821cc1f6cbafb8d559e63d13879fc1ce11f10ed0.tar.bz2
mgorny-821cc1f6cbafb8d559e63d13879fc1ce11f10ed0.zip
Update the ebuilds for testing autotools-utils code.
-rw-r--r--app-cdr/mirage2iso/mirage2iso-9999.ebuild12
-rw-r--r--app-portage/repo-commit/repo-commit-9999.ebuild12
-rw-r--r--dev-dotnet/pe-format/pe-format-2.9999.ebuild12
-rw-r--r--dev-util/atomic-install/atomic-install-9999.ebuild13
-rw-r--r--net-im/ekg2/ekg2-9999.ebuild15
-rw-r--r--net-misc/autoupnp/autoupnp-9999.ebuild12
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild12
-rw-r--r--sys-apps/uam/uam-9999.ebuild14
-rw-r--r--sys-devel/ccattr/ccattr-9999.ebuild13
-rw-r--r--sys-devel/systemd-sdk/systemd-sdk-9999.ebuild12
-rw-r--r--www-servers/pshs/pshs-9999.ebuild12
-rw-r--r--x11-libs/libtinynotify-cli/libtinynotify-cli-9999.ebuild23
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild13
-rw-r--r--x11-libs/libtinynotify/libtinynotify-9999.ebuild13
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-9999.ebuild21
-rw-r--r--x11-misc/tinynotify-send/tinynotify-send-9999.ebuild13
16 files changed, 89 insertions, 133 deletions
diff --git a/app-cdr/mirage2iso/mirage2iso-9999.ebuild b/app-cdr/mirage2iso/mirage2iso-9999.ebuild
index 7618dcf..f9aceb2 100644
--- a/app-cdr/mirage2iso/mirage2iso-9999.ebuild
+++ b/app-cdr/mirage2iso/mirage2iso-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="CD/DVD image converter using libmirage"
HOMEPAGE="https://github.com/mgorny/mirage2iso/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -36,11 +39,6 @@ DEPEND="${DEPEND}
dev-libs/libassuan"
KEYWORDS=
SRC_URI=
-
-src_prepare() {
- autotools-utils_src_prepare
- eautoreconf
-}
#endif
src_configure() {
diff --git a/app-portage/repo-commit/repo-commit-9999.ebuild b/app-portage/repo-commit/repo-commit-9999.ebuild
index 3bfd579..15b7728 100644
--- a/app-portage/repo-commit/repo-commit-9999.ebuild
+++ b/app-portage/repo-commit/repo-commit-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="A repository commit helper"
HOMEPAGE="https://github.com/mgorny/repo-commit/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -26,9 +29,4 @@ RDEPEND="app-portage/gentoolkit-dev
KEYWORDS=
SRC_URI=
-
-src_prepare() {
- autotools-utils_src_prepare
- eautoreconf
-}
#endif
diff --git a/dev-dotnet/pe-format/pe-format-2.9999.ebuild b/dev-dotnet/pe-format/pe-format-2.9999.ebuild
index fc5fe85..7ab5a15 100644
--- a/dev-dotnet/pe-format/pe-format-2.9999.ebuild
+++ b/dev-dotnet/pe-format/pe-format-2.9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils systemd
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}2.git
http://github.com/mgorny/${PN}2.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils systemd
+
DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
HOMEPAGE="https://github.com/mgorny/pe-format2/"
SRC_URI="mirror://github/mgorny/${PN}2/${P}.tar.bz2"
@@ -27,11 +30,6 @@ KEYWORDS=
SRC_URI=
DEPEND="sys-devel/systemd-sdk"
-
-src_prepare() {
- autotools-utils_src_prepare
- eautoreconf
-}
#endif
src_configure() {
diff --git a/dev-util/atomic-install/atomic-install-9999.ebuild b/dev-util/atomic-install/atomic-install-9999.ebuild
index 2357148..99d7d75 100644
--- a/dev-util/atomic-install/atomic-install-9999.ebuild
+++ b/dev-util/atomic-install/atomic-install-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="A library and tool to atomically install sets of files"
HOMEPAGE="https://github.com/mgorny/atomic-install/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -29,12 +32,6 @@ KEYWORDS=
SRC_URI=
DEPEND="${DEPEND}
>=dev-util/gtk-doc-1.18"
-
-src_prepare() {
- autotools-utils_src_prepare
- autotools_run_tool gtkdocize
- eautoreconf
-}
#endif
src_configure() {
diff --git a/net-im/ekg2/ekg2-9999.ebuild b/net-im/ekg2/ekg2-9999.ebuild
index 7cb5826..91784f6 100644
--- a/net-im/ekg2/ekg2-9999.ebuild
+++ b/net-im/ekg2/ekg2-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/leafnode/${PN}.git
http://github.com/leafnode/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="Text-based, multi-protocol instant messenger"
HOMEPAGE="http://www.ekg2.org"
SRC_URI="http://pl.ekg2.org/${P}.tar.gz"
@@ -65,14 +68,6 @@ pkg_pretend() {
fi
}
-#if LIVE
-src_prepare() {
- autotools-utils_src_prepare
- eautopoint
- eautoreconf
-}
-#endif
-
src_configure() {
myeconfargs=(
# direct plugin references
diff --git a/net-misc/autoupnp/autoupnp-9999.ebuild b/net-misc/autoupnp/autoupnp-9999.ebuild
index ee68886..e054eb2 100644
--- a/net-misc/autoupnp/autoupnp-9999.ebuild
+++ b/net-misc/autoupnp/autoupnp-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="Automatic open port forwarder using UPnP"
HOMEPAGE="https://github.com/mgorny/autoupnp/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -29,11 +32,6 @@ DOCS=( README )
#if LIVE
KEYWORDS=
SRC_URI=
-
-src_prepare() {
- autotools-utils_src_prepare
- eautoreconf
-}
#endif
src_configure() {
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 5cc5c8d..b113b73 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -4,14 +4,16 @@
EAPI=4
-inherit autotools-utils bash-completion-r1 linux-info pam systemd
-
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}
http://cgit.freedesktop.org/${PN}/"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils bash-completion-r1 linux-info pam systemd
+
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.bz2"
@@ -75,10 +77,6 @@ src_prepare() {
# Force the rebuild of .vala sources
touch src/*.vala || die
autotools-utils_src_prepare
-#if LIVE
- autotools_run_tool intltoolize
- eautoreconf
-#endif
}
src_configure() {
diff --git a/sys-apps/uam/uam-9999.ebuild b/sys-apps/uam/uam-9999.ebuild
index bf4b5cc..454a6c8 100644
--- a/sys-apps/uam/uam-9999.ebuild
+++ b/sys-apps/uam/uam-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils eutils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils eutils
+
DESCRIPTION="Simple udev-based automounter for removable USB media"
HOMEPAGE="https://github.com/mgorny/uam/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -30,13 +33,6 @@ KEYWORDS=
SRC_URI=
#endif
-#if LIVE
-src_prepare() {
- autotools-utils_src_prepare
- eautoreconf
-}
-#endif
-
src_configure() {
myeconfargs=(
--libdir=/lib
diff --git a/sys-devel/ccattr/ccattr-9999.ebuild b/sys-devel/ccattr/ccattr-9999.ebuild
index 36de742..117f696 100644
--- a/sys-devel/ccattr/ccattr-9999.ebuild
+++ b/sys-devel/ccattr/ccattr-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="Macros for simple and portable use of CC extension attributes"
HOMEPAGE="https://github.com/mgorny/ccattr/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -27,12 +30,6 @@ DEPEND="${DEPEND}
dev-util/gtk-doc-am"
KEYWORDS=
SRC_URI=
-
-src_prepare() {
- autotools-utils_src_prepare
- autotools_run_tool gtkdocize
- eautoreconf
-}
#endif
src_configure() {
diff --git a/sys-devel/systemd-sdk/systemd-sdk-9999.ebuild b/sys-devel/systemd-sdk/systemd-sdk-9999.ebuild
index a1ed8be..176c82a 100644
--- a/sys-devel/systemd-sdk/systemd-sdk-9999.ebuild
+++ b/sys-devel/systemd-sdk/systemd-sdk-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="Macros and misc files for systemd daemons"
HOMEPAGE="https://github.com/mgorny/systemd-sdk/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -23,9 +26,4 @@ IUSE=""
KEYWORDS=
SRC_URI=
-
-src_prepare() {
- autotools-utils_src_prepare
- eautoreconf
-}
#endif
diff --git a/www-servers/pshs/pshs-9999.ebuild b/www-servers/pshs/pshs-9999.ebuild
index 12ae0a4..d534a63 100644
--- a/www-servers/pshs/pshs-9999.ebuild
+++ b/www-servers/pshs/pshs-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
HOMEPAGE="https://github.com/mgorny/pshs/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -31,11 +34,6 @@ DEPEND="${RDEPEND}
#if LIVE
KEYWORDS=
SRC_URI=
-
-src_prepare() {
- autotools-utils_src_prepare
- eautoreconf
-}
#endif
src_configure() {
diff --git a/x11-libs/libtinynotify-cli/libtinynotify-cli-9999.ebuild b/x11-libs/libtinynotify-cli/libtinynotify-cli-9999.ebuild
index eac88aa..04dd3d9 100644
--- a/x11-libs/libtinynotify-cli/libtinynotify-cli-9999.ebuild
+++ b/x11-libs/libtinynotify-cli/libtinynotify-cli-9999.ebuild
@@ -3,17 +3,20 @@
# $Header: $
EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="git://github.com/mgorny/tinynotify-send.git
+ http://github.com/mgorny/tinynotify-send.git"
+
+inherit git-2
+#endif
+
inherit autotools-utils
MY_PN=tinynotify-send
MY_P=${MY_PN}-${PV}
-#if LIVE
-EGIT_REPO_URI="git://github.com/mgorny/${MY_PN}.git
- http://github.com/mgorny/${MY_PN}.git"
-inherit autotools git-2
-#endif
-
DESCRIPTION="Common CLI routines for tinynotify-send & sw-notify-send"
HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
SRC_URI="mirror://github/mgorny/${MY_PN}/${MY_P}.tar.bz2"
@@ -36,16 +39,10 @@ KEYWORDS=
SRC_URI=
DEPEND="${DEPEND}
>=dev-util/gtk-doc-1.18"
-
-src_prepare() {
- autotools-utils_src_prepare
- autotools_run_tool gtkdocize
- eautoreconf
-}
#endif
src_configure() {
- myeconfargs=(
+ local myeconfargs=(
$(use_enable doc gtk-doc)
--disable-regular
--disable-system-wide
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
index a5ca5ca..57edf7f 100644
--- a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="A system-wide notifications module for libtinynotify"
HOMEPAGE="https://github.com/mgorny/libtinynotify-systemwide/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -33,12 +36,6 @@ KEYWORDS=
SRC_URI=
DEPEND="${DEPEND}
>=dev-util/gtk-doc-1.18"
-
-src_prepare() {
- autotools-utils_src_prepare
- autotools_run_tool gtkdocize
- eautoreconf
-}
#endif
src_configure() {
diff --git a/x11-libs/libtinynotify/libtinynotify-9999.ebuild b/x11-libs/libtinynotify/libtinynotify-9999.ebuild
index e404afc..e1fbdd0 100644
--- a/x11-libs/libtinynotify/libtinynotify-9999.ebuild
+++ b/x11-libs/libtinynotify/libtinynotify-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
HOMEPAGE="https://github.com/mgorny/libtinynotify/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -32,12 +35,6 @@ KEYWORDS=
SRC_URI=
DEPEND="${DEPEND}
>=dev-util/gtk-doc-1.18"
-
-src_prepare() {
- autotools-utils_src_prepare
- autotools_run_tool gtkdocize
- eautoreconf
-}
#endif
src_configure() {
diff --git a/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
index fa40aad..ea083d0 100644
--- a/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
+++ b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
@@ -3,17 +3,20 @@
# $Header: $
EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="git://github.com/mgorny/tinynotify-send.git
+ http://github.com/mgorny/tinynotify-send.git"
+
+inherit git-2
+#endif
+
inherit autotools-utils
MY_PN=tinynotify-send
MY_P=${MY_PN}-${PV}
-#if LIVE
-EGIT_REPO_URI="git://github.com/mgorny/${MY_PN}.git
- http://github.com/mgorny/${MY_PN}.git"
-inherit autotools git-2
-#endif
-
DESCRIPTION="A system-wide variant of tinynotify-send"
HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
SRC_URI="mirror://github/mgorny/${MY_PN}/${MY_P}.tar.bz2"
@@ -37,12 +40,6 @@ KEYWORDS=
SRC_URI=
DEPEND="${DEPEND}
dev-util/gtk-doc"
-
-src_prepare() {
- autotools-utils_src_prepare
- autotools_run_tool gtkdocize
- eautoreconf
-}
#endif
src_configure() {
diff --git a/x11-misc/tinynotify-send/tinynotify-send-9999.ebuild b/x11-misc/tinynotify-send/tinynotify-send-9999.ebuild
index 881ac2a..141e6e3 100644
--- a/x11-misc/tinynotify-send/tinynotify-send-9999.ebuild
+++ b/x11-misc/tinynotify-send/tinynotify-send-9999.ebuild
@@ -3,14 +3,17 @@
# $Header: $
EAPI=4
-inherit autotools-utils
#if LIVE
+AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="git://github.com/mgorny/${PN}.git
http://github.com/mgorny/${PN}.git"
-inherit autotools git-2
+
+inherit git-2
#endif
+inherit autotools-utils
+
DESCRIPTION="A notification sending utility (using libtinynotify)"
HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
@@ -33,12 +36,6 @@ KEYWORDS=
SRC_URI=
DEPEND="${DEPEND}
dev-util/gtk-doc"
-
-src_prepare() {
- autotools-utils_src_prepare
- autotools_run_tool gtkdocize
- eautoreconf
-}
#endif
src_configure() {