summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-05-13 16:35:15 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-05-13 16:35:15 -0500
commitc2d0d989c57e0c2ec1256666c8cdeab3006c201b (patch)
tree89d610592f04105eeb4dea4f9623dd8fde14cef9
parentapp-crypt/lazy-random: update ebuild (diff)
downloadtamiko-c2d0d989c57e0c2ec1256666c8cdeab3006c201b.tar.gz
tamiko-c2d0d989c57e0c2ec1256666c8cdeab3006c201b.tar.bz2
tamiko-c2d0d989c57e0c2ec1256666c8cdeab3006c201b.zip
sys-apps/likwid: update EAPI 6 -> 8
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sys-apps/likwid/Manifest1
-rw-r--r--sys-apps/likwid/likwid-5.2.1-r50.ebuild147
2 files changed, 148 insertions, 0 deletions
diff --git a/sys-apps/likwid/Manifest b/sys-apps/likwid/Manifest
index 67808c4..cef42f0 100644
--- a/sys-apps/likwid/Manifest
+++ b/sys-apps/likwid/Manifest
@@ -1,2 +1,3 @@
DIST likwid-5.1.1.tar.gz 2226404 SHA256 faec7c62987967232f476a6ff0ee85af686fd24b5a360126896b7f435d1f943f SHA512 6f78f57ffddbc12c4861945b5aece86f94b1086911ff2972e1bb5fed08f263c57e73dd278f0d146a9ca3438159b14a8b5431f281972842269fc2f5adb52de6c1 WHIRLPOOL 349206045b365b2363618feb0f609852ac7d01c00e46488a172de3d4ba84d0140fdb2bd36f39473c65fc27420def598836e4e7bd30d9f0ac8ceb3b162ebadf7f
DIST likwid-5.2.0.tar.gz 2299164 SHA256 aa6dccacfca59e52d8f3be187ffcf292b2a2fa1f51a81bf8912b9d48e5a257e0 SHA512 f69e44d51b8576db4af76395b5d0620660d9225e3114531b2d5822727f9bceb271ec99853a0f9e14ae4959a3d6f159c832cc0892101ddd12eb1c77a03f744e1f WHIRLPOOL f50138c7c5cd1b477b174613a4c0c56f3df3c26a5ec842d9969d0d99beffc8412e16e1ef341a90218f0ae648d84c67052808b53cad91cbe24b574e3abdf97a8e
+DIST likwid-5.2.1.tar.gz 2308041 SHA256 1b8e668da117f24302a344596336eca2c69d2bc2f49fa228ca41ea0688f6cbc2 SHA512 f096dcc071e976284c874aeb254dcb83c66ae808876a8c6be7b05e359d06800f1da25c01c072950c3493eb9ca10f6f9d81624feef61cc7a01f40fc0d003f98a7 WHIRLPOOL e06a570674a1333481fb97796878eeeedda489dd53204b2eda25b64ce5e88d63f6436efe2ffe1ece0236b39e72df3b0ec12d51d48eb7f91ccabc8c5306ce7e89
diff --git a/sys-apps/likwid/likwid-5.2.1-r50.ebuild b/sys-apps/likwid/likwid-5.2.1-r50.ebuild
new file mode 100644
index 0000000..499f382
--- /dev/null
+++ b/sys-apps/likwid/likwid-5.2.1-r50.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+
+inherit fcaps fortran-2 linux-info toolchain-funcs
+
+DESCRIPTION="A performance-oriented tool suite for x86 multicore environments"
+HOMEPAGE="https://github.com/rrze-likwid/likwid"
+SRC_URI="https://ftp.fau.de/pub/likwid/${P}.tar.gz"
+
+LICENSE="GPL-3+ BSD MIT"
+
+SLOT="0"
+KEYWORDS="~amd64" # upstream partial support exists for x86 arm arm64
+IUSE="fortran"
+
+CDEPEND="dev-lang/perl"
+
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}"
+
+CONFIG_CHECK="~X86_MSR"
+
+FILECAPS=(
+ -M 755 cap_sys_rawio+ep usr/sbin/likwid-accessD
+ --
+ -M 755 cap_sys_rawio+ep usr/sbin/likwid-setFreq
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.3.1-fix-gnustack.patch"
+)
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ # Ensure we build with a non executable stack
+ sed \
+ -e '/^SHARED_CFLAGS/s/$/ -Wa,--noexecstack/' \
+ -i make/include_{GCC*,CLANG}.mk \
+ || die "Failed to set nonexecstack"
+
+ # Make the install targets respect Q= for being quiet or not
+ # MUCH easier for debugging
+ sed -r \
+ -e '/^install/,/^[a-z]/{/^\t@/{ s/@/$(Q)/; }}' \
+ -i \
+ Makefile || die "Failed to sed Makefile"
+
+ sed -i \
+ -e '/^\.NOTPARALLEL:/d' \
+ Makefile \
+ bench/Makefile \
+ ext/hwloc/Makefile || die "Failed to re-enable parallel"
+
+ default
+}
+
+export_emake_opts() {
+ # Warning: this build system uses PREFIX in a way that differs from
+ # autoconf! It's more like:
+ # PREFIX=$(DESTDIR)$(INSTALLED_PREFIX)
+ # it's not 100% like that, because parts of the Makefiles are inconsistent.
+ # this is the same solution used in the upstream RPM specs
+ # these variables are uppercase so they match what's put into Make.
+ local INSTALLED_PREFIX=/usr
+ local INSTALLED_LIBPREFIX=/usr/$(get_libdir) # upstream is '$(INSTALLED_PREFIX)/lib'
+ local INSTALLED_MANPREFIX=/usr/share/man # upstream has it as used but undefined variable.
+ # If the build is too loud, pass 'Q=@'
+ src_compile_opts=(
+ "Q="
+ "INSTALLED_PREFIX=${INSTALLED_PREFIX}"
+ "INSTALLED_LIBPREFIX=${INSTALLED_LIBPREFIX}"
+ "INSTALLED_MANPREFIX=${INSTALLED_MANPREFIX}"
+ "PREFIX=${INSTALLED_PREFIX}"
+ "LIBPREFIX=${INSTALLED_LIBPREFIX}"
+ "MANPREFIX=${INSTALLED_MANPREFIX}"
+ "CC=$(tc-getCC)"
+ "ANSI_CFLAGS=${CFLAGS}"
+ "INSTRUMENT_BENCH=true"
+ "FORTRAN_INTERFACE=$(usex fortran likwid.mod false)"
+ "FC=$(usex fortran "${FC}" false)"
+ "FCFLAGS=-J ./ -fsyntax-only" # needed for building correctly
+ )
+ src_install_opts=(
+ "PREFIX=${D}${INSTALLED_PREFIX}"
+ "LIBPREFIX=${D}${INSTALLED_LIBPREFIX}"
+ "MANPREFIX=${D}${INSTALLED_MANPREFIX}"
+ )
+}
+
+src_compile() {
+ export_emake_opts
+ emake \
+ "${src_compile_opts[@]}" \
+ || die 'emake failed'
+}
+
+src_install () {
+ export_emake_opts
+ emake \
+ "${src_compile_opts[@]}" \
+ "${src_install_opts[@]}" \
+ DESTDIR="${D}" \
+ install || die 'emake install failed'
+
+ use fortran && doheader likwid.mod
+
+ # Fix Python filter added shortly after 4.3.3
+ #python_fix_shebang "${D}"/usr/share/likwid/filter/
+
+ # Do NOT use 'doman'! The upstream 'make install' target does a sed as it's
+ # generating the final manpage to the real install dir; and the copies in
+ # ${S} are unmodified.
+ dodoc README.md CHANGELOG
+ dodoc doc/*.txt
+ dodoc doc/*.md
+ dodoc -r doc/applications doc/archs
+ # Fix upstream partial doc install
+ rm -rf "${D}"/usr/share/likwid/docs || die
+ ln -sf "/usr/share/doc/${PF}" "${D}"/usr/share/likwid/docs || die
+}
+
+pkg_preinst() {
+ # This is now a symlink, but used to be a plain directory
+ OLDDOCDIR=/usr/share/likwid/docs
+ if [[ ! -L "${OLDDOCDIR}" && -d "${OLDDOCDIR}" ]]; then
+ einfo "Cleaning up old docdir at ${OLDDOCDIR}"
+ rm -rf "${OLDDOCDIR}" || die
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ einfo "If you get 'Cannot gather values from MSR_PLATFORM_INFO', then 'modprobe msr'!"
+ einfo
+ ewarn "To enable users to access performance counters it is necessary to"
+ ewarn "change the access permissions to /dev/cpu/msr[0]* devices."
+ ewarn "It can be accomplished by adding the following line to file"
+ ewarn "/etc/udev/rules.d/99-myrules.rules: KERNEL==\"msr[0-9]*\" MODE=\"0666\""
+ ewarn "Alternatively, assign the MSR files to a unique group and use mode 0660"
+}